aboutsummaryrefslogtreecommitdiff
path: root/biology/rainbow
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2018-04-02 16:50:46 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2018-04-02 16:50:46 +0000
commit69f9d7e451312560b4485ddfa75b4d3a63a448a4 (patch)
tree25b7473f6ca60d44b3fbcf8cbc1bcf3045a84458 /biology/rainbow
parentae3f123f18044a50fec073fc127b9a2e93e6ec4f (diff)
downloadports-69f9d7e451312560b4485ddfa75b4d3a63a448a4.tar.gz
ports-69f9d7e451312560b4485ddfa75b4d3a63a448a4.zip
biology/rainbow: Efficient clustering and assembling of short reads
Approved by: jrm (mentor) Differential Revision: https://reviews.freebsd.org/D14924
Notes
Notes: svn path=/head/; revision=466235
Diffstat (limited to 'biology/rainbow')
-rw-r--r--biology/rainbow/Makefile26
-rw-r--r--biology/rainbow/distinfo3
-rw-r--r--biology/rainbow/files/patch-Makefile10
-rw-r--r--biology/rainbow/pkg-descr10
4 files changed, 49 insertions, 0 deletions
diff --git a/biology/rainbow/Makefile b/biology/rainbow/Makefile
new file mode 100644
index 000000000000..0fe16b14a1e8
--- /dev/null
+++ b/biology/rainbow/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= rainbow
+DISTVERSION= 2.0.4
+CATEGORIES= biology
+MASTER_SITES= SF/bio-rainbow
+DISTNAME= rainbow_${PORTVERSION}
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Efficient clustering and assembling of short reads, especially for RAD
+
+LICENSE= GPLv3+
+
+USES= gmake
+
+PLIST_FILES= bin/rainbow bin/ezmsim bin/rbasm
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} \
+ ${WRKSRC}/rainbow \
+ ${WRKSRC}/ezmsim \
+ ${WRKSRC}/rbasm \
+ ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/biology/rainbow/distinfo b/biology/rainbow/distinfo
new file mode 100644
index 000000000000..f58d4d136c56
--- /dev/null
+++ b/biology/rainbow/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520455667
+SHA256 (rainbow_2.0.4.tar.gz) = 79281aae3bccd1ad467afef6fc7c8327aaa8d56f538821e2833d2b8f26b5bafc
+SIZE (rainbow_2.0.4.tar.gz) = 77111
diff --git a/biology/rainbow/files/patch-Makefile b/biology/rainbow/files/patch-Makefile
new file mode 100644
index 000000000000..eb3f2af46dae
--- /dev/null
+++ b/biology/rainbow/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig 2015-07-27 18:28:54 UTC
++++ Makefile
+@@ -1,5 +1,5 @@
+-CC=gcc
+-CFLAGS= -W -O2 -Wall -Wno-self-assign -Wno-unused-function
++CC?=gcc
++CFLAGS?= -W -O2 -Wall -Wno-self-assign -Wno-unused-function
+ DFLAGS= -D_FILE_OFFSET_BITS=64
+ GLIBS=-lm
+ GENERIC_SRC= string.h bitvec.h file_reader.h hashset.h sort.h list.h dna.h heap.h stdaln.h vector.h
diff --git a/biology/rainbow/pkg-descr b/biology/rainbow/pkg-descr
new file mode 100644
index 000000000000..395ad106b586
--- /dev/null
+++ b/biology/rainbow/pkg-descr
@@ -0,0 +1,10 @@
+Rainbow provides an ultra-fast and memory-efficient solution to clustering and
+assembling short genetic sequence reads produced by Restriction site Associated
+DNA Sequencing (RAD-seq). It does this by, first, clustering reads using a
+spaced seed method, then it divides potential groups into haplotypes in a
+top-down manner. Next, along a guide tree, it iteratively merges sibling
+leaves in a bottom-up manner if they are similar enough. Finally, Rainbow uses
+a greedy algorithm to locally assemble merged reads into contigs. Both optimal
+and suboptimal assembly results are output.
+
+WWW: http://sourceforge.net/projects/bio-rainbow/