aboutsummaryrefslogtreecommitdiff
path: root/biology/scrm
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-05-15 04:58:27 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-05-15 04:58:27 +0000
commit04c132a637463e0556a8b7089fad7a44a04648d1 (patch)
treef867ae2e1f798fdb824c89298dc08c60cc82097a /biology/scrm
parent053cbfdcb94539e1a624cabba39044643d81942e (diff)
downloadports-04c132a637463e0556a8b7089fad7a44a04648d1.tar.gz
ports-04c132a637463e0556a8b7089fad7a44a04648d1.zip
New port: biology/scrm: Coalescent simulator for biological sequences
Notes
Notes: svn path=/head/; revision=535266
Diffstat (limited to 'biology/scrm')
-rw-r--r--biology/scrm/Makefile22
-rw-r--r--biology/scrm/distinfo3
-rw-r--r--biology/scrm/files/patch-src_random_fastfunc.h11
-rw-r--r--biology/scrm/pkg-descr8
4 files changed, 44 insertions, 0 deletions
diff --git a/biology/scrm/Makefile b/biology/scrm/Makefile
new file mode 100644
index 000000000000..afcf57f23b3a
--- /dev/null
+++ b/biology/scrm/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= scrm
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.7.4
+CATEGORIES= biology
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Coalescent simulator for biological sequences
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= autoreconf gmake
+USE_GITHUB= yes
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/scrm \
+ man/man1/scrm.1.gz
+
+.include <bsd.port.mk>
diff --git a/biology/scrm/distinfo b/biology/scrm/distinfo
new file mode 100644
index 000000000000..26a9894b9b44
--- /dev/null
+++ b/biology/scrm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1589518122
+SHA256 (scrm-scrm-v1.7.4_GH0.tar.gz) = 13f4b0febabcdf6a2b478693febd2fb9d3f47532fb39ffaa4f01fe816f69ceb7
+SIZE (scrm-scrm-v1.7.4_GH0.tar.gz) = 341612
diff --git a/biology/scrm/files/patch-src_random_fastfunc.h b/biology/scrm/files/patch-src_random_fastfunc.h
new file mode 100644
index 000000000000..018a0d8464ba
--- /dev/null
+++ b/biology/scrm/files/patch-src_random_fastfunc.h
@@ -0,0 +1,11 @@
+--- src/random/fastfunc.h.orig 2020-05-15 04:49:19 UTC
++++ src/random/fastfunc.h
+@@ -27,7 +27,7 @@
+ #include <cmath>
+ #include <vector>
+
+-#if !defined(__APPLE__)
++#if !defined(__APPLE__) && !defined(__FreeBSD__)
+ #include <malloc.h>
+ #endif
+
diff --git a/biology/scrm/pkg-descr b/biology/scrm/pkg-descr
new file mode 100644
index 000000000000..99d784f7fdf9
--- /dev/null
+++ b/biology/scrm/pkg-descr
@@ -0,0 +1,8 @@
+scrm simulates the evolution of genetic sequences. It takes a neutral
+evolutionary model as input, and generates random sequences that evolved under
+the model. As coalescent simulator, it traces the ancestry of the sampled
+sequences backwards in time and is therefore extremely efficient. Compared to
+other coalescent simulators, it can simulate chromosome-scale sequences without
+a measureable reduction of genetic linkage between different sites.
+
+WWW: https://scrm.github.io/