aboutsummaryrefslogtreecommitdiff
path: root/biology/seaview
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-11-17 13:22:29 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-11-17 13:22:29 +0000
commitc56e966dc9b128f679a26118f128493c13b867bc (patch)
treee27bae22ba1c92f3d4b1d73b5166fcbe8675aef8 /biology/seaview
parent792dbec403484e6996c756123ac87017179ba21c (diff)
downloadports-c56e966dc9b128f679a26118f128493c13b867bc.tar.gz
ports-c56e966dc9b128f679a26118f128493c13b867bc.zip
- unbreak
Feature safe: yes
Notes
Notes: svn path=/head/; revision=285957
Diffstat (limited to 'biology/seaview')
-rw-r--r--biology/seaview/Makefile2
-rw-r--r--biology/seaview/files/patch-use_mase_files.cxx29
2 files changed, 29 insertions, 2 deletions
diff --git a/biology/seaview/Makefile b/biology/seaview/Makefile
index b5f68db04374..335f3e9aca8e 100644
--- a/biology/seaview/Makefile
+++ b/biology/seaview/Makefile
@@ -20,8 +20,6 @@ COMMENT= Multiple DNA/protein sequence alignment editor
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
pdf.8:${PORTSDIR}/print/pdflib
-BROKEN= does not compile
-
NO_WRKSUBDIR= yes
EXTRACT_CMD= ${CAT}
EXTRACT_BEFORE_ARGS= #
diff --git a/biology/seaview/files/patch-use_mase_files.cxx b/biology/seaview/files/patch-use_mase_files.cxx
new file mode 100644
index 000000000000..6f437c439880
--- /dev/null
+++ b/biology/seaview/files/patch-use_mase_files.cxx
@@ -0,0 +1,29 @@
+--- use_mase_files.cxx.orig 2011-11-17 14:20:13.000000000 +0100
++++ use_mase_files.cxx 2011-11-17 14:20:01.000000000 +0100
+@@ -1457,8 +1457,6 @@
+
+ #else
+
+-extern "C" { int stat(char *, void *); }
+-
+ int check_path(char *fname)
+ /* to check for presence of file fname
+ searching for it through all path directories
+@@ -1468,7 +1466,7 @@
+ #define Mxdir 200
+ char dir[Mxdir+1], *path, *deb, *fin;
+ int lf, ltot;
+- static char stat_struct[250]; /* bigger than necessary */
++ struct stat sb;
+ path=getenv("PATH"); /* get the list of path directories,
+ separated by :
+ */
+@@ -1488,7 +1486,7 @@
+ dir[ltot]='/';
+ strcpy(dir+ltot+1,fname);
+ /* now dir is appended with filename */
+- if( stat(dir, stat_struct) == 0) return 0;
++ if( stat(dir, &sb) == 0) return 0;
+ }
+ deb=fin+1;
+ }