aboutsummaryrefslogtreecommitdiff
path: root/biology/stringtie
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-02-16 20:54:52 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-02-16 20:54:52 +0000
commit0d3f38dc377829a0eec387925f8c3997135d3080 (patch)
tree2b9d0ca08abec8545eef9990f3f8536a05ee8659 /biology/stringtie
parent13f745c5b9bb62a8e6735129bc833aa25912deb7 (diff)
downloadports-0d3f38dc377829a0eec387925f8c3997135d3080.tar.gz
ports-0d3f38dc377829a0eec387925f8c3997135d3080.zip
biology/stringtie: Update 1.3.4d -> 2.1.1
PR: 243718 Submitted by: Motomichi Matsuzaki <mzaki@e-mail.ne.jp> (maintainer)
Notes
Notes: svn path=/head/; revision=526322
Diffstat (limited to 'biology/stringtie')
-rw-r--r--biology/stringtie/Makefile14
-rw-r--r--biology/stringtie/distinfo6
-rw-r--r--biology/stringtie/files/patch-Makefile56
-rw-r--r--biology/stringtie/files/patch-gclib_GIntHash.hh20
-rw-r--r--biology/stringtie/files/patch-samtools-0.1.18_bam__aux.c20
5 files changed, 19 insertions, 97 deletions
diff --git a/biology/stringtie/Makefile b/biology/stringtie/Makefile
index 57c2fdb096ed..4110ba7ab712 100644
--- a/biology/stringtie/Makefile
+++ b/biology/stringtie/Makefile
@@ -1,20 +1,22 @@
# $FreeBSD$
PORTNAME= stringtie
-DISTVERSION= 1.3.4d
+DISTVERSION= 2.1.1
CATEGORIES= biology
MASTER_SITES= http://ccb.jhu.edu/software/stringtie/dl/
-MAINTAINER= mzaki@niid.go.jp
+MAINTAINER= mzaki@e-mail.ne.jp
COMMENT= Transcript assembly and quantification for RNA-seq
-LICENSE= ART20 MIT
-LICENSE_COMB= multi
-LICENSE_FILE_ART20= ${WRKSRC}/LICENSE
-LICENSE_FILE_MIT= ${WRKSRC}/samtools-0.1.18/COPYING
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= bash:shells/bash \
+ curl:ftp/curl
USES= gmake
ALL_TARGET= release
+TEST_TARGET= test
PLIST_FILES= bin/stringtie
diff --git a/biology/stringtie/distinfo b/biology/stringtie/distinfo
index 020a9bf31fc4..9cb6aece307b 100644
--- a/biology/stringtie/distinfo
+++ b/biology/stringtie/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1530582079
-SHA256 (stringtie-1.3.4d.tar.gz) = b1962d0108146ce7fea39d069b5e5de918e0e21daef9e1425ec9b778094d6ae6
-SIZE (stringtie-1.3.4d.tar.gz) = 438025
+TIMESTAMP = 1580533096
+SHA256 (stringtie-2.1.1.tar.gz) = 7ea152b791856b1bd5dd2d475b06fae05398ee7e03f2f9844418010376edcca2
+SIZE (stringtie-2.1.1.tar.gz) = 1969917
diff --git a/biology/stringtie/files/patch-Makefile b/biology/stringtie/files/patch-Makefile
index 52df9a78c090..a9a490e404fd 100644
--- a/biology/stringtie/files/patch-Makefile
+++ b/biology/stringtie/files/patch-Makefile
@@ -1,55 +1,15 @@
---- Makefile.orig 2018-03-06 16:29:49 UTC
+--- Makefile.orig 2020-01-26 03:31:12 UTC
+++ Makefile
-@@ -6,12 +6,12 @@ GDIR :=./gclib
-
- INCDIRS := -I. -I${GDIR} -I${BAM}
-
--CC := g++
-+CXX ?= g++
-
- BASEFLAGS := -Wall -Wextra ${INCDIRS} -fsigned-char -D_FILE_OFFSET_BITS=64 \
- -D_LARGEFILE_SOURCE -fno-strict-aliasing -fno-exceptions -fno-rtti
-
--LINKER := g++
-+LINKER = ${CXX}
-
- LDFLAGS := -g -L${BAM} $(LDFLAGS)
-
-@@ -22,13 +22,13 @@ ifneq (,$(findstring nothreads,$(MAKECMD
+@@ -20,7 +20,7 @@ ifeq "$(GCCVER8)" "1"
+ BASEFLAGS += -Wno-class-memaccess
endif
- #detect MinGW (Windows environment)
--ifneq (,$(findstring mingw,$(shell ${CC} -dumpmachine)))
-+ifneq (,$(findstring mingw,$(shell ${CXX} -dumpmachine)))
- WINDOWS=1
- endif
-
- # MinGW32 GCC 4.5 link problem fix
- #ifdef WINDOWS
--ifneq (,$(findstring 4.5.,$(shell g++ -dumpversion)))
-+ifneq (,$(findstring 4.5.,$(shell ${CXX} -dumpversion)))
- STATIC_CLIB=1
- endif
- #endif
-@@ -63,7 +63,7 @@ endif
- ifneq (,$(filter %release %static, $(MAKECMDGOALS)))
- # -- release build
- RELEASE_BUILD=1
-- CFLAGS := -DNDEBUG -g $(BASEFLAGS) $(CFLAGS) -O3
-+ CFLAGS := -DNDEBUG -g $(BASEFLAGS) $(CFLAGS)
- else
- ifneq (,$(filter %memcheck %memdebug, $(MAKECMDGOALS)))
- #use sanitizer in gcc 4.9+
-@@ -122,7 +122,7 @@ endif
-
-
- %.o : %.cpp
-- ${CC} ${CFLAGS} -c $< -o $@
-+ ${CXX} ${CFLAGS} -c $< -o $@
+-LINKER := $(if $(LINKER),$(LINKER),g++)
++LINKER := $(if $(LINKER),$(LINKER),$(CXX))
- OBJS += rlink.o tablemaker.o tmerge.o
+ LDFLAGS := $(if $(LDFLAGS),$(LDFLAGS),-g)
-@@ -137,7 +137,7 @@ rlink.o : rlink.h tablemaker.h $(GDIR)/G
+@@ -151,7 +151,7 @@ rlink.o : rlink.h tablemaker.h $(GDIR)/G
tmerge.o : rlink.h tmerge.h
tablemaker.o : tablemaker.h rlink.h
${BAM}/libbam.a:
@@ -58,7 +18,7 @@
stringtie: ${BAM}/libbam.a $(OBJS) stringtie.o
${LINKER} ${LDFLAGS} -o $@ ${filter-out %.a %.so, $^} ${LIBS}
@echo
-@@ -151,6 +151,6 @@ clean:
+@@ -167,6 +167,6 @@ clean:
${RM} stringtie${EXE} stringtie.o* $(OBJS)
${RM} core.*
allclean cleanAll cleanall:
diff --git a/biology/stringtie/files/patch-gclib_GIntHash.hh b/biology/stringtie/files/patch-gclib_GIntHash.hh
deleted file mode 100644
index a29977a4db84..000000000000
--- a/biology/stringtie/files/patch-gclib_GIntHash.hh
+++ /dev/null
@@ -1,20 +0,0 @@
---- gclib/GIntHash.hh.orig 2018-03-06 16:29:49 UTC
-+++ gclib/GIntHash.hh
-@@ -122,7 +122,7 @@ public:
- uint32 NextKey() {
- Cell* cell=ghash.NextCell();
- if (cell) return cell->key;
-- else return NULL;
-+ else return 0;
- }
- OBJ* NextValue() {
- Cell* cell=ghash.NextCell();
-@@ -201,7 +201,7 @@ public:
- uint32 NextKey() {
- Cell* cell=ghash.NextCell();
- if (cell) return cell->key;
-- else return NULL;
-+ else return 0;
- }
- OBJ* NextValue() {
- Cell* cell=ghash.NextCell();
diff --git a/biology/stringtie/files/patch-samtools-0.1.18_bam__aux.c b/biology/stringtie/files/patch-samtools-0.1.18_bam__aux.c
deleted file mode 100644
index fb7dcf5c19f2..000000000000
--- a/biology/stringtie/files/patch-samtools-0.1.18_bam__aux.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- samtools-0.1.18/bam_aux.c.orig 2018-03-06 16:29:49 UTC
-+++ samtools-0.1.18/bam_aux.c
-@@ -25,7 +25,7 @@ uint8_t *bam_aux_get_core(bam1_t *b, con
- return bam_aux_get(b, tag);
- }
-
--inline int aux_type2size(uint8_t type)
-+int aux_type2size(uint8_t type)
- {
- switch (type) {
- case 'A': case 'c': case 'C':
-@@ -43,7 +43,7 @@ inline int aux_type2size(uint8_t type)
- }
- }
-
--inline uint8_t* skip_aux(uint8_t* s) {
-+uint8_t* skip_aux(uint8_t* s) {
- int size = aux_type2size(*s); ++s; // skip type
- uint32_t n;
- switch (size) {