aboutsummaryrefslogtreecommitdiff
path: root/biology/stringtie
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-07-11 21:32:39 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-07-11 21:32:39 +0000
commit9f819d30ba5491e06c95fbaddca9da401a4252be (patch)
tree6482400427008cb2f2e9c258d4ba56a33f33fcc4 /biology/stringtie
parenta6faba7903124ffae72203cf7283cba21900e3ca (diff)
downloadports-9f819d30ba5491e06c95fbaddca9da401a4252be.tar.gz
ports-9f819d30ba5491e06c95fbaddca9da401a4252be.zip
New port: biology/stringtie: Transcript assembly and quantification for RNA-seq
PR: 229480 Submitted by: Motomichi Matsuzaki <mzaki@niid.go.jp>
Notes
Notes: svn path=/head/; revision=474480
Diffstat (limited to 'biology/stringtie')
-rw-r--r--biology/stringtie/Makefile24
-rw-r--r--biology/stringtie/distinfo3
-rw-r--r--biology/stringtie/files/patch-Makefile68
-rw-r--r--biology/stringtie/files/patch-gclib_GIntHash.hh20
-rw-r--r--biology/stringtie/files/patch-samtools-0.1.18_Makefile10
-rw-r--r--biology/stringtie/files/patch-samtools-0.1.18_bam__aux.c20
-rw-r--r--biology/stringtie/pkg-descr11
7 files changed, 156 insertions, 0 deletions
diff --git a/biology/stringtie/Makefile b/biology/stringtie/Makefile
new file mode 100644
index 000000000000..57c2fdb096ed
--- /dev/null
+++ b/biology/stringtie/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= stringtie
+DISTVERSION= 1.3.4d
+CATEGORIES= biology
+MASTER_SITES= http://ccb.jhu.edu/software/stringtie/dl/
+
+MAINTAINER= mzaki@niid.go.jp
+COMMENT= Transcript assembly and quantification for RNA-seq
+
+LICENSE= ART20 MIT
+LICENSE_COMB= multi
+LICENSE_FILE_ART20= ${WRKSRC}/LICENSE
+LICENSE_FILE_MIT= ${WRKSRC}/samtools-0.1.18/COPYING
+
+USES= gmake
+ALL_TARGET= release
+
+PLIST_FILES= bin/stringtie
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/stringtie ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/biology/stringtie/distinfo b/biology/stringtie/distinfo
new file mode 100644
index 000000000000..020a9bf31fc4
--- /dev/null
+++ b/biology/stringtie/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1530582079
+SHA256 (stringtie-1.3.4d.tar.gz) = b1962d0108146ce7fea39d069b5e5de918e0e21daef9e1425ec9b778094d6ae6
+SIZE (stringtie-1.3.4d.tar.gz) = 438025
diff --git a/biology/stringtie/files/patch-Makefile b/biology/stringtie/files/patch-Makefile
new file mode 100644
index 000000000000..52df9a78c090
--- /dev/null
+++ b/biology/stringtie/files/patch-Makefile
@@ -0,0 +1,68 @@
+--- Makefile.orig 2018-03-06 16:29:49 UTC
++++ Makefile
+@@ -6,12 +6,12 @@ GDIR :=./gclib
+
+ INCDIRS := -I. -I${GDIR} -I${BAM}
+
+-CC := g++
++CXX ?= g++
+
+ BASEFLAGS := -Wall -Wextra ${INCDIRS} -fsigned-char -D_FILE_OFFSET_BITS=64 \
+ -D_LARGEFILE_SOURCE -fno-strict-aliasing -fno-exceptions -fno-rtti
+
+-LINKER := g++
++LINKER = ${CXX}
+
+ LDFLAGS := -g -L${BAM} $(LDFLAGS)
+
+@@ -22,13 +22,13 @@ ifneq (,$(findstring nothreads,$(MAKECMD
+ endif
+
+ #detect MinGW (Windows environment)
+-ifneq (,$(findstring mingw,$(shell ${CC} -dumpmachine)))
++ifneq (,$(findstring mingw,$(shell ${CXX} -dumpmachine)))
+ WINDOWS=1
+ endif
+
+ # MinGW32 GCC 4.5 link problem fix
+ #ifdef WINDOWS
+-ifneq (,$(findstring 4.5.,$(shell g++ -dumpversion)))
++ifneq (,$(findstring 4.5.,$(shell ${CXX} -dumpversion)))
+ STATIC_CLIB=1
+ endif
+ #endif
+@@ -63,7 +63,7 @@ endif
+ ifneq (,$(filter %release %static, $(MAKECMDGOALS)))
+ # -- release build
+ RELEASE_BUILD=1
+- CFLAGS := -DNDEBUG -g $(BASEFLAGS) $(CFLAGS) -O3
++ CFLAGS := -DNDEBUG -g $(BASEFLAGS) $(CFLAGS)
+ else
+ ifneq (,$(filter %memcheck %memdebug, $(MAKECMDGOALS)))
+ #use sanitizer in gcc 4.9+
+@@ -122,7 +122,7 @@ endif
+
+
+ %.o : %.cpp
+- ${CC} ${CFLAGS} -c $< -o $@
++ ${CXX} ${CFLAGS} -c $< -o $@
+
+ OBJS += rlink.o tablemaker.o tmerge.o
+
+@@ -137,7 +137,7 @@ rlink.o : rlink.h tablemaker.h $(GDIR)/G
+ tmerge.o : rlink.h tmerge.h
+ tablemaker.o : tablemaker.h rlink.h
+ ${BAM}/libbam.a:
+- cd ${BAM} && make lib
++ cd ${BAM} && ${MAKE} lib
+ stringtie: ${BAM}/libbam.a $(OBJS) stringtie.o
+ ${LINKER} ${LDFLAGS} -o $@ ${filter-out %.a %.so, $^} ${LIBS}
+ @echo
+@@ -151,6 +151,6 @@ clean:
+ ${RM} stringtie${EXE} stringtie.o* $(OBJS)
+ ${RM} core.*
+ allclean cleanAll cleanall:
+- cd ${BAM} && make clean
++ cd ${BAM} && ${MAKE} clean
+ ${RM} stringtie${EXE} stringtie.o* $(OBJS)
+ ${RM} core.*
diff --git a/biology/stringtie/files/patch-gclib_GIntHash.hh b/biology/stringtie/files/patch-gclib_GIntHash.hh
new file mode 100644
index 000000000000..a29977a4db84
--- /dev/null
+++ b/biology/stringtie/files/patch-gclib_GIntHash.hh
@@ -0,0 +1,20 @@
+--- gclib/GIntHash.hh.orig 2018-03-06 16:29:49 UTC
++++ gclib/GIntHash.hh
+@@ -122,7 +122,7 @@ public:
+ uint32 NextKey() {
+ Cell* cell=ghash.NextCell();
+ if (cell) return cell->key;
+- else return NULL;
++ else return 0;
+ }
+ OBJ* NextValue() {
+ Cell* cell=ghash.NextCell();
+@@ -201,7 +201,7 @@ public:
+ uint32 NextKey() {
+ Cell* cell=ghash.NextCell();
+ if (cell) return cell->key;
+- else return NULL;
++ else return 0;
+ }
+ OBJ* NextValue() {
+ Cell* cell=ghash.NextCell();
diff --git a/biology/stringtie/files/patch-samtools-0.1.18_Makefile b/biology/stringtie/files/patch-samtools-0.1.18_Makefile
new file mode 100644
index 000000000000..86d0fa80d3fc
--- /dev/null
+++ b/biology/stringtie/files/patch-samtools-0.1.18_Makefile
@@ -0,0 +1,10 @@
+--- samtools-0.1.18/Makefile.orig 2018-03-06 16:29:49 UTC
++++ samtools-0.1.18/Makefile
+@@ -1,5 +1,5 @@
+-CC= gcc
+-CFLAGS= -g -Wall -fsigned-char -O2 #-m64 #-arch ppc
++CC?= gcc
++CFLAGS?= -g -Wall -fsigned-char -O2 #-m64 #-arch ppc
+ DFLAGS= -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -D_CURSES_LIB=0 #-D_USE_KNETFILE
+ KNETFILE_O= knetfile.o
+ LOBJS= bgzf.o kstring.o bam_aux.o bam.o bam_import.o sam.o bam_index.o \
diff --git a/biology/stringtie/files/patch-samtools-0.1.18_bam__aux.c b/biology/stringtie/files/patch-samtools-0.1.18_bam__aux.c
new file mode 100644
index 000000000000..fb7dcf5c19f2
--- /dev/null
+++ b/biology/stringtie/files/patch-samtools-0.1.18_bam__aux.c
@@ -0,0 +1,20 @@
+--- samtools-0.1.18/bam_aux.c.orig 2018-03-06 16:29:49 UTC
++++ samtools-0.1.18/bam_aux.c
+@@ -25,7 +25,7 @@ uint8_t *bam_aux_get_core(bam1_t *b, con
+ return bam_aux_get(b, tag);
+ }
+
+-inline int aux_type2size(uint8_t type)
++int aux_type2size(uint8_t type)
+ {
+ switch (type) {
+ case 'A': case 'c': case 'C':
+@@ -43,7 +43,7 @@ inline int aux_type2size(uint8_t type)
+ }
+ }
+
+-inline uint8_t* skip_aux(uint8_t* s) {
++uint8_t* skip_aux(uint8_t* s) {
+ int size = aux_type2size(*s); ++s; // skip type
+ uint32_t n;
+ switch (size) {
diff --git a/biology/stringtie/pkg-descr b/biology/stringtie/pkg-descr
new file mode 100644
index 000000000000..246cda936a4b
--- /dev/null
+++ b/biology/stringtie/pkg-descr
@@ -0,0 +1,11 @@
+StringTie is a fast and highly efficient assembler of RNA-seq alignments into
+potential transcripts. The input can be the alignments of raw reads as usual;
+it also accepts longer assembled sequences. The output can be processed by
+downstream software including Ballgown, Cuffdiff, etc.
+
+Citation:
+Pertea et al. (2015) StringTie enables improved reconstruction of a
+transcriptome from RNA-seq reads.
+Nature Biotechnology 33: 290-295 doi:10.1038/nbt.3122
+
+WWW: http://www.ccb.jhu.edu/software/stringtie/