aboutsummaryrefslogtreecommitdiff
path: root/biology/trimadap
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2018-04-03 18:23:54 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2018-04-03 18:23:54 +0000
commit9db7a5f181c7b8e23660594e11a8b28c7d3319bd (patch)
tree3741a1ffdad908f9216f1d015e1c47d29921643b /biology/trimadap
parentd46cfd0917265667bd40a1f17480f802e15b46d0 (diff)
downloadports-9db7a5f181c7b8e23660594e11a8b28c7d3319bd.tar.gz
ports-9db7a5f181c7b8e23660594e11a8b28c7d3319bd.zip
biology/trimadap: Trim adapter sequences from Illumina data
Reviewed by: mat Approved by: jrm Differential Revision: https://reviews.freebsd.org/D14935
Notes
Notes: svn path=/head/; revision=466367
Diffstat (limited to 'biology/trimadap')
-rw-r--r--biology/trimadap/Makefile23
-rw-r--r--biology/trimadap/distinfo3
-rw-r--r--biology/trimadap/files/patch-Makefile20
-rw-r--r--biology/trimadap/files/patch-kthread.c10
-rw-r--r--biology/trimadap/pkg-descr8
5 files changed, 64 insertions, 0 deletions
diff --git a/biology/trimadap/Makefile b/biology/trimadap/Makefile
new file mode 100644
index 000000000000..21e8a9b4e149
--- /dev/null
+++ b/biology/trimadap/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= trimadap
+DISTVERSION= 0.1-3
+DISTVERSIONSUFFIX= -gddfef21
+CATEGORIES= biology
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Trim adapter sequences from Illumina data using heuristic rules
+
+LICENSE= GPLv2
+
+USE_GITHUB= yes
+GH_ACCOUNT= lh3
+
+PLIST_FILES= bin/trimadap-mt
+
+CFLAGS_i386= -msse2
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/trimadap-mt ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/biology/trimadap/distinfo b/biology/trimadap/distinfo
new file mode 100644
index 000000000000..99e06ce2a75b
--- /dev/null
+++ b/biology/trimadap/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522773176
+SHA256 (lh3-trimadap-0.1-3-gddfef21_GH0.tar.gz) = c2c42a3257d37b12be3523ed0d4415bddd401d72b99b05ba4ae33afaa3c3f373
+SIZE (lh3-trimadap-0.1-3-gddfef21_GH0.tar.gz) = 13138
diff --git a/biology/trimadap/files/patch-Makefile b/biology/trimadap/files/patch-Makefile
new file mode 100644
index 000000000000..e0d27599fd71
--- /dev/null
+++ b/biology/trimadap/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig 2017-02-11 22:31:35 UTC
++++ Makefile
+@@ -1,10 +1,12 @@
+-CC=gcc
+-CFLAGS=-g -Wall -O2 -Wno-unused-function
++CC ?= gcc
++CFLAGS ?= -g -Wall -O2 -Wno-unused-function
++LDFLAGS += -lz -lm
+
+-all:trimadap-mt
++all: trimadap-mt
+
+ trimadap-mt:trimadap-mt.c ksw.c kthread.c kseq.h ksw.h
+- $(CC) $(CFLAGS) -pthread ksw.c kthread.c trimadap-mt.c -o $@ -lz -lm
++ $(CC) $(CFLAGS) -pthread ksw.c kthread.c trimadap-mt.c -o $@ $(LDFLAGS)
+
+ clean:
+- rm -fr gmon.out *.o ext/*.o a.out seqtk trimadap *~ *.a *.dSYM session* trimadap-mt
++ rm -fr gmon.out *.o ext/*.o a.out seqtk trimadap *~ *.a \
++ *.dSYM session* trimadap-mt
diff --git a/biology/trimadap/files/patch-kthread.c b/biology/trimadap/files/patch-kthread.c
new file mode 100644
index 000000000000..5ce6af80ef47
--- /dev/null
+++ b/biology/trimadap/files/patch-kthread.c
@@ -0,0 +1,10 @@
+--- kthread.c.orig 2017-02-11 22:31:35 UTC
++++ kthread.c
+@@ -1,6 +1,7 @@
+ #include <pthread.h>
+ #include <stdlib.h>
+ #include <limits.h>
++#include <inttypes.h>
+
+ /************
+ * kt_for() *
diff --git a/biology/trimadap/pkg-descr b/biology/trimadap/pkg-descr
new file mode 100644
index 000000000000..f872dd7b2215
--- /dev/null
+++ b/biology/trimadap/pkg-descr
@@ -0,0 +1,8 @@
+Trimadap is a small tool to trim adapter sequences from Illumina data. It
+performs SSE2-SW between each read and each adapter sequence and identifies
+adapter sequences with a few heuristic rules which can be found in the
+ta_trim1() function in trimadap-mt.c. The default adapters it uses are included
+in illumina.txt. These are typical Illumina adapters from paired-end
+sequencing.
+
+WWW: https://github.com/lh3/trimadap