aboutsummaryrefslogtreecommitdiff
path: root/biology/ugene
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2016-05-07 19:38:53 +0000
committerDimitry Andric <dim@FreeBSD.org>2016-05-07 19:38:53 +0000
commit488fd1255a6b9d73ce4caee10ddc7b6864c0cdfb (patch)
tree80deb1775b61d078368d81f05c1957ecdf7d8d90 /biology/ugene
parentaa43e0125c8d3025af96a0011ebfaa1d2ced4b1b (diff)
downloadports-488fd1255a6b9d73ce4caee10ddc7b6864c0cdfb.tar.gz
ports-488fd1255a6b9d73ce4caee10ddc7b6864c0cdfb.zip
During the exp-run in bug 208158, it was found that biology/ugene gives
errors with libc++ 3.8.0: In file included from src/QScoreAdapter.cpp:1: In file included from src/QScoreAdapter.h:4: In file included from ../../include/U2Core/MAlignment.h:1: In file included from ../../include/U2Core/../../corelibs/U2Core/src/datatype/MAlignment.h:25: In file included from ../../include/U2Core/../../corelibs/U2Core/src/datatype/MAlignmentInfo.h:25: In file included from /usr/local/include/qt5/QtCore/QString:1: In file included from /usr/local/include/qt5/QtCore/qstring.h:41: In file included from /usr/local/include/qt5/QtCore/qchar.h:37: In file included from /usr/local/include/qt5/QtCore/qglobal.h:39: /usr/include/c++/v1/cstddef:43:15: fatal error: 'stddef.h' file not found #include_next <stddef.h> ^ This is because the port tries to add /usr/include as a system include directory, using -isystem, and this screws up the order of include directories. Fix it by patching up a number of .pri files to avoid using the -isystem flag. Approved by: h2+fbsdports@fsfe.org (maintainer) PR: 209366 MFH: 2016Q2
Notes
Notes: svn path=/head/; revision=414784
Diffstat (limited to 'biology/ugene')
-rw-r--r--biology/ugene/Makefile1
-rw-r--r--biology/ugene/files/patch-src_libs__3rdparty_samtools_samtools.pri11
-rw-r--r--biology/ugene/files/patch-src_plugins__3rdparty_variants_variants.pri11
-rw-r--r--biology/ugene/files/patch-src_ugene__globals.pri13
4 files changed, 36 insertions, 0 deletions
diff --git a/biology/ugene/Makefile b/biology/ugene/Makefile
index 8cd7c2e94c6f..6947d3efb962 100644
--- a/biology/ugene/Makefile
+++ b/biology/ugene/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ugene
DISTVERSION= 1.22.0
+PORTREVISION= 1
CATEGORIES= biology science
MASTER_SITES= http://ugene.unipro.ru/downloads/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} QueryDesigner_UserManual.pdf \
diff --git a/biology/ugene/files/patch-src_libs__3rdparty_samtools_samtools.pri b/biology/ugene/files/patch-src_libs__3rdparty_samtools_samtools.pri
new file mode 100644
index 000000000000..3951d5f87ecb
--- /dev/null
+++ b/biology/ugene/files/patch-src_libs__3rdparty_samtools_samtools.pri
@@ -0,0 +1,11 @@
+--- src/libs_3rdparty/samtools/samtools.pri.orig 2016-03-31 12:21:56 UTC
++++ src/libs_3rdparty/samtools/samtools.pri
+@@ -3,7 +3,7 @@ UGENE_RELATIVE_DESTDIR = ''
+
+ TEMPLATE = lib
+ CONFIG +=thread debug_and_release staticlib warn_off
+-INCLUDEPATH += src src/samtools ../../include /usr/include
++INCLUDEPATH += src src/samtools ../../include
+ win32 : INCLUDEPATH += src/samtools/win32
+ DEFINES+="_FILE_OFFSET_BITS=64" _LARGEFILE64_SOURCE _USE_KNETFILE
+ win32 : DEFINES += _USE_MATH_DEFINES "inline=__inline" "__func__=__FUNCTION__" "R_OK=4" "atoll=_atoi64" "alloca=_alloca"
diff --git a/biology/ugene/files/patch-src_plugins__3rdparty_variants_variants.pri b/biology/ugene/files/patch-src_plugins__3rdparty_variants_variants.pri
new file mode 100644
index 000000000000..9ecf2cc231fb
--- /dev/null
+++ b/biology/ugene/files/patch-src_plugins__3rdparty_variants_variants.pri
@@ -0,0 +1,11 @@
+--- src/plugins_3rdparty/variants/variants.pri.orig 2016-03-31 12:22:09 UTC
++++ src/plugins_3rdparty/variants/variants.pri
+@@ -20,7 +20,7 @@ use_bundled_zlib() {
+ win32 : LIBS += -lwsock32
+
+
+-INCLUDEPATH += src ../../include /usr/include
++INCLUDEPATH += src ../../include
+ INCLUDEPATH += ../../libs_3rdparty/samtools/src/samtools
+ INCLUDEPATH += ../../libs_3rdparty/samtools/src
+ INCLUDEPATH += ../../libs_3rdparty/samtools/src/samtools/bcftools
diff --git a/biology/ugene/files/patch-src_ugene__globals.pri b/biology/ugene/files/patch-src_ugene__globals.pri
new file mode 100644
index 000000000000..6c0a38639d38
--- /dev/null
+++ b/biology/ugene/files/patch-src_ugene__globals.pri
@@ -0,0 +1,13 @@
+--- src/ugene_globals.pri.orig 2016-03-31 12:22:21 UTC
++++ src/ugene_globals.pri
+@@ -8,8 +8,8 @@ DEFINES+=UGENE_VER_MAJOR=$${UGENE_VER_MA
+ DEFINES+=UGENE_VER_MINOR=$${UGENE_VER_MINOR}
+ DEFINES+=UGENE_VER_PATCH=$${UGENE_VER_PATCH}
+
+-unix : !macx : INCLUDEPATH-=/usr/include
+-unix : !macx : INCLUDEPATH+=/usr/include/qt5 /usr/include
++#unix : !macx : INCLUDEPATH-=/usr/include
++#unix : !macx : INCLUDEPATH+=/usr/include/qt5 /usr/include
+ #unix : !macx : INCLUDEPATH =/usr/include/qt5 $$INCLUDEPATH
+
+ # NGS package