aboutsummaryrefslogtreecommitdiff
path: root/biology/vt
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2020-08-03 17:42:32 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2020-08-03 17:42:32 +0000
commit551f57c4e0af095a436738f2df337ce072bfa741 (patch)
treef10412992812e7492d7a6b54ff4d590fddf637f7 /biology/vt
parentfb3f006dcf754294010a0a8c607bd6d62ba3d9c1 (diff)
downloadports-551f57c4e0af095a436738f2df337ce072bfa741.tar.gz
ports-551f57c4e0af095a436738f2df337ce072bfa741.zip
Notes
Diffstat (limited to 'biology/vt')
-rw-r--r--biology/vt/Makefile3
-rw-r--r--biology/vt/files/patch-bcf__ordered__writer.cpp20
-rw-r--r--biology/vt/files/patch-discover.cpp11
-rw-r--r--biology/vt/files/patch-genotype.cpp11
-rw-r--r--biology/vt/files/patch-read__filter.cpp18
5 files changed, 62 insertions, 1 deletions
diff --git a/biology/vt/Makefile b/biology/vt/Makefile
index bc41eccadc31..f4fcf29ae15f 100644
--- a/biology/vt/Makefile
+++ b/biology/vt/Makefile
@@ -2,6 +2,7 @@
PORTNAME= vt
DISTVERSION= 0.57721
+PORTREVISION= 1
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
@@ -9,7 +10,7 @@ COMMENT= Discovers short variants from Next Generation Sequencing data
LICENSE= MIT
-LIB_DEPENDS= libhts.so:biology/htslib \
+LIB_DEPENDS= libhts.so.3:biology/htslib \
libsvm.so:science/libsvm \
libdeflate.so:archivers/libdeflate \
libcurl.so:ftp/curl
diff --git a/biology/vt/files/patch-bcf__ordered__writer.cpp b/biology/vt/files/patch-bcf__ordered__writer.cpp
new file mode 100644
index 000000000000..ff58990bb063
--- /dev/null
+++ b/biology/vt/files/patch-bcf__ordered__writer.cpp
@@ -0,0 +1,20 @@
+--- bcf_ordered_writer.cpp.orig 2020-07-27 13:12:44 UTC
++++ bcf_ordered_writer.cpp
+@@ -155,7 +155,7 @@ void BCFOrderedWriter::write(bcf1_t *v)
+
+ if (i==buffer.end())
+ {
+- int32_t cutoff_pos1 = std::max(bcf_get_pos1(buffer.front())-window,1);
++ int32_t cutoff_pos1 = std::max(bcf_get_pos1(buffer.front())-window,(hts_pos_t)1);
+ if (bcf_get_pos1(v)<cutoff_pos1)
+ {
+ fprintf(stderr, "[%s:%d %s] Might not be sorted for window size %d at current record %s:%d < %d (%d [last record] - %d), please increase window size to at least %d.\n",
+@@ -251,7 +251,7 @@ void BCFOrderedWriter::flush(bool force)
+ {
+ if (buffer.size()>1)
+ {
+- int32_t cutoff_pos1 = std::max(bcf_get_pos1(buffer.front())-window,1);
++ int32_t cutoff_pos1 = std::max(bcf_get_pos1(buffer.front())-window,(hts_pos_t)1);
+
+ while (buffer.size()>1)
+ {
diff --git a/biology/vt/files/patch-discover.cpp b/biology/vt/files/patch-discover.cpp
new file mode 100644
index 000000000000..432638c9ce27
--- /dev/null
+++ b/biology/vt/files/patch-discover.cpp
@@ -0,0 +1,11 @@
+--- discover.cpp.orig 2020-07-27 13:45:38 UTC
++++ discover.cpp
+@@ -352,7 +352,7 @@ class Igor : Program
+ //already present
+ free(qname);
+ }
+- kh_val(reads, k) = {bam_get_pos1(s), bam_get_pos1(s)+bam_get_l_qseq(s)-1};
++ kh_val(reads, k) = {(int32_t)bam_get_pos1(s), (int32_t)bam_get_pos1(s)+bam_get_l_qseq(s)-1};
+ }
+ }
+ else
diff --git a/biology/vt/files/patch-genotype.cpp b/biology/vt/files/patch-genotype.cpp
new file mode 100644
index 000000000000..2cce36b46fbe
--- /dev/null
+++ b/biology/vt/files/patch-genotype.cpp
@@ -0,0 +1,11 @@
+--- genotype.cpp.orig 2020-07-27 13:47:27 UTC
++++ genotype.cpp
+@@ -301,7 +301,7 @@ class Igor : Program
+ //already present
+ free(qname);
+ }
+- kh_val(reads, k) = {bam_get_pos1(s), bam_get_pos1(s)+bam_get_l_qseq(s)-1};
++ kh_val(reads, k) = {(int32_t)bam_get_pos1(s), (int32_t)bam_get_pos1(s)+bam_get_l_qseq(s)-1};
+ }
+ }
+ else
diff --git a/biology/vt/files/patch-read__filter.cpp b/biology/vt/files/patch-read__filter.cpp
new file mode 100644
index 000000000000..3496945d575a
--- /dev/null
+++ b/biology/vt/files/patch-read__filter.cpp
@@ -0,0 +1,18 @@
+--- read_filter.cpp.orig 2020-07-27 13:49:14 UTC
++++ read_filter.cpp
+@@ -92,7 +92,7 @@ bool ReadFilter::filter_read(bam_hdr_t* h, bam1_t *s)
+ //already present
+ free(qname);
+ }
+- kh_val(reads, k) = {bam_get_pos1(s), bam_get_pos1(s)+bam_get_l_qseq(s)-1};
++ kh_val(reads, k) = {(int32_t)bam_get_pos1(s), (int32_t)bam_get_pos1(s)+bam_get_l_qseq(s)-1};
+ }
+ }
+ else
+@@ -272,4 +272,4 @@ void ReadFilter::bam_print_key_values(bam_hdr_t *h, ba
+ if (qual.m) free(qual.s);
+ if (cigar_string.m) free(cigar_string.s);
+ if (cigar_expanded_string.m) free(cigar_expanded_string.s);
+-}
+\ No newline at end of file
++}