aboutsummaryrefslogtreecommitdiff
path: root/biology/vt
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2020-11-09 00:35:58 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2020-11-09 00:35:58 +0000
commit899ed588d961ba4465259e06f78937f6f180031a (patch)
tree4dd372db391dfd7f80c54db437fbe056466199e1 /biology/vt
parent98488e5fad6963bd5b7c502ae526f214e60d111b (diff)
downloadports-899ed588d961ba4465259e06f78937f6f180031a.tar.gz
ports-899ed588d961ba4465259e06f78937f6f180031a.zip
biology/vt: Fix build with htslib 1.11
Reported by: fallout
Notes
Notes: svn path=/head/; revision=554660
Diffstat (limited to 'biology/vt')
-rw-r--r--biology/vt/Makefile4
-rw-r--r--biology/vt/files/patch-hts__utils.h11
2 files changed, 13 insertions, 2 deletions
diff --git a/biology/vt/Makefile b/biology/vt/Makefile
index f4fcf29ae15f..95d9ed794d9d 100644
--- a/biology/vt/Makefile
+++ b/biology/vt/Makefile
@@ -2,7 +2,7 @@
PORTNAME= vt
DISTVERSION= 0.57721
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
@@ -10,7 +10,7 @@ COMMENT= Discovers short variants from Next Generation Sequencing data
LICENSE= MIT
-LIB_DEPENDS= libhts.so.3:biology/htslib \
+LIB_DEPENDS= libhts.so:biology/htslib \
libsvm.so:science/libsvm \
libdeflate.so:archivers/libdeflate \
libcurl.so:ftp/curl
diff --git a/biology/vt/files/patch-hts__utils.h b/biology/vt/files/patch-hts__utils.h
new file mode 100644
index 000000000000..6d5bdb4c3c3c
--- /dev/null
+++ b/biology/vt/files/patch-hts__utils.h
@@ -0,0 +1,11 @@
+--- hts_utils.h.orig 2020-11-08 22:09:58 UTC
++++ hts_utils.h
+@@ -47,7 +47,7 @@ typedef struct {
+
+ KHASH_MAP_INIT_STR(s, faidx1_t)
+
+-struct __faidx_t {
++struct faidx_t {
+ BGZF *bgzf;
+ int n, m;
+ char **name;