aboutsummaryrefslogtreecommitdiff
path: root/cad/astk-serveur
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /cad/astk-serveur
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'cad/astk-serveur')
-rw-r--r--cad/astk-serveur/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/cad/astk-serveur/Makefile b/cad/astk-serveur/Makefile
index 0cebc043add1..b5c91eeb81fb 100644
--- a/cad/astk-serveur/Makefile
+++ b/cad/astk-serveur/Makefile
@@ -108,9 +108,9 @@ SHIA= zsh
SHIADEP= ${SHIA}
.if !defined(WITH_ED)
-. if exists(${X11BASE}/bin/nedit)
+. if exists(${LOCALBASE}/bin/nedit)
WITH_ED= nedit
-RUN_DEPENDS+= ${X11BASE}/bin/nedit:${PORTSDIR}/editors/nedit
+RUN_DEPENDS+= ${LOCALBASE}/bin/nedit:${PORTSDIR}/editors/nedit
. elif exists(${LOCALBASE}/bin/gvim)
WITH_ED= gvim
RUN_DEPENDS+= ${LOCALBASE}/bin/gvim:${PORTSDIR}/editors/vim
@@ -125,10 +125,10 @@ WITH_ED= gedit
RUN_DEPENDS+= ${LOCALBASE}/bin/gedit:${PORTSDIR}/editors/gedit
. elif exists(${LOCALBASE}/bin/kwrite)
WITH_ED= kwrite
-RUN_DEPENDS+= ${X11BASE}/bin/kwrite:${PORTSDIR}/x11/kdebase3
+RUN_DEPENDS+= ${LOCALBASE}/bin/kwrite:${PORTSDIR}/x11/kdebase3
. elif exists(${LOCALBASE}/bin/xedit)
WITH_ED= xedit
-RUN_DEPENDS+= ${X11BASE}/bin/xedit:${PORTSDIR}/x11/xedit
+RUN_DEPENDS+= ${LOCALBASE}/bin/xedit:${PORTSDIR}/x11/xedit
. else
WITH_ED= vi
. endif
@@ -206,12 +206,12 @@ do-configure:
-e "s#?vaster?#${vaster}#" \
-e "s#?TOOLS_DIR?#${tools_dir}#" ${conf_dir}/outils
${REINPLACE_CMD} -e "s#?HOME_ASTK?#${inst_dir}#" \
- -e "s#?XTERM?#${X11BASE}/bin/xterm#" \
+ -e "s#?XTERM?#${LOCALBASE}/bin/xterm#" \
-e "s#?FULL_SERVER_NAME?#${SERVER_NAME}#" \
-e "s#?SERVER_NAME?#${HOST_NAME}#" \
-e "s#?ASTER_ROOT?#${PREFIX}/aster#" \
-e "s#?EDITOR?#${WITH_ED}#" ${conf_dir}/config_serveurs
- ${REINPLACE_CMD} -e "s#?XTERM?#${X11BASE}/bin/xterm#" \
+ ${REINPLACE_CMD} -e "s#?XTERM?#${LOCALBASE}/bin/xterm#" \
-e "s#?ASTER_VERSION?#${ASTER_VER}#" \
-e "s#langue : ENG#langue : ${ASTK_LANG}#" \
-e "s#?DOMAIN_NAME?#${DOMAIN_NAME}#" \