aboutsummaryrefslogtreecommitdiff
path: root/cad/astk-serveur
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2010-12-29 22:01:55 +0000
committerThierry Thomas <thierry@FreeBSD.org>2010-12-29 22:01:55 +0000
commit94f67d3e038a1cc8f1ed98c0857176ac1e941902 (patch)
tree33d368336bd22697a4f9d68d9fd8590e5e90b1bf /cad/astk-serveur
parent6ae38b227acba6a09e047209b7f5acd79a2bd602 (diff)
downloadports-94f67d3e038a1cc8f1ed98c0857176ac1e941902.tar.gz
ports-94f67d3e038a1cc8f1ed98c0857176ac1e941902.zip
Upgrade to 1.8.4.
Notes
Notes: svn path=/head/; revision=267144
Diffstat (limited to 'cad/astk-serveur')
-rw-r--r--cad/astk-serveur/Makefile16
-rw-r--r--cad/astk-serveur/files.client/pkg-message.in2
-rw-r--r--cad/astk-serveur/files/patch-etc_asrun42
-rw-r--r--cad/astk-serveur/pkg-plist68
4 files changed, 72 insertions, 56 deletions
diff --git a/cad/astk-serveur/Makefile b/cad/astk-serveur/Makefile
index 92a6aa17824d..fc2c95f4bebb 100644
--- a/cad/astk-serveur/Makefile
+++ b/cad/astk-serveur/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= astk
-PORTVERSION= 1.8.3
+PORTVERSION= 1.8.4
CATEGORIES= cad
.if !defined(CLIENT_SEUL)
PKGNAMESUFFIX= -serveur
@@ -29,6 +29,7 @@ COMMENT?= Graphical interface for Code_Aster (server side)
# There exists a "logical" RUN_DEPENDS towards french/aster and french/eficas
# for the server part, but it is not set to avoid circular dependences.
+
RUN_DEPENDS+= ${SHELL_INSTALL_ASTER}:${PORTSDIR}/shells/${SHIADEP}
LICENSE= GPLv2
@@ -39,7 +40,6 @@ USE_PYTHON= yes
NO_BUILD= yes
REINPLACE_ARGS= -i ""
-ASTER_DISTVERSION= ${ASTER_VER}-1
EXTRACT_WRKSRC= ${WRKDIR}/aster-${DISTVERSIONPREFIX}${ASTER_DISTVERSION:S/-/./:R}/SRC
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -49,7 +49,7 @@ aster_dir= ${LOCALBASE}/aster/${vaster}
S_SCRIPTS= bin/as_run bin/parallel_cp asrun/installation.py \
share/codeaster/asrun/data/mpirun_template
S_PYLIBS= share/codeaster/asrun/examples/alamain.py \
- unittest/data/config_serveurs unittest/010_misc.py \
+ unittest/datafiles/config_serveurs unittest/010_misc.py \
unittest/015_package.py unittest/run_test.py
C_SCRIPTS= bin/astk bin/bsf
tools_dir= ${LOCALBASE}/aster/outils
@@ -83,7 +83,10 @@ RUN_DEPENDS+= qsub:${PORTSDIR}/sysutils/torque
. endif
.else
RUN_DEPENDS+= xterm:${PORTSDIR}/x11/xterm \
- wish${TK_VER}:${PORTSDIR}/x11-toolkits/tk${SHORT_TK_VER}
+ wish${TK_VER}:${PORTSDIR}/x11-toolkits/tk${SHORT_TK_VER} \
+ ${LOCALBASE}/lib/${TKPKG}/pkgIndex.tcl:${PORTSDIR}/graphics/tkpng
+TKPKG_VER= 0.9
+TKPKG= tkpng${TKPKG_VER}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/ASTK_CLIENT
PATCHDIR= ${MASTERDIR}/files.client
PLIST_SUB= ASTKDIR=${LINSTDIR}/ASTK_CLIENT SERV="@comment " CLIENT="" vaster="" \
@@ -180,6 +183,9 @@ do-configure:
${REINPLACE_CMD} -e "s|?ASTER_VERSION?|${vaster}|" \
-e 's|#?vers : VVV?|vers : ${vaster}|' \
${WRKSRC}/etc/aster
+ ${REINPLACE_CMD} -e 's|?DEBUGGER_COMMAND_POST?|gdb -batch --command=@D @E @C|'\
+ -e 's|?DEBUGGER_COMMAND?|gdb --dbx --command=@D @E @C|' \
+ ${WRKSRC}/etc/asrun
. if defined(WITH_MPI)
${REINPLACE_CMD} -e "s|?MPIRUN?|${HOME_MPI}/bin/mpirun|" \
-e "s|?ASTER_CONFDIR?|${PREFIX}/aster|" \
@@ -211,7 +217,7 @@ do-configure:
-e "s|/opt/aster|${aster_dir}|" ${WRKSRC}/${libs}
. endfor
. if defined(WITH_PBS)
-. for cf in etc/asrun unittest/data/config_serveurs
+. for cf in etc/asrun unittest/datafiles/config_serveurs
${REINPLACE_CMD} -e "s|batch : non|batch : oui|" \
${WRKSRC}/${cf}
. endfor
diff --git a/cad/astk-serveur/files.client/pkg-message.in b/cad/astk-serveur/files.client/pkg-message.in
index 2d5019e1f020..358f0a81182a 100644
--- a/cad/astk-serveur/files.client/pkg-message.in
+++ b/cad/astk-serveur/files.client/pkg-message.in
@@ -31,5 +31,5 @@ ASTK uses the rcp/rsh protocol: it must be configured (check /etc/inetd.conf
and ~/.rhosts); if you launch astk with the parameter --check, it will check
your configuration.
-ASTK launch xterm with -display: check that Xorg is not launched with
+ASTK launches xterm with -display: check that Xorg is not launched with
-nolisten tcp
diff --git a/cad/astk-serveur/files/patch-etc_asrun b/cad/astk-serveur/files/patch-etc_asrun
index 7a1c924cd974..bdfef809a1b0 100644
--- a/cad/astk-serveur/files/patch-etc_asrun
+++ b/cad/astk-serveur/files/patch-etc_asrun
@@ -1,6 +1,6 @@
---- ./etc/asrun.orig 2009-12-23 15:53:06.000000000 +0100
-+++ ./etc/asrun 2010-01-10 21:19:13.000000000 +0100
-@@ -41,6 +41,10 @@
+--- etc/asrun.orig 2010-12-21 19:08:32.000000000 +0100
++++ etc/asrun 2010-12-27 21:42:25.000000000 +0100
+@@ -38,6 +38,10 @@
# shared folders = for which remote copy is never necessary (comma separated)
shared_folders :
@@ -11,26 +11,7 @@
# choose True to create symbolic links instead of copying executable and catalogs
symlink : True
-@@ -108,12 +112,12 @@
- # batch_job : to display information about jobs
- # batch_kil : to delete jobs
- # --- Sun Grid Engine example
--batch_nom : SunGE
--batch_ini : /opt/SunGE6.0/default/common/settings.sh
--batch_sub : /opt/SunGE6.0/bin/lx24-x86/qsub
--batch_jid : JOB_ID
--batch_job : /opt/SunGE6.0/bin/lx24-x86/qstat
--batch_kil : /opt/SunGE6.0/bin/lx24-x86/qdel
-+#batch_nom : SunGE
-+#batch_ini : /opt/SunGE6.0/default/common/settings.sh
-+#batch_sub : /opt/SunGE6.0/bin/lx24-x86/qsub
-+#batch_jid : JOB_ID
-+#batch_job : /opt/SunGE6.0/bin/lx24-x86/qstat
-+#batch_kil : /opt/SunGE6.0/bin/lx24-x86/qdel
-
- # --- LSF example
- #batch_nom : LSF
-@@ -124,28 +128,28 @@
+@@ -121,28 +125,28 @@
#batch_kil : /usr/share/lsf/6.2/linux2.6-glibc2.3-ia64/bin/bkill
# --- PBS example
@@ -67,7 +48,7 @@
# shell command to get processor id
# LAM/MPI : echo $LAMRANK
-@@ -172,8 +176,11 @@
+@@ -170,8 +174,11 @@
# ps commands : uncomment lines corresponding to your platform
#ps_cpu : /bin/ps -e --width=512 -ocputime -ocommand
#ps_pid : /bin/ps -e --width=512 -opid -ocommand
@@ -81,16 +62,3 @@
#-------------------------------------------------------------------------------
# debug command :
-@@ -182,10 +189,9 @@
- # @D will be remplaced by the filename which contains "where+quit"
- # @d will be remplaced by the string 'where ; quit'
- #
--#cmd_post : gdb -batch --command=@D @E @C
-+cmd_post : gdb -batch --command=@D @E @C
- #cmd_dbg : ddd --debugger gdb --command=@D @E @C
--cmd_post : ?DEBUGGER_COMMAND_POST?
--cmd_dbg : ?DEBUGGER_COMMAND?
-+cmd_dbg : gdb --dbx --command=@D @E @C
-
- #-------------------------------------------------------------------------------
- # style of ctags used (optionnal, leave commented to ignore ctags generation)
diff --git a/cad/astk-serveur/pkg-plist b/cad/astk-serveur/pkg-plist
index 3409ac7f1352..c8ab755bd937 100644
--- a/cad/astk-serveur/pkg-plist
+++ b/cad/astk-serveur/pkg-plist
@@ -38,6 +38,38 @@
%%CLIENT%%%%ASTKDIR%%/lib/fichier.tcl
%%CLIENT%%%%ASTKDIR%%/lib/file_funct.tcl
%%CLIENT%%%%ASTKDIR%%/lib/i_serv.tcl
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_button_cancel.gif
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_button_cancel.png
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_delete.gif
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_delete.png
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_downarrow.gif
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_downarrow.png
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_edit.gif
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_edit.png
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_empty.gif
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_empty.png
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_filenew.gif
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_filenew.png
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_fileopen.gif
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_fileopen.png
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_folder.gif
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_folder.png
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_folder_open.gif
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_folder_open.png
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_help.gif
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_help.png
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_iconwindow.gif
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_iconwindow.png
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_openterm.gif
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_openterm.png
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_reload.gif
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_reload.png
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_salome.gif
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_salome.png
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_up.gif
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_up.png
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_uparrow.gif
+%%CLIENT%%%%ASTKDIR%%/lib/icons/ambiance_uparrow.png
%%CLIENT%%%%ASTKDIR%%/lib/icons/astk.png
%%CLIENT%%%%ASTKDIR%%/lib/icons/crystalsvg_22_1downarrow.gif
%%CLIENT%%%%ASTKDIR%%/lib/icons/crystalsvg_22_1uparrow.gif
@@ -218,6 +250,9 @@
%%SERV%%%%ASTKDIR%%/asrun/common/i18n.py
%%SERV%%%%ASTKDIR%%/asrun/common/i18n.pyc
%%SERV%%%%ASTKDIR%%/asrun/common/i18n.pyo
+%%SERV%%%%ASTKDIR%%/asrun/common/lockfile.py
+%%SERV%%%%ASTKDIR%%/asrun/common/lockfile.pyc
+%%SERV%%%%ASTKDIR%%/asrun/common/lockfile.pyo
%%SERV%%%%ASTKDIR%%/asrun/common/rcfile.py
%%SERV%%%%ASTKDIR%%/asrun/common/rcfile.pyc
%%SERV%%%%ASTKDIR%%/asrun/common/rcfile.pyo
@@ -245,6 +280,9 @@
%%SERV%%%%ASTKDIR%%/asrun/contrib/__init__.py
%%SERV%%%%ASTKDIR%%/asrun/contrib/__init__.pyc
%%SERV%%%%ASTKDIR%%/asrun/contrib/__init__.pyo
+%%SERV%%%%ASTKDIR%%/asrun/contrib/log_usage.py
+%%SERV%%%%ASTKDIR%%/asrun/contrib/log_usage.pyc
+%%SERV%%%%ASTKDIR%%/asrun/contrib/log_usage.pyo
%%SERV%%%%ASTKDIR%%/asrun/core/__init__.py
%%SERV%%%%ASTKDIR%%/asrun/core/__init__.pyc
%%SERV%%%%ASTKDIR%%/asrun/core/__init__.pyo
@@ -263,6 +301,9 @@
%%SERV%%%%ASTKDIR%%/asrun/dev/messages.py
%%SERV%%%%ASTKDIR%%/asrun/dev/messages.pyc
%%SERV%%%%ASTKDIR%%/asrun/dev/messages.pyo
+%%SERV%%%%ASTKDIR%%/asrun/dev/routines.py
+%%SERV%%%%ASTKDIR%%/asrun/dev/routines.pyc
+%%SERV%%%%ASTKDIR%%/asrun/dev/routines.pyo
%%SERV%%%%ASTKDIR%%/asrun/distrib.py
%%SERV%%%%ASTKDIR%%/asrun/distrib.pyc
%%SERV%%%%ASTKDIR%%/asrun/distrib.pyo
@@ -435,18 +476,19 @@
%%SERV%%%%ASTKDIR%%/unittest/data.py
%%SERV%%%%ASTKDIR%%/unittest/data.pyc
%%SERV%%%%ASTKDIR%%/unittest/data.pyo
-%%SERV%%%%ASTKDIR%%/unittest/data/astout.list
-%%SERV%%%%ASTKDIR%%/unittest/data/astout_dvp.list
-%%SERV%%%%ASTKDIR%%/unittest/data/chg_capy.comm
-%%SERV%%%%ASTKDIR%%/unittest/data/config_serveurs
-%%SERV%%%%ASTKDIR%%/unittest/data/forma01a.mmed
-%%SERV%%%%ASTKDIR%%/unittest/data/hostfile
-%%SERV%%%%ASTKDIR%%/unittest/data/parametric.distr
-%%SERV%%%%ASTKDIR%%/unittest/data/parametric.pre.include
-%%SERV%%%%ASTKDIR%%/unittest/data/poursuite.comm
-%%SERV%%%%ASTKDIR%%/unittest/data/sleep.comm
-%%SERV%%%%ASTKDIR%%/unittest/data/study.comm
-%%SERV%%%%ASTKDIR%%/unittest/data/with_win_CR.export
+%%SERV%%%%ASTKDIR%%/unittest/datafiles/astout.list
+%%SERV%%%%ASTKDIR%%/unittest/datafiles/astout_dvp.list
+%%SERV%%%%ASTKDIR%%/unittest/datafiles/chg_capy.comm
+%%SERV%%%%ASTKDIR%%/unittest/datafiles/config_serveurs
+%%SERV%%%%ASTKDIR%%/unittest/datafiles/forma01a.mmed
+%%SERV%%%%ASTKDIR%%/unittest/datafiles/hostfile
+%%SERV%%%%ASTKDIR%%/unittest/datafiles/parametric.distr
+%%SERV%%%%ASTKDIR%%/unittest/datafiles/parametric.pre.include
+%%SERV%%%%ASTKDIR%%/unittest/datafiles/poursuite.comm
+%%SERV%%%%ASTKDIR%%/unittest/datafiles/sleep.comm
+%%SERV%%%%ASTKDIR%%/unittest/datafiles/study.comm
+%%SERV%%%%ASTKDIR%%/unittest/datafiles/test_profile.sh
+%%SERV%%%%ASTKDIR%%/unittest/datafiles/with_win_CR.export
%%SERV%%%%ASTKDIR%%/unittest/run_test.py
%%SERV%%%%ASTKDIR%%/unittest/run_test.pyc
%%SERV%%%%ASTKDIR%%/unittest/run_test.pyo
@@ -460,7 +502,7 @@
%%CLIENT%%@dirrm %%BWidget_DIR%%/images
%%CLIENT%%@dirrm %%BWidget_DIR%%/lang
%%CLIENT%%@dirrm %%BWidget_DIR%%
-%%SERV%%@dirrm %%ASTKDIR%%/unittest/data
+%%SERV%%@dirrm %%ASTKDIR%%/unittest/datafiles
%%SERV%%@dirrm %%ASTKDIR%%/unittest
%%SERV%%@dirrm %%ASTKDIR%%/share/codeaster/asrun/examples
%%SERV%%@dirrm %%ASTKDIR%%/share/codeaster/asrun/data