aboutsummaryrefslogtreecommitdiff
path: root/cad/calculix-ccx
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-09-12 15:18:06 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-10-03 17:47:27 +0000
commit07fb2d5e9d001934f1670d01aec1f536f14ebde2 (patch)
treef2f87572cb6aa68955a9057625ca5ed1acbb394a /cad/calculix-ccx
parente8b8483aa7832bea5fdc062db342a76255d6281b (diff)
downloadports-07fb2d5e9d001934f1670d01aec1f536f14ebde2.tar.gz
ports-07fb2d5e9d001934f1670d01aec1f536f14ebde2.zip
*/*: Remove compiler:openmp from Mk/Uses/compiler.mk
The option implied a dependency on gcc but clang got openmp support long ago. Remove compiler:openmp from Mk/Uses/compiler.mk For ports using USE=compiler:openmp, just remove it and make them build with clang. Fix conditionals when necessary Bump PORTREVISION where appropriate If problem arises, they can be addressed by using USE_GCC=yes An update to the Porter's Handbook will follow. Approved by: portmgr (bapt) Differential Revision: https://reviews.freebsd.org/D31971
Diffstat (limited to 'cad/calculix-ccx')
-rw-r--r--cad/calculix-ccx/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/cad/calculix-ccx/Makefile b/cad/calculix-ccx/Makefile
index c5733de025f5..3807d9a7ea8d 100644
--- a/cad/calculix-ccx/Makefile
+++ b/cad/calculix-ccx/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ccx
PORTVERSION= 2.17
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= cad
MASTER_SITES= http://www.dhondt.de/
PKGNAMEPREFIX= CalculiX-
@@ -18,7 +18,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libarpack.so:math/arpack-ng \
libspooles.so:math/spooles
-USES= blaslapack compiler:openmp fortran gmake perl5 tar:bzip2
+USES= blaslapack fortran gmake perl5 tar:bzip2
USE_PERL5= build
DIST_SOURCES= ccx_${PORTVERSION}.src${EXTRACT_SUFX}