aboutsummaryrefslogtreecommitdiff
path: root/cad/electric
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-20 02:32:14 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-20 02:32:14 +0000
commit972fda0d8fe45dc597990f8c4d47ebeb0122bf87 (patch)
treee2ac4a8bc1fcc1688ffd041101551d0387cb03fe /cad/electric
parent0769d3f48e824a405d197c2461e5f7db62fe1dcc (diff)
downloadports-972fda0d8fe45dc597990f8c4d47ebeb0122bf87.tar.gz
ports-972fda0d8fe45dc597990f8c4d47ebeb0122bf87.zip
Update to 6.0.6
Notes
Notes: svn path=/head/; revision=66773
Diffstat (limited to 'cad/electric')
-rw-r--r--cad/electric/Makefile8
-rw-r--r--cad/electric/distinfo2
-rw-r--r--cad/electric/files/patch-src::graph::graphunixx11.c26
-rw-r--r--cad/electric/pkg-plist4
4 files changed, 35 insertions, 5 deletions
diff --git a/cad/electric/Makefile b/cad/electric/Makefile
index a8bd187e71ed..cfa173afdda8 100644
--- a/cad/electric/Makefile
+++ b/cad/electric/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= electric
-PORTVERSION= 6.0.5
+PORTVERSION= 6.0.6
CATEGORIES= cad
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,12 +20,12 @@ USE_MOTIF= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= -with-x
-INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
-
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local/lib/electric/|${PREFIX}/share/electric/lib/|; \
s|/usr/local/|${PREFIX}/|' ${WRKSRC}/src/include/config.h
- @${REINPLACE_CMD} -e 's|/lib/electric|/share/electric/lib|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|/lib/electric|/share/electric/lib|; \
+ s|@PTHREAD_LIBS@|${PTHREAD_LIBS:S/"//g}|' \
+ ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|/usr/X11R6/|${X11BASE}/|' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/cad/electric/distinfo b/cad/electric/distinfo
index 8f83b584fec3..cc9fd3dfd9af 100644
--- a/cad/electric/distinfo
+++ b/cad/electric/distinfo
@@ -1 +1 @@
-MD5 (electric-6.05.tar.gz) = 3fdf248897d76bd13c1dfb36de953d18
+MD5 (electric-6.06.tar.gz) = 17848541e74307e0a320b360765fd4d2
diff --git a/cad/electric/files/patch-src::graph::graphunixx11.c b/cad/electric/files/patch-src::graph::graphunixx11.c
new file mode 100644
index 000000000000..cb008da2ba80
--- /dev/null
+++ b/cad/electric/files/patch-src::graph::graphunixx11.c
@@ -0,0 +1,26 @@
+--- src/graph/graphunixx11.c.orig Fri Jun 14 20:01:11 2002
++++ src/graph/graphunixx11.c Thu Sep 19 23:30:14 2002
+@@ -149,6 +149,8 @@
+ INTBIG gra_initializetcl(void);
+ #endif
+
++#include <sys/sysctl.h>
++
+ /****** windows ******/
+
+ #define WMLEFTBORDER 8 /* size of left border for windows */
+@@ -2889,8 +2891,13 @@
+ INTBIG enumprocessors(void)
+ {
+ INTBIG numproc;
++ size_t proclen;
++
++ proclen = sizeof(numproc);
++ if ((sysctlbyname("hw.ncpu", &numproc, &proclen, NULL, 0) < 0) ||
++ (proclen != sizeof(numproc)))
++ numproc = 1;
+
+- numproc = sysconf(_SC_NPROCESSORS_ONLN);
+ return(numproc);
+ }
+
diff --git a/cad/electric/pkg-plist b/cad/electric/pkg-plist
index cdc6d64f9529..3fa4873516d4 100644
--- a/cad/electric/pkg-plist
+++ b/cad/electric/pkg-plist
@@ -10,10 +10,14 @@ share/electric/lib/evetutor.mac
share/electric/lib/international/fr/LC_MESSAGES/electric.mo
share/electric/lib/international/fr/LC_MESSAGES/license.txt
share/electric/lib/international/messages.po
+share/electric/lib/leparts.txt
share/electric/lib/pads4u.txt
share/electric/lib/pla_mocmos.txt
share/electric/lib/sclib.txt
+share/electric/lib/spiceparts.mac
share/electric/lib/spiceparts.txt
+share/electric/lib/spicepartsS3.mac
+share/electric/lib/spicepartsS3.txt
share/electric/lib/tsmc25.txt
share/electric/lib/umc18.txt
@dirrm share/electric/lib/international/fr/LC_MESSAGES