aboutsummaryrefslogtreecommitdiff
path: root/cad/fasm
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-10-27 01:00:18 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-10-27 01:00:18 +0000
commit9974b99d68bebf360c460d87f6ab227632fd0007 (patch)
treeed8bd2edde2368771bc39b518fcc2a0d433d2b0b /cad/fasm
parentb6812a7e0292d13847f9f6138e2eb124784ae640 (diff)
downloadports-9974b99d68bebf360c460d87f6ab227632fd0007.tar.gz
ports-9974b99d68bebf360c460d87f6ab227632fd0007.zip
New port: cad/fasm: FPGA assembly (FASM) parser and generator
Notes
Notes: svn path=/head/; revision=515742
Diffstat (limited to 'cad/fasm')
-rw-r--r--cad/fasm/Makefile23
-rw-r--r--cad/fasm/distinfo3
-rw-r--r--cad/fasm/pkg-descr7
3 files changed, 33 insertions, 0 deletions
diff --git a/cad/fasm/Makefile b/cad/fasm/Makefile
new file mode 100644
index 000000000000..96f254c620d5
--- /dev/null
+++ b/cad/fasm/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= fasm
+PORTVERSION= g20190920
+CATEGORIES= cad python
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= FPGA assembly (FASM) parser and generator
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}textX>0:lang/py-textX@${PY_FLAVOR}
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= SymbiFlow
+GH_TAGNAME= b8db365
+USE_PYTHON= distutils concurrent noflavors autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/cad/fasm/distinfo b/cad/fasm/distinfo
new file mode 100644
index 000000000000..cbfb62398dab
--- /dev/null
+++ b/cad/fasm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1572137905
+SHA256 (SymbiFlow-fasm-g20190920-b8db365_GH0.tar.gz) = eff6550ce5c6dff464b26c5fc8d7e4ff335289b1e9475bbc8a1b403ac305fe23
+SIZE (SymbiFlow-fasm-g20190920-b8db365_GH0.tar.gz) = 57454
diff --git a/cad/fasm/pkg-descr b/cad/fasm/pkg-descr
new file mode 100644
index 000000000000..6fa0263bd428
--- /dev/null
+++ b/cad/fasm/pkg-descr
@@ -0,0 +1,7 @@
+FPGA Assembly is a file format designed by the SymbiFlow Project developers to
+provide a plain text file format for configuring the internals of an FPGA.
+
+It is designed to allow FPGA place and route to not care about the actual
+bitstream format used on an FPGA.
+
+WWW: https://github.com/SymbiFlow/fasm