aboutsummaryrefslogtreecommitdiff
path: root/cad/fidocadj
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2012-05-05 16:51:14 +0000
committerNicola Vitale <nivit@FreeBSD.org>2012-05-05 16:51:14 +0000
commit57c32dd687a6cde808b648bcda1a2b2023ab355c (patch)
treebcb2ed9a9bcfe291ffe68c3c5eebb0391aaf5271 /cad/fidocadj
parentd5944a32e9015fe219cd5024e4ca1c34594e9c9f (diff)
downloadports-57c32dd687a6cde808b648bcda1a2b2023ab355c.tar.gz
ports-57c32dd687a6cde808b648bcda1a2b2023ab355c.zip
FidoCadJ is an easy to use graphical editor, with a library of electrical
symbols and footprints (traditional and SMD). It aims to be an agile and effective small EDA tool for hobbyists. FidoCadJ stores its drawings in a compact text format, practical for the copy and paste in newsgroups and forums: this has determined its success on the Usenet and in numerous communities. WWW: http://davbucci.chez-alice.fr/index.php?argument=elettronica/fidocadj/fidocadj.inc
Notes
Notes: svn path=/head/; revision=296050
Diffstat (limited to 'cad/fidocadj')
-rw-r--r--cad/fidocadj/Makefile45
-rw-r--r--cad/fidocadj/distinfo4
-rw-r--r--cad/fidocadj/files/fidocadj.sh.in5
-rw-r--r--cad/fidocadj/pkg-descr9
-rw-r--r--cad/fidocadj/pkg-plist6
5 files changed, 69 insertions, 0 deletions
diff --git a/cad/fidocadj/Makefile b/cad/fidocadj/Makefile
new file mode 100644
index 000000000000..6a781bfe3e27
--- /dev/null
+++ b/cad/fidocadj/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: fidocadj
+# Date created: 2012-05-02
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fidocadj
+PORTVERSION= 0.23.7
+#PORTREVISION= 0
+CATEGORIES= cad
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= ${PORTNAME}.jar
+.if !defined(NOPORTDOCS)
+DISTFILES+= ${PORTNAME}_manual_en.pdf
+.endif
+EXTRACT_ONLY=
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= An easy to use graphical editor for electronics
+
+LICENSE= GPLv3
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+
+NO_BUILD= yes
+
+SUB_FILES= ${PORTNAME}.sh
+
+JAVA_VERSION= 1.5+
+USE_JAVA= yes
+
+FDCJ_MANUAL= ${PORTNAME}_manual_en.pdf
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
+ ${MKDIR} ${DATADIR}; \
+ ${INSTALL_DATA} ${DISTDIR}/${PORTNAME}.jar ${DATADIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR} && \
+ ${INSTALL_DATA} ${DISTDIR}/${FDCJ_MANUAL} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/cad/fidocadj/distinfo b/cad/fidocadj/distinfo
new file mode 100644
index 000000000000..6368beeda566
--- /dev/null
+++ b/cad/fidocadj/distinfo
@@ -0,0 +1,4 @@
+SHA256 (fidocadj.jar) = 94e6e6c67913c8312d00a2bc7b37715db6f3934aff2ded888a30426b25af892c
+SIZE (fidocadj.jar) = 419310
+SHA256 (fidocadj_manual_en.pdf) = 5020e01a6d37b35647917785901b58d4229be2fdb65784766de2b28ca8ad6132
+SIZE (fidocadj_manual_en.pdf) = 2435667
diff --git a/cad/fidocadj/files/fidocadj.sh.in b/cad/fidocadj/files/fidocadj.sh.in
new file mode 100644
index 000000000000..71c4e3ec855f
--- /dev/null
+++ b/cad/fidocadj/files/fidocadj.sh.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -jar "%%DATADIR%%/fidocadj.jar" "$@"
diff --git a/cad/fidocadj/pkg-descr b/cad/fidocadj/pkg-descr
new file mode 100644
index 000000000000..3b351bf0c63f
--- /dev/null
+++ b/cad/fidocadj/pkg-descr
@@ -0,0 +1,9 @@
+FidoCadJ is an easy to use graphical editor, with a library of electrical
+symbols and footprints (traditional and SMD). It aims to be an agile and
+effective small EDA tool for hobbyists.
+
+FidoCadJ stores its drawings in a compact text format, practical for the
+copy and paste in newsgroups and forums: this has determined its success
+on the Usenet and in numerous communities.
+
+WWW: http://davbucci.chez-alice.fr/index.php?argument=elettronica/fidocadj/fidocadj.inc
diff --git a/cad/fidocadj/pkg-plist b/cad/fidocadj/pkg-plist
new file mode 100644
index 000000000000..aff4eb911e17
--- /dev/null
+++ b/cad/fidocadj/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+bin/fidocadj
+%%DATADIR%%/fidocadj.jar
+%%PORTDOCS%%%%DOCSDIR%%/fidocadj_manual_en.pdf
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%