aboutsummaryrefslogtreecommitdiff
path: root/cad/geda
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-23 20:27:55 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-23 20:27:55 +0000
commit2913e108ba4a60bc1ccb6ca27f6b3c02bdd5102e (patch)
tree65c12df1e5c3628ca9e8b7f82c5494d5cce83076 /cad/geda
parentfd08f4f2ed0a095f1fe0c092c3bde0f04a8cb6ea (diff)
downloadports-2913e108ba4a60bc1ccb6ca27f6b3c02bdd5102e.tar.gz
ports-2913e108ba4a60bc1ccb6ca27f6b3c02bdd5102e.zip
cad/geda: Unbreak on FreeBSD 11
PR: 192786 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=365808
Diffstat (limited to 'cad/geda')
-rw-r--r--cad/geda/Makefile12
-rw-r--r--cad/geda/files/patch-libgeda__src__scheme_object.c13
2 files changed, 18 insertions, 7 deletions
diff --git a/cad/geda/Makefile b/cad/geda/Makefile
index bf0cc459c8fb..ee03b299353c 100644
--- a/cad/geda/Makefile
+++ b/cad/geda/Makefile
@@ -3,7 +3,7 @@
PORTNAME= geda
PORTVERSION= 1.8.2
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= http://ftp.geda-project.org/geda-gaf/stable/%SUBDIR%/
@@ -19,10 +19,8 @@ LIB_DEPENDS= libstroke.so:${PORTSDIR}/devel/libstroke \
libguile.so:${PORTSDIR}/lang/guile
RUN_DEPENDS= gawk:${PORTSDIR}/lang/gawk
-OPTIONS_DEFINE= DOCS
-
-USES= desktop-file-utils gettext gmake pathfix libtool perl5 \
- pkgconfig shared-mime-info shebangfix
+USES= desktop-file-utils gettext gmake libtool pathfix perl5 \
+ pkgconfig python:run shared-mime-info shebangfix
SHEBANG_FILES= examples/lightning_detector/bom libgeda/docs/*.dox \
utils/gxyrs/*.pl utils/scripts/* \
utils/docs/*.dox gattrib/docs/*.dox \
@@ -30,9 +28,9 @@ SHEBANG_FILES= examples/lightning_detector/bom libgeda/docs/*.dox \
gnetlist/docs/*.dox
USE_GNOME= gtk20
USE_PERL5= run
-USE_PYTHON_RUN= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libstroke=${LOCALBASE}
+INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
@@ -50,7 +48,7 @@ CONFLICTS= geda-docs-[0-9]* geda-examples-[0-9]* geda-gattrib-[0-9]* \
PORTSCOUT= limitw:1,even
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-patch:
.for dir in gattrib gschem libgeda
diff --git a/cad/geda/files/patch-libgeda__src__scheme_object.c b/cad/geda/files/patch-libgeda__src__scheme_object.c
new file mode 100644
index 000000000000..2cfdabebc8db
--- /dev/null
+++ b/cad/geda/files/patch-libgeda__src__scheme_object.c
@@ -0,0 +1,13 @@
+--- libgeda/src/scheme_object.c.orig
++++ libgeda/src/scheme_object.c
+@@ -1986,8 +1986,8 @@
+ * \param filename_s New filename for \a obj_s.
+ * \return \a obj_s.
+ */
+-SCM_DEFINE (set_picture_data_vector_x, "%set-picture-data/vector!",
+- 3, 0, 0, (SCM obj_s, SCM data_s, SCM filename_s),
++SCM_DEFINE (set_picture_data_vector_x, "%set-picture-data/vector!", 3, 0, 0,
++ (SCM obj_s, SCM data_s, SCM filename_s),
+ "Set a picture object's data from a vector.")
+ {
+ SCM vec_s = scm_any_to_s8vector (data_s);