aboutsummaryrefslogtreecommitdiff
path: root/cad/gspiceui/files
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2015-11-08 10:53:51 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2015-11-08 10:53:51 +0000
commitcd351e43751bafe2032076984d2fcfb239d8dad7 (patch)
tree1d110294b8e98c90d09dd9734c20dd7ce7d2325f /cad/gspiceui/files
parentff33c0ed8e73c7a2d2b4799d29989428656b00a8 (diff)
downloadports-cd351e43751bafe2032076984d2fcfb239d8dad7.tar.gz
ports-cd351e43751bafe2032076984d2fcfb239d8dad7.zip
Notes
Diffstat (limited to 'cad/gspiceui/files')
-rw-r--r--cad/gspiceui/files/patch-src_Makefile35
-rw-r--r--cad/gspiceui/files/patch-src_TypeDefs.hpp25
2 files changed, 60 insertions, 0 deletions
diff --git a/cad/gspiceui/files/patch-src_Makefile b/cad/gspiceui/files/patch-src_Makefile
new file mode 100644
index 000000000000..1dd97ea94cdc
--- /dev/null
+++ b/cad/gspiceui/files/patch-src_Makefile
@@ -0,0 +1,35 @@
+--- src/Makefile.orig 2015-03-29 12:25:24 UTC
++++ src/Makefile
+@@ -38,13 +38,12 @@ DESTDIR = /usr/local/bin
+ #***************************************************************************************************
+
+ # Which compiler
+-CXX = g++
+
+ # Application name
+ PROG = gspiceui
+
+ # wxWidgets configuration utility
+-WXCFG = wx-config --unicode --version=$(GSPICEUI_WXLIB)
++WXCFG = $(WX_CONFIG)
+
+ # Dependency file
+ DEPS = Makefile.deps
+@@ -71,7 +70,7 @@ BINDIR = $(ROOT)/bin
+ # -Og Optimize debugging experience but don't break debugging
+ ifeq ($(GSPICEUI_DBG),0)
+ # Options for release (not using -Wall since it's GCC specific)
+- CXXFLAGS := -O1 -pipe $(shell $(WXCFG) --cxxflags)
++ CXXFLAGS += $(shell $(WXCFG) --cxxflags)
+ else
+ # Options for development
+ CXXFLAGS := -g -Og -Wall -Wextra -pipe $(shell $(WXCFG) --cxxflags)
+@@ -83,7 +82,7 @@ ifeq ($(GSPICEUI_WXLIB),2.8)
+ endif
+
+ # Includes
+-INCLUDES = -I/usr/include -I/usr/X11R6/include -I.
++INCLUDES = -I.
+
+ # Libraries
+ # (The pkg-config stuff was requested by a user, somehow pangox was missing)
diff --git a/cad/gspiceui/files/patch-src_TypeDefs.hpp b/cad/gspiceui/files/patch-src_TypeDefs.hpp
new file mode 100644
index 000000000000..b71877da8461
--- /dev/null
+++ b/cad/gspiceui/files/patch-src_TypeDefs.hpp
@@ -0,0 +1,25 @@
+--- src/TypeDefs.hpp.orig 2015-04-06 10:28:07 UTC
++++ src/TypeDefs.hpp
+@@ -57,16 +57,18 @@ extern bool g_bDebug; // Declared in
+ //**************************************************************************************************
+ // Type definitions
+
+-//typedef unsigned long ulong;
+-//typedef unsigned int uint;
+-//typedef unsigned char uchar;
++#ifdef __BSD__
++typedef unsigned long ulong;
++typedef unsigned int uint;
++typedef unsigned char uchar;
++#endif
+
+ typedef wxStaticText wxLabel;
+
+ //**************************************************************************************************
+ // Operating System specific macro declarations
+
+-#ifdef __WXOSX__
++#if defined(__WXOSX__) || defined(__BSD__)
+ #define EXP10(X) pow(10.0,X)
+ #define EXP10F(X) powf(10.0,X)
+ #else