aboutsummaryrefslogtreecommitdiff
path: root/cad/gtkwave
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2023-11-25 13:12:35 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2023-11-25 22:20:06 +0000
commit6873e16acf25ad9734069631fce0ee41b0b19dd3 (patch)
treee15bd8fe5ec08ff8df82cd37ba2338a83d2c7910 /cad/gtkwave
parent3160b608d187efa67490d53d181f47159f8c605f (diff)
downloadports-6873e16acf25ad9734069631fce0ee41b0b19dd3.tar.gz
ports-6873e16acf25ad9734069631fce0ee41b0b19dd3.zip
Diffstat (limited to 'cad/gtkwave')
-rw-r--r--cad/gtkwave/Makefile9
-rw-r--r--cad/gtkwave/distinfo6
-rw-r--r--cad/gtkwave/files/patch-Makefile.in6
-rw-r--r--cad/gtkwave/files/patch-configure4
-rw-r--r--cad/gtkwave/files/patch-examples__Makefile.in8
5 files changed, 17 insertions, 16 deletions
diff --git a/cad/gtkwave/Makefile b/cad/gtkwave/Makefile
index b532636fc942..2343476688ce 100644
--- a/cad/gtkwave/Makefile
+++ b/cad/gtkwave/Makefile
@@ -1,7 +1,9 @@
PORTNAME= gtkwave
DISTVERSION= 3.3.117
+PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= http://gtkwave.sourceforge.net/
+DISTNAME= ${PORTNAME}-gtk3-${DISTVERSION}
MAINTAINER= eduardo@FreeBSD.org
COMMENT= Electronic Waveform Viewer
@@ -10,16 +12,15 @@ WWW= https://gtkwave.sourceforge.net/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2 \
- libharfbuzz.so:print/harfbuzz
+LIB_DEPENDS= libharfbuzz.so:print/harfbuzz
USES= compiler:c++11-lang desktop-file-utils gettext gmake gnome \
gperf pkgconfig shared-mime-info
-USE_GNOME= cairo gdkpixbuf2 gtk20
+USE_GNOME= cairo gdkpixbuf2 gtk30
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-mime-update \
+ --enable-gtk3 \
--without-gconf
PORTDOCS= gtkwave.odt
diff --git a/cad/gtkwave/distinfo b/cad/gtkwave/distinfo
index b17a0ee3d291..aa748028bfde 100644
--- a/cad/gtkwave/distinfo
+++ b/cad/gtkwave/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1692191386
-SHA256 (gtkwave-3.3.117.tar.gz) = 55520fc308244c5dc99d5a3f42f5e782eb8e6a9e81cece5c84ea3f11875bff13
-SIZE (gtkwave-3.3.117.tar.gz) = 3506108
+TIMESTAMP = 1700906356
+SHA256 (gtkwave-gtk3-3.3.117.tar.gz) = 3cf1537586a911cbb0601af8fa18cf6da708c8a14a71f69ce3cb9118e8571db9
+SIZE (gtkwave-gtk3-3.3.117.tar.gz) = 3332677
diff --git a/cad/gtkwave/files/patch-Makefile.in b/cad/gtkwave/files/patch-Makefile.in
index 8ba3eeab6792..f4a762169d3f 100644
--- a/cad/gtkwave/files/patch-Makefile.in
+++ b/cad/gtkwave/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- Makefile.in.orig 2017-10-08 05:44:27 UTC
+--- Makefile.in.orig 2023-08-13 22:32:40 UTC
+++ Makefile.in
-@@ -340,7 +340,7 @@ target_alias = @target_alias@
+@@ -345,7 +345,7 @@ top_srcdir = @top_srcdir@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-SUBDIRS = doc examples man src contrib share
+SUBDIRS = examples man src contrib share
EXTRA_DIST = ChangeLog COPYING INSTALL LICENSE.TXT README NEWS AUTHORS \
- autogen.sh wave_locale.h tcl.m4
+ autogen.sh wave_locale.h tcl.m4 changes_from_gtk2.txt
diff --git a/cad/gtkwave/files/patch-configure b/cad/gtkwave/files/patch-configure
index 8262d0c34abc..d03ea3cf91a9 100644
--- a/cad/gtkwave/files/patch-configure
+++ b/cad/gtkwave/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2017-10-08 05:44:27 UTC
+--- configure.orig 2023-08-13 22:32:40 UTC
+++ configure
-@@ -10293,6 +10293,7 @@ OLD_LDFLAGS="${LDFLAGS}"
+@@ -10820,6 +10820,7 @@ LDFLAGS="${LDFLAGS} ${TCLSPEC_LHS} ${TKLSPEC_LHS}"
TCLSPEC_LHS="${TCL_LIB_SPEC% *}"
TKLSPEC_LHS="${TK_LIB_SPEC% *}"
LDFLAGS="${LDFLAGS} ${TCLSPEC_LHS} ${TKLSPEC_LHS}"
diff --git a/cad/gtkwave/files/patch-examples__Makefile.in b/cad/gtkwave/files/patch-examples__Makefile.in
index b62bf3638a94..96165ea2c05c 100644
--- a/cad/gtkwave/files/patch-examples__Makefile.in
+++ b/cad/gtkwave/files/patch-examples__Makefile.in
@@ -1,6 +1,6 @@
---- examples/Makefile.in.orig 2018-03-05 23:07:23 UTC
+--- examples/Makefile.in.orig 2023-08-13 22:32:41 UTC
+++ examples/Makefile.in
-@@ -60,7 +60,7 @@ am__make_running_with_option = \
+@@ -60,7 +60,7 @@ am__make_keepgoing = (target_option=k; $(am__make_runn
test $$has_opt = yes
am__make_dryrun = (target_option=n; $(am__make_running_with_option))
am__make_keepgoing = (target_option=k; $(am__make_running_with_option))
@@ -9,12 +9,12 @@
pkgincludedir = $(includedir)/@PACKAGE@
pkglibdir = $(libdir)/@PACKAGE@
pkglibexecdir = $(libexecdir)/@PACKAGE@
-@@ -292,7 +292,7 @@ top_build_prefix = @top_build_prefix@
+@@ -293,7 +293,7 @@ dist_examples_DATA = des.gtkw des.tcl des.v des.fst tr
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
dist_examples_DATA = des.gtkw des.tcl des.v des.fst transaction.fst transaction.gtkw transaction.c gtkwaverc sst_exclusion_example.rc
-examplesdir = $(pkgdatadir)/examples
-+examplesdir = $(pkgdatadir)/examples/@PACKAGE@
++examplesdir = $(pkgdatadir)/examples/gtkwave
all: all-am
.SUFFIXES: