aboutsummaryrefslogtreecommitdiff
path: root/cad/horizon-eda
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-08-07 04:03:30 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-08-07 04:03:30 +0000
commit08b224b002e57bc552941fe37b606592435bbfa4 (patch)
tree9e86bfb7e55e656a59014cd7ed55ff18aca51a79 /cad/horizon-eda
parentfc03c50eeeb49b187f0a32b67d0c2c63014991b6 (diff)
downloadports-08b224b002e57bc552941fe37b606592435bbfa4.tar.gz
ports-08b224b002e57bc552941fe37b606592435bbfa4.zip
New port: cad/horizon-eda: EDA package for printed circuit board design
Notes
Notes: svn path=/head/; revision=544311
Diffstat (limited to 'cad/horizon-eda')
-rw-r--r--cad/horizon-eda/Makefile41
-rw-r--r--cad/horizon-eda/distinfo5
-rw-r--r--cad/horizon-eda/files/patch-Makefile11
-rw-r--r--cad/horizon-eda/pkg-descr5
-rw-r--r--cad/horizon-eda/pkg-plist9
5 files changed, 71 insertions, 0 deletions
diff --git a/cad/horizon-eda/Makefile b/cad/horizon-eda/Makefile
new file mode 100644
index 000000000000..e3aec143327f
--- /dev/null
+++ b/cad/horizon-eda/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= horizon-eda
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.2.1
+CATEGORIES= cad
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES= b40e3ed3f92c4b28af307135223ecf05eacecc82.patch:-p1 # backport the build failure fix
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= EDA package for printed circuit board design
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/optional.hpp:devel/boost-libs \
+ cppzmq>0:net/cppzmq \
+ glm>0:math/glm
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libepoxy.so:graphics/libepoxy \
+ libgit2.so:devel/libgit2 \
+ libpodofo.so:graphics/podofo \
+ libTKSTEP.so:cad/opencascade \
+ libuuid.so:misc/e2fsprogs-libuuid \
+ libzip.so:archivers/libzip \
+ libzmq.so:net/libzmq4
+
+USES= compiler:c++17-lang gmake gnome localbase pkgconfig python:build sqlite
+USE_GITHUB= yes
+GH_PROJECT= horizon
+USE_GNOME= atkmm gdkpixbuf2 gtkmm30 librsvg2
+
+BINARY_ALIAS= python3=${PYTHON_CMD}
+
+INSTALLS_ICONS= yes
+
+post-install:
+ cd ${STAGEDIR}${PREFIX}/bin && ${STRIP_CMD} horizon-imp horizon-eda
+
+.include <bsd.port.mk>
diff --git a/cad/horizon-eda/distinfo b/cad/horizon-eda/distinfo
new file mode 100644
index 000000000000..960645435fa3
--- /dev/null
+++ b/cad/horizon-eda/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1596747687
+SHA256 (horizon-eda-horizon-v1.2.1_GH0.tar.gz) = 3c0d66afeec55cf7fffbb25a467f7aac1576a5f93fec1f461d7f8a3e20072365
+SIZE (horizon-eda-horizon-v1.2.1_GH0.tar.gz) = 2933726
+SHA256 (b40e3ed3f92c4b28af307135223ecf05eacecc82.patch) = 3d0e9a50346931f842b856c0e1defaf6b6b9cce57ed134393f8e0bc9db1f22d3
+SIZE (b40e3ed3f92c4b28af307135223ecf05eacecc82.patch) = 795
diff --git a/cad/horizon-eda/files/patch-Makefile b/cad/horizon-eda/files/patch-Makefile
new file mode 100644
index 000000000000..08298607747b
--- /dev/null
+++ b/cad/horizon-eda/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2020-08-06 20:40:55 UTC
++++ Makefile
+@@ -657,7 +657,7 @@ endif
+ LIBS_ALL = $(LIBS_COMMON) gtkmm-3.0 epoxy cairomm-pdf-1.0 librsvg-2.0 libzmq libgit2 libcurl glm
+
+ OPTIMIZE = -fdata-sections -ffunction-sections
+-DEBUGFLAGS = -g3
++#DEBUGFLAGS = -g3
+ CXXFLAGS += $(DEBUGFLAGS) $(DEFINES) $(OPTIMIZE) $(shell $(PKG_CONFIG) --cflags $(LIBS_ALL)) -MP -MMD -pthread -Wall -Wshadow -std=c++17 -O3
+ CFLAGS = $(filter-out -std=%,$(CXXFLAGS)) -std=c99
+ LDFLAGS += -lm -lpthread
diff --git a/cad/horizon-eda/pkg-descr b/cad/horizon-eda/pkg-descr
new file mode 100644
index 000000000000..e60910d4eaba
--- /dev/null
+++ b/cad/horizon-eda/pkg-descr
@@ -0,0 +1,5 @@
+Horizon EDA is an Electronic Design Automation package supporting an integrated
+end-to-end workflow for printed circuit board design including parts management
+and schematic entry.
+
+WWW: https://horizon-eda.org/
diff --git a/cad/horizon-eda/pkg-plist b/cad/horizon-eda/pkg-plist
new file mode 100644
index 000000000000..3536617092c2
--- /dev/null
+++ b/cad/horizon-eda/pkg-plist
@@ -0,0 +1,9 @@
+bin/horizon-eda
+bin/horizon-imp
+share/applications/org.horizon_eda.HorizonEDA.desktop
+share/icons/hicolor/16x16/apps/org.horizon_eda.HorizonEDA.png
+share/icons/hicolor/256x256/apps/org.horizon_eda.HorizonEDA.png
+share/icons/hicolor/32x32/apps/org.horizon_eda.HorizonEDA.png
+share/icons/hicolor/64x64/apps/org.horizon_eda.HorizonEDA.png
+share/icons/hicolor/scalable/apps/org.horizon_eda.HorizonEDA.svg
+share/metainfo/org.horizon_eda.HorizonEDA.metainfo.xml