aboutsummaryrefslogtreecommitdiff
path: root/cad/ifcopenshell
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-05-23 06:57:49 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-05-23 06:57:49 +0000
commit28a0c076675a6068eab1cc16a4b5b9b07a4b392d (patch)
tree73075f3e63dd54e591c6da10d89738dd3808adf1 /cad/ifcopenshell
parent0cf68837cd2c3e97ce2f4167bbd856c91b419a43 (diff)
downloadports-28a0c076675a6068eab1cc16a4b5b9b07a4b392d.tar.gz
ports-28a0c076675a6068eab1cc16a4b5b9b07a4b392d.zip
[NEW PORT] cad/ifcopenshell: Open source IFC library and geometry engine
IfcOpenShell is an open source (LGPL) software library for working with the Industry Foundation Classes (IFC) file format. Currently supported IFC releases are IFC2x3 TC1 and [IFC4 Add2 TC1]. PR: 243007 Reported by: chitty_cloud@me.com Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D24687
Notes
Notes: svn path=/head/; revision=536269
Diffstat (limited to 'cad/ifcopenshell')
-rw-r--r--cad/ifcopenshell/Makefile37
-rw-r--r--cad/ifcopenshell/distinfo3
-rw-r--r--cad/ifcopenshell/files/patch-cmake_CMakeLists.txt10
-rw-r--r--cad/ifcopenshell/pkg-descr5
-rw-r--r--cad/ifcopenshell/pkg-plist82
5 files changed, 137 insertions, 0 deletions
diff --git a/cad/ifcopenshell/Makefile b/cad/ifcopenshell/Makefile
new file mode 100644
index 000000000000..45bd62c711e9
--- /dev/null
+++ b/cad/ifcopenshell/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= ifcopenshell
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.6.0
+DISTVERSIONSUFFIX= b0
+CATEGORIES= cad
+DISTNAME= ${PORTNAME}-${DISTVERSION}
+
+MAINTAINER= lbartoletti@FreeBSD.org
+COMMENT= Open source IFC library and geometry engine
+
+LICENSE= LGPL3+
+LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
+
+BUILD_DEPENDS= nlohmann-json>0:devel/nlohmann-json
+LIB_DEPENDS= libboost_system.so:devel/boost-libs \
+ libTKernel.so:cad/opencascade
+
+USES= cmake eigen:3 gnome
+USE_GNOME= libxml2
+USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_PROJECT= IfcOpenShell
+
+CMAKE_SOURCE_PATH= ${WRKSRC}/cmake
+
+CMAKE_OFF= BUILD_IFCPYTHON \
+ COLLADA_SUPPORT
+CMAKE_ON= BUILD_SHARED_LIBS \
+ ENABLE_BUILD_OPTIMIZATIONS \
+ GLTF_SUPPORT
+CMAKE_ARGS= -Djson_hpp=${LOCALBASE}/include/nlohmann \
+ -DOCC_INCLUDE_DIR=${LOCALBASE}/include/OpenCASCADE \
+ -DOCC_LIBRARY_DIR=${LOCALBASE}/lib
+
+.include <bsd.port.mk>
diff --git a/cad/ifcopenshell/distinfo b/cad/ifcopenshell/distinfo
new file mode 100644
index 000000000000..edfab0f216ef
--- /dev/null
+++ b/cad/ifcopenshell/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1587226962
+SHA256 (ifcopenshell-IfcOpenShell-v0.6.0b0_GH0.tar.gz) = d4a9a28b715512659670f2a101bef64363df7808a64ed30e7019161caae6a914
+SIZE (ifcopenshell-IfcOpenShell-v0.6.0b0_GH0.tar.gz) = 2718837
diff --git a/cad/ifcopenshell/files/patch-cmake_CMakeLists.txt b/cad/ifcopenshell/files/patch-cmake_CMakeLists.txt
new file mode 100644
index 000000000000..cfb17dfd2374
--- /dev/null
+++ b/cad/ifcopenshell/files/patch-cmake_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- cmake/CMakeLists.txt.orig 2020-04-18 16:47:03 UTC
++++ cmake/CMakeLists.txt
+@@ -163,6 +163,7 @@ if(USE_MMAP)
+ endif()
+
+ if (IFCXML_SUPPORT)
++ find_package(LibXml2 REQUIRED)
+ add_definitions(-DWITH_IFCXML)
+ endif()
+
diff --git a/cad/ifcopenshell/pkg-descr b/cad/ifcopenshell/pkg-descr
new file mode 100644
index 000000000000..8b44eb8a578e
--- /dev/null
+++ b/cad/ifcopenshell/pkg-descr
@@ -0,0 +1,5 @@
+IfcOpenShell is an open source (LGPL) software library for working with the
+Industry Foundation Classes (IFC) file format. Currently supported IFC
+releases are IFC2x3 TC1 and [IFC4 Add2 TC1].
+
+WWW: http://ifcopenshell.org
diff --git a/cad/ifcopenshell/pkg-plist b/cad/ifcopenshell/pkg-plist
new file mode 100644
index 000000000000..8783990c8a22
--- /dev/null
+++ b/cad/ifcopenshell/pkg-plist
@@ -0,0 +1,82 @@
+bin/IfcConvert
+bin/IfcGeomServer
+include/ifcgeom/IfcGeom.h
+include/ifcgeom/IfcGeomElement.h
+include/ifcgeom/IfcGeomIteratorImplementation.h
+include/ifcgeom/IfcGeomIteratorSettings.h
+include/ifcgeom/IfcGeomRepresentation.h
+include/ifcgeom/IfcGeomShapeType.h
+include/ifcgeom/IfcGeomTree.h
+include/ifcgeom/IfcRegister.h
+include/ifcgeom/IfcRegisterConvertCurve.h
+include/ifcgeom/IfcRegisterConvertFace.h
+include/ifcgeom/IfcRegisterConvertShape.h
+include/ifcgeom/IfcRegisterConvertShapes.h
+include/ifcgeom/IfcRegisterConvertWire.h
+include/ifcgeom/IfcRegisterCreateCache.h
+include/ifcgeom/IfcRegisterDef.h
+include/ifcgeom/IfcRegisterGeomHeader.h
+include/ifcgeom/IfcRegisterPurgeCache.h
+include/ifcgeom/IfcRegisterShapeType.h
+include/ifcgeom/IfcRegisterUndef.h
+include/ifcgeom/IfcRepresentationShapeItem.h
+include/ifcgeom/ifc_geom_api.h
+include/ifcgeom_schema_agnostic/IfcGeomFilter.h
+include/ifcgeom_schema_agnostic/IfcGeomIterator.h
+include/ifcgeom_schema_agnostic/IfcGeomMaterial.h
+include/ifcgeom_schema_agnostic/IfcGeomRenderStyles.h
+include/ifcgeom_schema_agnostic/IteratorImplementation.h
+include/ifcgeom_schema_agnostic/Kernel.h
+include/ifcgeom_schema_agnostic/Serialization.h
+include/ifcparse/Argument.h
+include/ifcparse/ArgumentType.h
+include/ifcparse/Ifc2x3.h
+include/ifcparse/Ifc2x3enum.h
+include/ifcparse/Ifc4.h
+include/ifcparse/Ifc4enum.h
+include/ifcparse/IfcBaseClass.h
+include/ifcparse/IfcCharacterDecoder.h
+include/ifcparse/IfcEntityDescriptor.h
+include/ifcparse/IfcEntityInstanceData.h
+include/ifcparse/IfcEntityList.h
+include/ifcparse/IfcException.h
+include/ifcparse/IfcFile.h
+include/ifcparse/IfcGlobalId.h
+include/ifcparse/IfcHierarchyHelper.h
+include/ifcparse/IfcLogger.h
+include/ifcparse/IfcParse.h
+include/ifcparse/IfcSIPrefix.h
+include/ifcparse/IfcSchema.h
+include/ifcparse/IfcSpfHeader.h
+include/ifcparse/IfcSpfStream.h
+include/ifcparse/IfcWrite.h
+include/ifcparse/ifc_parse_api.h
+include/ifcparse/macros.h
+include/ifcparse/utils.h
+include/serializers/ColladaSerializer.cpp
+include/serializers/ColladaSerializer.h
+include/serializers/GeometrySerializer.h
+include/serializers/GltfSerializer.cpp
+include/serializers/GltfSerializer.h
+include/serializers/IgesSerializer.h
+include/serializers/OpenCascadeBasedSerializer.cpp
+include/serializers/OpenCascadeBasedSerializer.h
+include/serializers/Serializer.h
+include/serializers/StepSerializer.h
+include/serializers/SvgSerializer.cpp
+include/serializers/SvgSerializer.h
+include/serializers/WavefrontObjSerializer.cpp
+include/serializers/WavefrontObjSerializer.h
+include/serializers/XmlSerializer.cpp
+include/serializers/XmlSerializer.h
+include/serializers/schema_dependent/XmlSerializer.cpp
+include/serializers/schema_dependent/XmlSerializer.h
+include/serializers/util.cpp
+include/serializers/util.h
+lib/libIfcGeom.so
+lib/libIfcGeom_ifc2x3.a
+lib/libIfcGeom_ifc4.a
+lib/libIfcParse.so
+lib/libSerializers.so
+lib/libSerializers_ifc2x3.a
+lib/libSerializers_ifc4.a