aboutsummaryrefslogtreecommitdiff
path: root/cad/iverilog
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2015-10-08 19:38:57 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2015-10-08 19:38:57 +0000
commitae780c919e895134d1c591d81a68830e9622d3a6 (patch)
tree893e3b1318b4217dce612d4eccc027bb1eb8e0e7 /cad/iverilog
parent8af85032143d26352e6823e197bcf6ef31b63651 (diff)
downloadports-ae780c919e895134d1c591d81a68830e9622d3a6.tar.gz
ports-ae780c919e895134d1c591d81a68830e9622d3a6.zip
Fix build on FreeBSD 9.*
FreeBSD 9.* has an older, noncompatible version of flex. Fix this by using flex from ports instead. Submitted by: kwm
Notes
Notes: svn path=/head/; revision=398890
Diffstat (limited to 'cad/iverilog')
-rw-r--r--cad/iverilog/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/cad/iverilog/Makefile b/cad/iverilog/Makefile
index 281ffe8288f0..f317b93561a7 100644
--- a/cad/iverilog/Makefile
+++ b/cad/iverilog/Makefile
@@ -15,6 +15,13 @@ LICENSE= GPLv2
GNU_CONFIGURE= yes
USES= bison gmake
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} < 1000033
+BUILD_DEPENDS+= flex>=0:${PORTSDIR}/textproc/flex
+CONFIGURE_ENV+= ac_cv_prog_LEX="${LOCALBASE}/bin/flex"
+.endif
+
CONFIGURE_ARGS= --disable-suffix
.include <bsd.port.mk>