aboutsummaryrefslogtreecommitdiff
path: root/cad/kicad-devel
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2021-06-10 12:50:29 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2021-06-10 13:10:45 +0000
commited1548773960b674f97d72ce5066e896ebbdc1b7 (patch)
treeddb9e141b2da6cf7ee29c896d5af6d820f0952db /cad/kicad-devel
parentb08a7396eb210bcd6e23a83e003743e88018958f (diff)
downloadports-ed1548773960b674f97d72ce5066e896ebbdc1b7.tar.gz
ports-ed1548773960b674f97d72ce5066e896ebbdc1b7.zip
cad/kicad-devel: Update to latest commit
Diffstat (limited to 'cad/kicad-devel')
-rw-r--r--cad/kicad-devel/Makefile2
-rw-r--r--cad/kicad-devel/Makefile.git_rev4
-rw-r--r--cad/kicad-devel/distinfo6
-rw-r--r--cad/kicad-devel/files/patch-3d-viewer_3d__rendering_legacy_3d__model.cpp11
-rw-r--r--cad/kicad-devel/files/patch-CMakeLists.txt22
-rw-r--r--cad/kicad-devel/files/patch-include-gal-graphics_abstraction_layer.h8
-rw-r--r--cad/kicad-devel/files/patch-include-kiway.h8
-rw-r--r--cad/kicad-devel/pkg-plist43
8 files changed, 58 insertions, 46 deletions
diff --git a/cad/kicad-devel/Makefile b/cad/kicad-devel/Makefile
index b56000461513..951865550ac0 100644
--- a/cad/kicad-devel/Makefile
+++ b/cad/kicad-devel/Makefile
@@ -53,7 +53,7 @@ SHEBANG_FILES= pcbnew/python/plugins/touch_slider_wizard.py
CMAKE_ARGS= -DLOCALBASE="${LOCALBASE}" \
-DCMAKE_BUILD_TYPE="Debug" \
-DKICAD_TESTING_VERSION=ON \
- -DKICAD_BUILD_VERSION=${DISTVERSION} \
+ -DKICAD_VERSION=${DISTVERSION} \
-DCMAKE_INCLUDE_PATH="${WRKSRC}/include ${LOCALBASE}/include" \
-DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}" \
-DwxWidgets_USE_DEBUG=ON \
diff --git a/cad/kicad-devel/Makefile.git_rev b/cad/kicad-devel/Makefile.git_rev
index 1949442e1b8e..aed76ccd49fa 100644
--- a/cad/kicad-devel/Makefile.git_rev
+++ b/cad/kicad-devel/Makefile.git_rev
@@ -1,2 +1,2 @@
-GIT_SRC_HASH= f88be65825d8f23379b55f333a2b7054bea01c58
-GIT_SRC_DATE= 20210215215911
+GIT_SRC_HASH= 1c3df973d6a480277f0853caad0e7e255981c929
+GIT_SRC_DATE= 20210610134502
diff --git a/cad/kicad-devel/distinfo b/cad/kicad-devel/distinfo
index c53fb68792b5..ddf9dd645406 100644
--- a/cad/kicad-devel/distinfo
+++ b/cad/kicad-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1617884322
-SHA256 (kicad/kicad/code-kicad-f88be65825d8f23379b55f333a2b7054bea01c58_GL0.tar.gz) = e15acbc8730f779ab5736bb69117558a3da283b2001b0720b2e30b4b94a15e90
-SIZE (kicad/kicad/code-kicad-f88be65825d8f23379b55f333a2b7054bea01c58_GL0.tar.gz) = 33377789
+TIMESTAMP = 1623329556
+SHA256 (kicad/kicad/code-kicad-1c3df973d6a480277f0853caad0e7e255981c929_GL0.tar.gz) = 7b7e5bcd537ba0e854d32ddc2461eee25c2ce14dcd526c820dc7ac51e462fbbc
+SIZE (kicad/kicad/code-kicad-1c3df973d6a480277f0853caad0e7e255981c929_GL0.tar.gz) = 35907193
diff --git a/cad/kicad-devel/files/patch-3d-viewer_3d__rendering_legacy_3d__model.cpp b/cad/kicad-devel/files/patch-3d-viewer_3d__rendering_legacy_3d__model.cpp
new file mode 100644
index 000000000000..81409ebfadba
--- /dev/null
+++ b/cad/kicad-devel/files/patch-3d-viewer_3d__rendering_legacy_3d__model.cpp
@@ -0,0 +1,11 @@
+--- 3d-viewer/3d_rendering/legacy/3d_model.cpp.orig 2021-06-08 11:48:08 UTC
++++ 3d-viewer/3d_rendering/legacy/3d_model.cpp
+@@ -488,7 +488,7 @@ void MODEL_3D::DrawBbox() const
+ reinterpret_cast<const void*>( offsetof( VERTEX, m_color ) ) );
+
+ glDrawElements( GL_LINES, bbox_idx_count, m_bbox_index_buffer_type,
+- reinterpret_cast<const void*>( NULL ) );
++ reinterpret_cast<const void*>( 0 ) );
+ }
+
+
diff --git a/cad/kicad-devel/files/patch-CMakeLists.txt b/cad/kicad-devel/files/patch-CMakeLists.txt
deleted file mode 100644
index 3fbf50421c59..000000000000
--- a/cad/kicad-devel/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,22 +0,0 @@
---- CMakeLists.txt.orig 2019-03-11 16:59:38.982264000 +0100
-+++ CMakeLists.txt 2019-03-11 17:00:47.354215000 +0100
-@@ -668,8 +668,8 @@ if( KICAD_SCRIPTING OR KICAD_SCRIPTING_MODULES )
- set( PythonLibs_FIND_VERSION 3.3 )
- else()
- # force a python version < 3.0
-- set( PythonInterp_FIND_VERSION 2.6 )
-- set( PythonLibs_FIND_VERSION 2.6 )
-+ set( PythonInterp_FIND_VERSION 2.7 )
-+ set( PythonLibs_FIND_VERSION 2.7 )
- endif()
-
- find_package( PythonInterp )
-@@ -711,7 +711,7 @@ if( KICAD_SCRIPTING OR KICAD_SCRIPTING_MODULES )
- if( KICAD_SCRIPTING_PYTHON3 )
- find_package( PythonLibs 3.3 REQUIRED )
- else()
-- find_package( PythonLibs 2.6 REQUIRED )
-+ find_package( PythonLibs 2.7 REQUIRED )
- endif()
-
- if( KICAD_SCRIPTING_WXPYTHON )
diff --git a/cad/kicad-devel/files/patch-include-gal-graphics_abstraction_layer.h b/cad/kicad-devel/files/patch-include-gal-graphics_abstraction_layer.h
index 23f076a44fd9..aba5786d116a 100644
--- a/cad/kicad-devel/files/patch-include-gal-graphics_abstraction_layer.h
+++ b/cad/kicad-devel/files/patch-include-gal-graphics_abstraction_layer.h
@@ -1,8 +1,10 @@
---- include/gal/graphics_abstraction_layer.h.orig 2016-04-16 13:14:32.003824016 +0200
-+++ include/gal/graphics_abstraction_layer.h 2016-04-16 13:15:06.143789160 +0200
-@@ -31,4 +31,5 @@
+--- include/gal/graphics_abstraction_layer.h.orig 2021-06-08 00:34:09 UTC
++++ include/gal/graphics_abstraction_layer.h
+@@ -30,6 +30,7 @@
+ #include <deque>
#include <stack>
#include <limits>
+#include <cmath>
#include <math/matrix3x3.h>
+
diff --git a/cad/kicad-devel/files/patch-include-kiway.h b/cad/kicad-devel/files/patch-include-kiway.h
index 0a307f37d12e..07ebc8158a9d 100644
--- a/cad/kicad-devel/files/patch-include-kiway.h
+++ b/cad/kicad-devel/files/patch-include-kiway.h
@@ -1,9 +1,11 @@
---- include/kiway.h.orig 2015-01-10 18:11:39.000000000 +0000
-+++ include/kiway.h 2015-01-11 10:51:52.458174797 +0000
-@@ -115,5 +115,5 @@
+--- include/kiway.h.orig 2021-06-08 00:34:09 UTC
++++ include/kiway.h
+@@ -113,7 +113,7 @@
#define KIFACE_INSTANCE_NAME_AND_VERSION "KIFACE_1"
+ #ifndef SWIG
-#if defined(__linux__) || defined(__FreeBSD__)
+#if defined(__linux__) || defined(__FreeBSD__) || defined(__DragonFly__)
#define LIB_ENV_VAR wxT( "LD_LIBRARY_PATH" )
#elif defined(__WXMAC__)
+ #define LIB_ENV_VAR wxT( "DYLD_LIBRARY_PATH" )
diff --git a/cad/kicad-devel/pkg-plist b/cad/kicad-devel/pkg-plist
index 58afbcb7fbda..968372dfe2d6 100644
--- a/cad/kicad-devel/pkg-plist
+++ b/cad/kicad-devel/pkg-plist
@@ -1,6 +1,7 @@
bin/_cvpcb.kiface
bin/_eeschema.kiface
bin/_gerbview.kiface
+bin/_kipython.kiface
bin/_pcb_calculator.kiface
bin/_pcbnew.kiface
bin/_pl_editor.kiface
@@ -23,13 +24,12 @@ lib/libkicad_3dsg.so
lib/libkicad_3dsg.so.2.0.0
%%PYTHON_SITELIBDIR%%/_pcbnew.so
%%PYTHON_SITELIBDIR%%/pcbnew.py
-share/appdata/kicad.appdata.xml
-%%DESKTOPDIR%%/bitmap2component.desktop
-%%DESKTOPDIR%%/eeschema.desktop
-%%DESKTOPDIR%%/gerbview.desktop
-%%DESKTOPDIR%%/kicad.desktop
-%%DESKTOPDIR%%/pcbcalculator.desktop
-%%DESKTOPDIR%%/pcbnew.desktop
+%%DESKTOPDIR%%/org.kicad.bitmap2component.desktop
+%%DESKTOPDIR%%/org.kicad.eeschema.desktop
+%%DESKTOPDIR%%/org.kicad.gerbview.desktop
+%%DESKTOPDIR%%/org.kicad.kicad.desktop
+%%DESKTOPDIR%%/org.kicad.pcbcalculator.desktop
+%%DESKTOPDIR%%/org.kicad.pcbnew.desktop
%%PORTDOCS%%%%DOCSDIR%%/scripts/lib_convert.py
%%PORTDOCS%%%%DOCSDIR%%/scripts/test_kicad_plugin.py
%%PORTDOCS%%%%DOCSDIR%%/scripts/test_plugin.py
@@ -97,12 +97,10 @@ share/icons/hicolor/scalable/mimetypes/application-x-kicad-pcb.svg
share/icons/hicolor/scalable/mimetypes/application-x-kicad-project.svg
share/icons/hicolor/scalable/mimetypes/application-x-kicad-schematic.svg
%%DATADIR%%/demos/complex_hierarchy/ampli_ht.kicad_sch
-%%DATADIR%%/demos/complex_hierarchy/complex_hierarchy-cache.lib
%%DATADIR%%/demos/complex_hierarchy/complex_hierarchy.kicad_pcb
%%DATADIR%%/demos/complex_hierarchy/complex_hierarchy.kicad_pro
%%DATADIR%%/demos/complex_hierarchy/complex_hierarchy.kicad_sch
%%DATADIR%%/demos/complex_hierarchy/complex_hierarchy_schlib.kicad_sym
-%%DATADIR%%/demos/complex_hierarchy/complex_hierarchy_schlib.lib
%%DATADIR%%/demos/complex_hierarchy/fp-lib-table
%%DATADIR%%/demos/complex_hierarchy/sym-lib-table
%%DATADIR%%/demos/custom_pads_test/custom_pads_schlib.kicad_sym
@@ -171,7 +169,7 @@ share/icons/hicolor/scalable/mimetypes/application-x-kicad-schematic.svg
%%DATADIR%%/demos/kit-dev-coldfire-xilinx_5213/sym-lib-table
%%DATADIR%%/demos/kit-dev-coldfire-xilinx_5213/xilinx.kicad_sch
%%DATADIR%%/demos/microwave/microwave.kicad_pcb
-%%DATADIR%%/demos/microwave/microwave.pro
+%%DATADIR%%/demos/microwave/microwave.kicad_pro
%%DATADIR%%/demos/microwave/shape1.txt
%%DATADIR%%/demos/pic_programmer/fp-lib-table
%%DATADIR%%/demos/pic_programmer/libs/3d_shapes/adjustable_rx2v4.wrl
@@ -230,6 +228,25 @@ share/icons/hicolor/scalable/mimetypes/application-x-kicad-schematic.svg
%%DATADIR%%/demos/stickhub/StickHub.kicad_pcb
%%DATADIR%%/demos/stickhub/StickHub.kicad_pro
%%DATADIR%%/demos/stickhub/StickHub.kicad_sch
+%%DATADIR%%/demos/stickhub/footprints.pretty/1005_C.kicad_mod
+%%DATADIR%%/demos/stickhub/footprints.pretty/1006_C.kicad_mod
+%%DATADIR%%/demos/stickhub/footprints.pretty/1608_C.kicad_mod
+%%DATADIR%%/demos/stickhub/footprints.pretty/1P-1.5x1.5.kicad_mod
+%%DATADIR%%/demos/stickhub/footprints.pretty/2012_C.kicad_mod
+%%DATADIR%%/demos/stickhub/footprints.pretty/CP_Elec_6.3x11_Board_Edge_Mirrored.kicad_mod
+%%DATADIR%%/demos/stickhub/footprints.pretty/Creative_Commons_BY_Mask.kicad_mod
+%%DATADIR%%/demos/stickhub/footprints.pretty/Creative_Commons_CC_Mask.kicad_mod
+%%DATADIR%%/demos/stickhub/footprints.pretty/Creative_Commons_NC_Mask.kicad_mod
+%%DATADIR%%/demos/stickhub/footprints.pretty/Creative_Commons_SA_Mask.kicad_mod
+%%DATADIR%%/demos/stickhub/footprints.pretty/Crystal_4-SMD_2.5x2mm.kicad_mod
+%%DATADIR%%/demos/stickhub/footprints.pretty/Duo_LED_1.6x0.8_Kingbright_APHB1608LZGKSURKC.kicad_mod
+%%DATADIR%%/demos/stickhub/footprints.pretty/JP-2_1.5x1.5.kicad_mod
+%%DATADIR%%/demos/stickhub/footprints.pretty/JST_SH_SM04B-SRSS-TB_1x04-1MP_P1.00mm_Horizontal.kicad_mod
+%%DATADIR%%/demos/stickhub/footprints.pretty/LQFP-48_7x7mm_P0.5mm.kicad_mod
+%%DATADIR%%/demos/stickhub/footprints.pretty/Plain_Hole_3mm.kicad_mod
+%%DATADIR%%/demos/stickhub/footprints.pretty/TDFN-8_1.5x2mm_Fused-Lead_JEDEC_MO-252_W2015D.kicad_mod
+%%DATADIR%%/demos/stickhub/footprints.pretty/USB_A_PCB_traces_small.kicad_mod
+%%DATADIR%%/demos/stickhub/fp-lib-table
%%DATADIR%%/demos/stickhub/sym-lib-table
%%DATADIR%%/demos/test_pads_inside_pads/sym-lib-table
%%DATADIR%%/demos/test_pads_inside_pads/test_pads_inside_pads.kicad_pcb
@@ -244,7 +261,6 @@ share/icons/hicolor/scalable/mimetypes/application-x-kicad-schematic.svg
%%DATADIR%%/demos/test_xil_95108/sym-lib-table
%%DATADIR%%/demos/video/bus_pci.kicad_sch
%%DATADIR%%/demos/video/esvideo.kicad_sch
-%%DATADIR%%/demos/video/esvideo.sch
%%DATADIR%%/demos/video/fp-lib-table
%%DATADIR%%/demos/video/graphic.kicad_sch
%%DATADIR%%/demos/video/libs/footprints.pretty/CV3-30PF.kicad_mod
@@ -273,14 +289,16 @@ share/icons/hicolor/scalable/mimetypes/application-x-kicad-schematic.svg
%%DATADIR%%/plugins/bom_csv_sorted_by_ref.py
%%DATADIR%%/plugins/bom_html_grouped_by_value.py
%%DATADIR%%/plugins/bom_html_with_advanced_grouping.py
-%%DATADIR%%/plugins/bom_sorted_by_ref.py
+%%DATADIR%%/plugins/bom_txt_sorted_by_ref.py
%%DATADIR%%/plugins/bom_with_title_block_2_csv.xsl
%%DATADIR%%/plugins/kicad_netlist_reader.py
%%DATADIR%%/plugins/netlist_form_OrcadPcb2.xsl
%%DATADIR%%/plugins/netlist_form_cadstar-RINF.xsl
%%DATADIR%%/plugins/netlist_form_cadstar.xsl
%%DATADIR%%/plugins/netlist_form_pads-pcb.asc.xsl
+%%DATADIR%%/resources/images.tar.gz
%%DATADIR%%/scripting/kicad_pyshell/__init__.py
+%%DATADIR%%/scripting/kicad_pyshell/kicad_pyeditor.py
%%DATADIR%%/scripting/plugins/FPC_wizard.py
%%DATADIR%%/scripting/plugins/FootprintWizardBase.py
%%DATADIR%%/scripting/plugins/PadArray.py
@@ -298,5 +316,6 @@ share/icons/hicolor/scalable/mimetypes/application-x-kicad-schematic.svg
%%DATADIR%%/scripting/plugins/uss39_barcode.py
%%DATADIR%%/scripting/plugins/zip_wizard.py
%%DATADIR%%/template/kicad.kicad_pro
+share/metainfo/org.kicad.kicad.metainfo.xml
share/mime/packages/kicad-gerbers.xml
share/mime/packages/kicad-kicad.xml