aboutsummaryrefslogtreecommitdiff
path: root/cad/kicad-library-templates-devel
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2020-12-27 17:33:10 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2020-12-27 17:33:10 +0000
commitddf7fbf95151c50b496ce21d5a9ae4877ec51198 (patch)
treea6b8621ad73ebe47314da1008f0316e9bed74c49 /cad/kicad-library-templates-devel
parent28a27ea97df95ef9e72c644efa67175d0f70f578 (diff)
downloadports-ddf7fbf95151c50b496ce21d5a9ae4877ec51198.tar.gz
ports-ddf7fbf95151c50b496ce21d5a9ae4877ec51198.zip
Switch the *library* ports to gitlab.
Update all devel ports to the current versions.
Notes
Notes: svn path=/head/; revision=559381
Diffstat (limited to 'cad/kicad-library-templates-devel')
-rw-r--r--cad/kicad-library-templates-devel/Makefile10
-rw-r--r--cad/kicad-library-templates-devel/Makefile.git_rev4
-rw-r--r--cad/kicad-library-templates-devel/distinfo6
-rw-r--r--cad/kicad-library-templates-devel/files/newVersion.sh2
4 files changed, 12 insertions, 10 deletions
diff --git a/cad/kicad-library-templates-devel/Makefile b/cad/kicad-library-templates-devel/Makefile
index 49b9a1cdbac0..936a3049e546 100644
--- a/cad/kicad-library-templates-devel/Makefile
+++ b/cad/kicad-library-templates-devel/Makefile
@@ -6,7 +6,9 @@ DISTVERSION= r${GIT_TMPL_DATE}
PORTREVISION= 1
#PORTREVISION= 1
CATEGORIES= cad
+MASTER_SITES= https://gitlab.com/kicad/libraries/${PORTNAME}-templates/-/archive/${GL_COMMIT}/
PKGNAMESUFFIX= -library-tmpl-devel
+DISTNAME= ${PORTNAME}-templates-${GL_COMMIT}
MAINTAINER= mr@FreeBSD.org
COMMENT= Official KiCad project templates
@@ -17,10 +19,10 @@ RUN_DEPENDS= kicad:cad/kicad-devel
CONFLICTS= kicad-4.*
-USE_GITHUB= yes
-GH_ACCOUNT= KiCad
-GH_PROJECT= kicad-templates
-GH_TAGNAME= ${GIT_TMPL_HASH}
+USE_GITLAB= nodefault
+GL_ACCOUNT= kicad
+GL_PROJECT= kicad/libraries
+GL_COMMIT= ${GIT_TMPL_HASH}
USES= cmake
diff --git a/cad/kicad-library-templates-devel/Makefile.git_rev b/cad/kicad-library-templates-devel/Makefile.git_rev
index b4b9c036a886..91b76f749fd1 100644
--- a/cad/kicad-library-templates-devel/Makefile.git_rev
+++ b/cad/kicad-library-templates-devel/Makefile.git_rev
@@ -1,2 +1,2 @@
-GIT_TMPL_HASH= d075fd62e82d079e52ac33046a16744aeaa5a645
-GIT_TMPL_DATE= 20201001193538
+GIT_TMPL_HASH= 32a4f6fab863976fdcfa232e3e08fdcf3323a954
+GIT_TMPL_DATE= 20201002060258
diff --git a/cad/kicad-library-templates-devel/distinfo b/cad/kicad-library-templates-devel/distinfo
index 1e8bbcf66782..d38278184af3 100644
--- a/cad/kicad-library-templates-devel/distinfo
+++ b/cad/kicad-library-templates-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1604432151
-SHA256 (KiCad-kicad-templates-r20201001193538-d075fd62e82d079e52ac33046a16744aeaa5a645_GH0.tar.gz) = 9510a42580eda6cfa576ba0c2a081c18cc42551756d09ce4d82bd9e2d93b4080
-SIZE (KiCad-kicad-templates-r20201001193538-d075fd62e82d079e52ac33046a16744aeaa5a645_GH0.tar.gz) = 1644768
+TIMESTAMP = 1609087931
+SHA256 (kicad-templates-32a4f6fab863976fdcfa232e3e08fdcf3323a954.tar.gz) = 895f8b4e93ccee9f986edd2d7042be497f2f9867b88d81de9de75951493dee4b
+SIZE (kicad-templates-32a4f6fab863976fdcfa232e3e08fdcf3323a954.tar.gz) = 1644767
diff --git a/cad/kicad-library-templates-devel/files/newVersion.sh b/cad/kicad-library-templates-devel/files/newVersion.sh
index a13a45485017..4887ff4f4ebd 100644
--- a/cad/kicad-library-templates-devel/files/newVersion.sh
+++ b/cad/kicad-library-templates-devel/files/newVersion.sh
@@ -9,7 +9,7 @@ WRKDIR=`pwd`/work
#mkdir -p "${WRKDIR}"
if [ \! -d "${CURDIR}/kicad-templates" ]; then
- git clone https://github.com/KiCad/kicad-templates.git -b master "${CURDIR}/kicad-templates";
+ git clone https://gitlab.com/kicad/libraries/kicad-templates.git -b master "${CURDIR}/kicad-templates";
else
cd "${CURDIR}/kicad-templates"
git pull;