aboutsummaryrefslogtreecommitdiff
path: root/cad/klayout
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2009-12-21 06:57:15 +0000
committerHiroki Sato <hrs@FreeBSD.org>2009-12-21 06:57:15 +0000
commit867fec5b589034185fdbdd1213fdc2addce3d072 (patch)
treea57d546e75a4bbd8a8a5a87b12ea6e33e8dea6c5 /cad/klayout
parent26d825dffbae3c971cd704d30a0f48c50f2e567b (diff)
downloadports-867fec5b589034185fdbdd1213fdc2addce3d072.tar.gz
ports-867fec5b589034185fdbdd1213fdc2addce3d072.zip
Update to 0.19.3.
Notes
Notes: svn path=/head/; revision=246337
Diffstat (limited to 'cad/klayout')
-rw-r--r--cad/klayout/Makefile20
-rw-r--r--cad/klayout/distinfo6
-rw-r--r--cad/klayout/files/patch-build.sh31
3 files changed, 33 insertions, 24 deletions
diff --git a/cad/klayout/Makefile b/cad/klayout/Makefile
index 2f94f5c3802b..bf1d63de123b 100644
--- a/cad/klayout/Makefile
+++ b/cad/klayout/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= klayout
-PORTVERSION= 0.17.2
-PORTREVISION= 1
+PORTVERSION= 0.19.3
CATEGORIES= cad
MASTER_SITES= http://www.klayout.de/
@@ -16,12 +15,15 @@ COMMENT= A Qt-based GDS2 Viewer
USE_GMAKE= yes
USE_QT_VER= 4
-QT_COMPONENTS= corelib gui network moc_build sql uic_build rcc_build qt3support xml
+QT_COMPONENTS= corelib gui network moc_build sql uic_build \
+ rcc_build qt3support xml
PLIST_FILES= bin/klayout \
bin/strm2gds \
bin/strm2oas \
+ bin/strm2txt \
bin/strmclip \
- bin/strmcmp
+ bin/strmcmp \
+ bin/strmxor
PLATFORMKEYWORD= freebsd-32-gcc-release
@@ -33,14 +35,8 @@ do-build:
-qtlib ${QT_LIBDIR}
do-install:
- cd ${WRKSRC}/bin.${PLATFORMKEYWORD} && \
+ cd ${WRKSRC}/build.${PLATFORMKEYWORD}/main && \
${INSTALL_PROGRAM} ${PLIST_FILES:S,^bin/,,} \
${PREFIX}/bin
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64: exhausts virtual memory
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/cad/klayout/distinfo b/cad/klayout/distinfo
index fd16e0ba5f95..709e62c97c82 100644
--- a/cad/klayout/distinfo
+++ b/cad/klayout/distinfo
@@ -1,3 +1,3 @@
-MD5 (klayout-0.17.2.tar.gz) = dd8fced574ca795d20e6e16065e7e4d1
-SHA256 (klayout-0.17.2.tar.gz) = a7ed5aeea4b6c29dad3a4d85c38a1cf37db50dd194769a206b862c7bdbee614a
-SIZE (klayout-0.17.2.tar.gz) = 991056
+MD5 (klayout-0.19.3.tar.gz) = 1c119310499b5ba166c94efd0c5f1e82
+SHA256 (klayout-0.19.3.tar.gz) = ba853af6f27c42faf4c15673eec8f4d534d373c2341ee3c4130825f88fcd3801
+SIZE (klayout-0.19.3.tar.gz) = 1428534
diff --git a/cad/klayout/files/patch-build.sh b/cad/klayout/files/patch-build.sh
index d9c7e5517ab8..c58a376aa639 100644
--- a/cad/klayout/files/patch-build.sh
+++ b/cad/klayout/files/patch-build.sh
@@ -1,8 +1,8 @@
---- build.sh.orig 2008-12-28 07:36:50.000000000 +0900
-+++ build.sh 2009-04-11 23:23:57.000000000 +0900
-@@ -136,11 +136,11 @@
- exit 1
- fi
+--- build.sh.orig 2009-12-18 07:52:08.000000000 +0900
++++ build.sh 2009-12-21 01:30:05.000000000 +0900
+@@ -158,11 +158,11 @@
+ ;;
+ esac
-if [ ! -r $QTBIN/moc ]; then
+if [ ! -r $QTBIN/moc-qt4 ]; then
@@ -14,8 +14,21 @@
echo "*** ERROR: unable to locate Qt UIC in $QTBIN"
exit 1
fi
-@@ -249,12 +249,12 @@
- echo "Build done."
+@@ -268,21 +268,21 @@
+
+ # -- Installing binaries --
+
+-echo "Installing binaries .."
+-cd $BUILD
+-$MAKE_PRG install
+-cd $CURR_DIR
++#echo "Installing binaries .."
++#cd $BUILD
++#$MAKE_PRG install
++#cd $CURR_DIR
+ echo "Build done."
+
+ if [ $WIN_CYGWIN = 0 ]; then
echo ""
echo "Final binary is ready in $BIN/$EXEC_NAME."
- echo "To run it, you may need to add the following to your LD_LIBRARY_PATH:"
@@ -29,6 +42,6 @@
+ #LD_LIBRARY_PATH=$QTLIB:$LD_LIBRARY_PATH
+ #$BIN/$EXEC_NAME -v
+ #$BIN/$EXEC_NAME -h
+ fi
- else
-
+ exit 0