aboutsummaryrefslogtreecommitdiff
path: root/cad/netgen
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2019-05-15 03:07:24 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2019-05-15 03:07:24 +0000
commit9f9a9f10fd1de4a3e93f17c8b6670938134cb254 (patch)
tree3f9229740827c8dc39bc3d54bf9318e78b0af247 /cad/netgen
parent45898e8abf09f7e9f37ededdab0f64e3b56aea06 (diff)
downloadports-9f9a9f10fd1de4a3e93f17c8b6670938134cb254.tar.gz
ports-9f9a9f10fd1de4a3e93f17c8b6670938134cb254.zip
- Fix mistake in r501675, where OSVERSION was tested in a place where it
wasn't yet defined.
Notes
Notes: svn path=/head/; revision=501677
Diffstat (limited to 'cad/netgen')
-rw-r--r--cad/netgen/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/cad/netgen/Makefile b/cad/netgen/Makefile
index bf6dc686ad46..9caa9a8a8fa8 100644
--- a/cad/netgen/Makefile
+++ b/cad/netgen/Makefile
@@ -34,10 +34,6 @@ OPTIONS_DEFAULT= # OCC
BROKEN_sparc64= internal gcc error (Bug 23159)
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1300014
-BROKEN= does not build with recent versions of FreeBSD
-.endif
-
OCC_LIB_DEPENDS= libTKernel.so:cad/opencascade
OCC_CXXFLAGS= -DOCCGEOMETRY -DHAVE_CONFIG_H -D${ARCH} -I${LOCALBASE}/include/OpenCASCADE
OCC_CONFIGURE_ON= --enable-occ
@@ -65,4 +61,10 @@ post-install:
${SH} ${FILESDIR}/netgen_copy_include_for_salome ${WRKSRC} ${STAGEDIR}${PREFIX}
${LN} ${STAGEDIR}${PREFIX}/lib/libnglib.so ${STAGEDIR}${PREFIX}/lib/libnglib.so.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1300014
+BROKEN= does not build with recent versions of FreeBSD
+.endif
+
+.include <bsd.port.post.mk>