aboutsummaryrefslogtreecommitdiff
path: root/cad/netgen
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-04-11 21:05:35 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-04-12 09:14:53 +0000
commitf34213df16160014b473ddb3f69e8acd10188d2f (patch)
tree9d6ca65809d460532d3f79aa3a3edcd40db88a39 /cad/netgen
parent251da67b652e69b8713b4dafb246669ad89f0953 (diff)
downloadports-f34213df16160014b473ddb3f69e8acd10188d2f.tar.gz
ports-f34213df16160014b473ddb3f69e8acd10188d2f.zip
Diffstat (limited to 'cad/netgen')
-rw-r--r--cad/netgen/Makefile1
-rw-r--r--cad/netgen/files/patch-ng_CMakeLists.txt14
2 files changed, 15 insertions, 0 deletions
diff --git a/cad/netgen/Makefile b/cad/netgen/Makefile
index 6e8d84673c8b..8c2dc40e9cd7 100644
--- a/cad/netgen/Makefile
+++ b/cad/netgen/Makefile
@@ -2,6 +2,7 @@
PORTNAME= netgen
PORTVERSION= 6.2.2102
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= cad
diff --git a/cad/netgen/files/patch-ng_CMakeLists.txt b/cad/netgen/files/patch-ng_CMakeLists.txt
new file mode 100644
index 000000000000..98e814b52965
--- /dev/null
+++ b/cad/netgen/files/patch-ng_CMakeLists.txt
@@ -0,0 +1,14 @@
+To fix this linker error:
+ ld: error: libsrc/interface/libinterface.so: undefined reference to pthread_create [--no-allow-shlib-undefined]
+bang pthread into the executable. It's not a **good** fix, though.
+
+--- ng/CMakeLists.txt.orig 2021-03-18 07:16:55 UTC
++++ ng/CMakeLists.txt
+@@ -32,6 +32,7 @@ if(USE_GUI)
+ endif(NOT APPLE)
+
+ target_link_libraries( netgen nglib gui netgen_python ${MPI_mpi_LIBRARY} ${MPI_CXX_LIBRARIES} ${LIBTOGL} ${ZLIB_LIBRARIES} ${JPEG_LIBRARIES} ${FFMPEG_LIBRARIES} ${X11_Xmu_LIB} ${X11_X11_LIB} ${OCC_LIBRARIES} ${TK_LIBRARY} ${TCL_LIBRARY})
++ target_link_libraries( netgen pthread )
+
+ if(NOT WIN32)
+ target_link_libraries( netgen mesh stlvis stl geom2dvis interface geom2d csg stl visual csgvis )