aboutsummaryrefslogtreecommitdiff
path: root/cad/openscad-devel
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2018-04-28 14:19:25 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2018-04-28 14:19:25 +0000
commit5a7e9b17e38b1f1b6198f6d7e029e43d116f1f7e (patch)
treebf31fa04a77984554eb750dba85df4eeb5cc821e /cad/openscad-devel
parente69837290c0a84fb919f69fc18345d67f8b80d67 (diff)
downloadports-5a7e9b17e38b1f1b6198f6d7e029e43d116f1f7e.tar.gz
ports-5a7e9b17e38b1f1b6198f6d7e029e43d116f1f7e.zip
Reenable for FreeBSD >= 10.4
Use the CONFIG argument to enable experimental features Submitted by: jbeich@
Notes
Notes: svn path=/head/; revision=468545
Diffstat (limited to 'cad/openscad-devel')
-rw-r--r--cad/openscad-devel/Makefile10
-rw-r--r--cad/openscad-devel/files/patch-openscad.pro5
2 files changed, 7 insertions, 8 deletions
diff --git a/cad/openscad-devel/Makefile b/cad/openscad-devel/Makefile
index 65ad017d2d1d..1845938d6d99 100644
--- a/cad/openscad-devel/Makefile
+++ b/cad/openscad-devel/Makefile
@@ -14,8 +14,6 @@ COMMENT= Programmer's solid 3D CAD modeller
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_FreeBSD_10= Missing __cxa_thread_atexit
-
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex \
${LOCALBASE}/include/boost/tuple/tuple.hpp:devel/boost-libs
LIB_DEPENDS= libgmp.so:math/gmp \
@@ -41,7 +39,7 @@ USE_QT4= corelib gui opengl moc_build uic_build rcc_build
PLIST_SUB= PORTVERSION=${PORTVERSION}
QMAKE_ENV= EIGENDIR=${LOCALBASE}/include/eigen3
QMAKE_ARGS+= VERSION=${PORTVERSION} \
- EXPERIMENTAL=yes \
+ CONFIG+="experimental" \
QMAKE_LEX=${LOCALBASE}/bin/flex \
QMAKE_YAC=${LOCALBASE}/bin/bison
@@ -49,4 +47,10 @@ post-patch:
@${REINPLACE_CMD} -e 's,share/man,man,' \
${WRKSRC}/openscad.pro
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1003506
+BROKEN= no __cxa_thread_atexit() support in FreeBSD libc < 10.4
+.endif
+
.include <bsd.port.mk>
diff --git a/cad/openscad-devel/files/patch-openscad.pro b/cad/openscad-devel/files/patch-openscad.pro
index e261d4978ac7..f764f845f1fa 100644
--- a/cad/openscad-devel/files/patch-openscad.pro
+++ b/cad/openscad-devel/files/patch-openscad.pro
@@ -1,10 +1,5 @@
--- openscad.pro.orig 2018-04-19 22:08:08 UTC
+++ openscad.pro
-@@ -1,3 +1,4 @@
-+CONFIG+=experimental
- # Environment variables which can be set to specify library locations:
- # MPIRDIR
- # MPFRDIR
@@ -105,6 +106,10 @@ mingw* {
CONFIG += qt
QT += widgets concurrent