aboutsummaryrefslogtreecommitdiff
path: root/cad/openscad-devel
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /cad/openscad-devel
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'cad/openscad-devel')
-rw-r--r--cad/openscad-devel/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/cad/openscad-devel/Makefile b/cad/openscad-devel/Makefile
index ddafa05daf94..578119793fa3 100644
--- a/cad/openscad-devel/Makefile
+++ b/cad/openscad-devel/Makefile
@@ -27,7 +27,7 @@ LIB_DEPENDS= libgmp.so:math/gmp \
CONFLICTS= openscad
USES= bison compiler:c++11-lang desktop-file-utils eigen:3 gettext-tools \
- pkgconfig python:run qmake shebangfix
+ pkgconfig python:run qmake qt:4 shebangfix
USE_GITHUB= yes
GH_ACCOUNT= openscad
GH_PROJECT= openscad
@@ -35,7 +35,7 @@ GH_TAGNAME= 179074dff8c23cbc0e651ce8463737df0006f4ca
#SHEBANG_FILES= libraries/MCAD/get_submodules.py
USE_GL= glu glew
-USE_QT4= corelib gui opengl moc_build uic_build rcc_build
+USE_QT= corelib gui opengl moc_build uic_build rcc_build
PLIST_SUB= PORTVERSION=${PORTVERSION}
QMAKE_ENV= EIGENDIR=${LOCALBASE}/include/eigen3
QMAKE_ARGS+= VERSION=${PORTVERSION} \