aboutsummaryrefslogtreecommitdiff
path: root/cad/openscad/Makefile
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2011-08-19 11:02:10 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2011-08-19 11:02:10 +0000
commit56ae4083fae66bfb85a98bd67848927b8e64402d (patch)
tree599aec01d9bcc4d9eafb9c22c3e79156aea037b1 /cad/openscad/Makefile
parent717babfdc4b4e9988fd8bc2686710b975ded30ec (diff)
Add openscad.
OpenSCAD is a software for creating 3D CAD objects. Unlike most free software for creating 3D models, it does not focus on the artistic aspects of 3D modelling but instead on the CAD aspects. Thus it is more suitable for creating 3D models of machine parts but perhaps not when creating computer-animated movies. OpenSCAD is not an interactive modeller. Instead it is something like a 3D-compiler that reads in a script file that describes the object and renders the 3D model from this script file. This gives designers full control over the modelling process and enables them to easily change any step in the modelling process or make designes that are defined by configurable parameters. WWW: http://www.openscad.org/ Obtained from (slightly): OpenBSD
Notes
Notes: svn path=/head/; revision=280009
Diffstat (limited to 'cad/openscad/Makefile')
-rw-r--r--cad/openscad/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/cad/openscad/Makefile b/cad/openscad/Makefile
new file mode 100644
index 000000000000..ecf36afe2311
--- /dev/null
+++ b/cad/openscad/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: openscad
+# Date created: 17 August 2011
+# Whom: Michael Reifenberger <mr@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openscad
+PORTVERSION= 2011.06
+#PORTREVISION= 0
+CATEGORIES= cad
+MASTER_SITES= https://cloud.github.com/downloads/openscad/openscad/
+DISTNAME= openscad-${PORTVERSION}.src
+
+MAINTAINER= mr@FreeBSD.org
+COMMENT= The programmer's solid 3D CAD modeller
+
+BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
+ flex:${PORTSDIR}/textproc/flex \
+ eigen>=2.0.3:${PORTSDIR}/math/eigen2 \
+ ${LOCALBASE}/include/boost/tuple/tuple.hpp:${PORTSDIR}/devel/boost-libs
+#RUN_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= GLU.1:${PORTSDIR}/graphics/libGLU \
+ gmp.10:${PORTSDIR}/math/gmp \
+ mpfr.4:${PORTSDIR}/math/mpfr \
+ CGAL.5:${PORTSDIR}/math/cgal \
+ opencsg:${PORTSDIR}/graphics/opencsg
+
+USE_GL= glew
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+#MAKE_JOBS_UNSAFE=yes
+QMAKE_ENV = EIGEN2DIR=${LOCALBASE}/include/eigen2
+QMAKE_FLAGS = VERSION=${PORTVERSION}
+MAKE_ENV = INSTALL_ROOT=${DESTDIR}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's,XXXFLEXXX,"${LOCALBASE}/bin/flex",' \
+ ${WRKSRC}/openscad.pro
+ ${REINPLACE_CMD} -e 's,XXXBISONXXX,"${LOCALBASE}/bin/bison",' \
+ ${WRKSRC}/openscad.pro
+
+do-configure:
+ cd ${WRKSRC} && \
+ ${SETENV} ${QMAKE_ENV} ${QMAKE} ${QMAKE_FLAGS} openscad.pro
+
+.include <bsd.port.mk>