aboutsummaryrefslogtreecommitdiff
path: root/cad/openscad
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-01-02 16:49:24 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-01-02 16:49:24 +0000
commit51d04637cb2aa7e77e78d6b7de91125251405083 (patch)
treefefd75a0b797bfd5f2fbecc832b9a94f740ee983 /cad/openscad
parenta3cc859109302e74945b2f3684edfd3e5c434fdc (diff)
downloadports-51d04637cb2aa7e77e78d6b7de91125251405083.tar.gz
ports-51d04637cb2aa7e77e78d6b7de91125251405083.zip
New USES=eigen
Usage: USES=eigen:<version>[,<type>] version: 2 or 3 (required) type: build (default), run For example: USES=eigen:2,build,run will add a BUILD- and RUN_DEPENDS on math/eigen2, and USES=eigen:3 will add a BUILD_DEPENDS on math/eigen3. * Convert the existing ports to use it - biology/iqtree: remove run time dependency (seemed not to be needed) - graphics/movit: remove run time dependency (seemed not to be needed) - science/avogadro: add run time dependeny (installed cmake file requires it to be present) Reviewed by: rakuco, mat Differential Revision: https://reviews.freebsd.org/D13702
Notes
Notes: svn path=/head/; revision=457914
Diffstat (limited to 'cad/openscad')
-rw-r--r--cad/openscad/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/cad/openscad/Makefile b/cad/openscad/Makefile
index 4c597ba6b746..0542eebfe20f 100644
--- a/cad/openscad/Makefile
+++ b/cad/openscad/Makefile
@@ -15,7 +15,6 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex \
- ${LOCALBASE}/libdata/pkgconfig/eigen3.pc:math/eigen3 \
${LOCALBASE}/include/boost/tuple/tuple.hpp:devel/boost-libs
LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr \
@@ -24,7 +23,7 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libharfbuzz.so:print/harfbuzz \
libopencsg.so:graphics/opencsg
-USES= bison compiler:c++11-lang desktop-file-utils gettext-tools pkgconfig qmake shebangfix
+USES= bison compiler:c++11-lang desktop-file-utils eigen:3 gettext-tools pkgconfig qmake shebangfix
SHEBANG_FILES= libraries/MCAD/get_submodules.py
USE_GL= glu glew
USE_QT4= corelib gui opengl moc_build uic_build rcc_build