aboutsummaryrefslogtreecommitdiff
path: root/cad/p5-Verilog-Perl
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2014-06-27 18:59:28 +0000
committerRenato Botelho <garga@FreeBSD.org>2014-06-27 18:59:28 +0000
commitb2b68f19a313b38886fd9b25803bf1260cecd807 (patch)
tree0a15520a902b8e679402fda1705a33f8a7aa66a8 /cad/p5-Verilog-Perl
parent479c6ac9b4397f9e62cb7929256421719cd7305a (diff)
downloadports-b2b68f19a313b38886fd9b25803bf1260cecd807.tar.gz
ports-b2b68f19a313b38886fd9b25803bf1260cecd807.zip
- Update to 3.404
- Fix build, it needs gcc PR: 191368 Submitted by: otaciliodearaujo@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=359597
Diffstat (limited to 'cad/p5-Verilog-Perl')
-rw-r--r--cad/p5-Verilog-Perl/Makefile11
-rw-r--r--cad/p5-Verilog-Perl/distinfo4
-rw-r--r--cad/p5-Verilog-Perl/files/patch-Makefile.PL39
-rw-r--r--cad/p5-Verilog-Perl/files/patch-Parser__Makefile.PL28
-rw-r--r--cad/p5-Verilog-Perl/files/patch-Preproc__Makefile.PL27
-rw-r--r--cad/p5-Verilog-Perl/pkg-descr2
-rw-r--r--cad/p5-Verilog-Perl/pkg-plist1
7 files changed, 103 insertions, 9 deletions
diff --git a/cad/p5-Verilog-Perl/Makefile b/cad/p5-Verilog-Perl/Makefile
index 62d88d60ecab..2d119981ccda 100644
--- a/cad/p5-Verilog-Perl/Makefile
+++ b/cad/p5-Verilog-Perl/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= Verilog-Perl
-PORTVERSION= 3.400
+PORTVERSION= 3.404
CATEGORIES= cad perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,14 +14,13 @@ BUILD_DEPENDS= flex>=2.5.35:${PORTSDIR}/textproc/flex
USES= bison gmake perl5
USE_PERL5= configure
+USE_GCC= any
+CONFIGURE_ENV= CXX=${CXX}\
+ CPP=${CPP}\
+ CC=${CC}
.include <bsd.port.pre.mk>
-post-patch:
- @${REINPLACE_CMD} -e '/EXE_FILES/ s/ vsplitmodule//' \
- ${WRKSRC}/Makefile.PL
- @${REINPLACE_CMD} -e 's|make|gmake|g' ${WRKSRC}/Makefile.PL
-
post-install:
${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Verilog/Parser/*.so
diff --git a/cad/p5-Verilog-Perl/distinfo b/cad/p5-Verilog-Perl/distinfo
index 50be6160d4bc..3b42dfc2b6f2 100644
--- a/cad/p5-Verilog-Perl/distinfo
+++ b/cad/p5-Verilog-Perl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Verilog-Perl-3.400.tar.gz) = e6f33d5c0346f56ba96fa9964dd75734e1315dff8dfce55f0b31f33a6210f69b
-SIZE (Verilog-Perl-3.400.tar.gz) = 558455
+SHA256 (Verilog-Perl-3.404.tar.gz) = 4eddc21a965019eecc2200e251186f9d8bd0643485d12feda7d0b26a328650d0
+SIZE (Verilog-Perl-3.404.tar.gz) = 558496
diff --git a/cad/p5-Verilog-Perl/files/patch-Makefile.PL b/cad/p5-Verilog-Perl/files/patch-Makefile.PL
new file mode 100644
index 000000000000..a9ff01e0296f
--- /dev/null
+++ b/cad/p5-Verilog-Perl/files/patch-Makefile.PL
@@ -0,0 +1,39 @@
+--- Makefile.PL 2014-03-11 19:59:40.000000000 -0300
++++ Makefile.PL 2014-06-25 11:18:59.000000000 -0300
+@@ -11,7 +11,7 @@
+
+ sub MY::postamble {
+ my $out="";
+- # Note OPTIMIZE is passed from upper makefile, so this code needed there too.
++ # Note OPTIMIZE is passed from upper gmakefile, so this code needed there too.
+ # -O2 optimization seems unreasonably slow on nearly every platform. I give up.
+ my $optimize = $Config{optimize}; $optimize =~ s/(^| )-O2( |$)/\1-O\2/g;
+ $out .= "OPTIMIZE = $optimize\n";
+@@ -82,6 +82,8 @@
+ return $out;
+ }
+
++$CXX = $ENV{CXX};
++
+ my $fail;
+ local $! = undef;
+ my $have_gen = -d "Preproc/gen";
+@@ -93,7 +95,7 @@
+ if ($have_gen) { warn "\n-Note: 'bison' must be installed to build from sources\n"; }
+ else { $fail=1; warn "\n%Error: 'bison' must be installed to build\n\n"; }
+ }
+-`g++ --version`; if ($?) { $fail=1; warn "\n%Error: 'gcc/g++' must be installed to build\n"; }
++system("$CXX --version"); if ($?) { $fail=1; warn "\n%Error: 'gcc/g++' must be installed to build\n"; }
+ if ($fail) {
+ if ($ENV{AUTOMATED_TESTING}) {
+ exit(0);
+@@ -135,8 +137,8 @@
+ },
+ );
+
+-my $mkv = `make --version`;
++my $mkv = `gmake --version`;
+ if ($? || $mkv !~ /GNU Make/i) {
+ warn "-Important: Now type 'gmake MAKE=gmake' as this package requires GNU Make\n";
+ }
+ 1;
diff --git a/cad/p5-Verilog-Perl/files/patch-Parser__Makefile.PL b/cad/p5-Verilog-Perl/files/patch-Parser__Makefile.PL
new file mode 100644
index 000000000000..550fc0d9dc1f
--- /dev/null
+++ b/cad/p5-Verilog-Perl/files/patch-Parser__Makefile.PL
@@ -0,0 +1,28 @@
+--- Parser/Makefile.PL 2014-03-11 19:59:40.000000000 -0300
++++ Parser/Makefile.PL 2014-06-25 11:19:19.000000000 -0300
+@@ -9,13 +9,15 @@
+
+ sub MY::postamble {
+ my $out;
++
++ $CXX = $ENV{CXX};
+ #print Config::myconfig();
+ if ($Config{osname} !~ /cygwin/i && $Config{archname} !~ /cygwin/i
+ && $Config{osname} !~ /darwin/i && $Config{archname} !~ /darwin/i) {
+ # Cygwin: Don't change LD, it breaks
+ # Sun: Requires g++ LD
+ # Linux: Either way
+- $out .= "LD = g++\n";
++ $out .= "LD = $CXX\n";
+ }
+ # Note OPTIMIZE is passed from upper makefile, so this code needed there too.
+ my $optimize = $Config{optimize}; $optimize =~ s/(^| )-O2( |$)/\1-O\2/g;
+@@ -46,7 +48,7 @@
+ $out .= "${cmt}CFLAGS += -DFLEX_DEBUG\n";
+ $out .= "LEXFLAGS += -d\n";
+ $out .= '
+-CC = $(OBJCACHE) g++
++CC = $(OBJCACHE) $(CXX)
+ LEX = flex
+ YACC = bison
+ PPSRC = ../Preproc
diff --git a/cad/p5-Verilog-Perl/files/patch-Preproc__Makefile.PL b/cad/p5-Verilog-Perl/files/patch-Preproc__Makefile.PL
new file mode 100644
index 000000000000..747ba533da79
--- /dev/null
+++ b/cad/p5-Verilog-Perl/files/patch-Preproc__Makefile.PL
@@ -0,0 +1,27 @@
+--- Preproc/Makefile.PL 2014-03-11 19:59:40.000000000 -0300
++++ Preproc/Makefile.PL 2014-06-25 11:19:37.000000000 -0300
+@@ -9,13 +9,14 @@
+
+ sub MY::postamble {
+ my $out;
++ $CXX = $ENV{CXX};
+ #print Config::myconfig();
+ if ($Config{osname} !~ /cygwin/i && $Config{archname} !~ /cygwin/i
+ && $Config{osname} !~ /darwin/i && $Config{archname} !~ /darwin/i) {
+ # Cygwin: Don't change LD, it breaks
+ # Sun: Requires g++ LD
+ # Linux: Either way
+- $out .= "LD = g++\n";
++ $out .= "LD = $CXX\n";
+ }
+ # Note OPTIMIZE is passed from upper makefile, so this code needed there too.
+ my $optimize = $Config{optimize}; $optimize =~ s/(^| )-O2( |$)/\1-O\2/g;
+@@ -46,7 +47,7 @@
+ $out .= "${cmt}CFLAGS += -DFLEX_DEBUG\n";
+ $out .= "${cmt}LEXFLAGS += -d\n";
+ $out .= '
+-CC = $(OBJCACHE) g++
++CC = $(OBJCACHE) $(CXX)
+ LEX = flex
+ YACC = bison
+ PPSRC = ../Preproc
diff --git a/cad/p5-Verilog-Perl/pkg-descr b/cad/p5-Verilog-Perl/pkg-descr
index ea471de4d4fd..dc92d97fe7d4 100644
--- a/cad/p5-Verilog-Perl/pkg-descr
+++ b/cad/p5-Verilog-Perl/pkg-descr
@@ -16,4 +16,4 @@ language. It includes:
edit this list, changing as many symbols as you wish. Vrename is then run a
second time to apply the changes.
-WWW: http://www.veripool.org/wiki/verilog-perl
+WWW: http://www.veripool.org/wiki/verilog-perl
diff --git a/cad/p5-Verilog-Perl/pkg-plist b/cad/p5-Verilog-Perl/pkg-plist
index 7d9e5378537f..56a87bae37b3 100644
--- a/cad/p5-Verilog-Perl/pkg-plist
+++ b/cad/p5-Verilog-Perl/pkg-plist
@@ -2,6 +2,7 @@ bin/vhier
bin/vpassert
bin/vppreproc
bin/vrename
+bin/vsplitmodule
%%PERL5_MAN3%%/Verilog::EditFiles.3.gz
%%PERL5_MAN3%%/Verilog::Getopt.3.gz
%%PERL5_MAN3%%/Verilog::Language.3.gz