aboutsummaryrefslogtreecommitdiff
path: root/cad/pdnmesh
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-08-19 13:29:59 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-08-19 13:29:59 +0000
commitbb271f0bf7b513a23a31da4ec8819b113ebf4587 (patch)
treeac5a462edc3d85d5f0b20a594802ce4b12f0bf9f /cad/pdnmesh
parent29879aded766da253313579a3503ff5e15026355 (diff)
downloadports-bb271f0bf7b513a23a31da4ec8819b113ebf4587.tar.gz
ports-bb271f0bf7b513a23a31da4ec8819b113ebf4587.zip
Convert ports to use the options helpers in categories [abc]*, and minor fixes.
Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D3412?
Notes
Notes: svn path=/head/; revision=394778
Diffstat (limited to 'cad/pdnmesh')
-rw-r--r--cad/pdnmesh/Makefile20
1 files changed, 6 insertions, 14 deletions
diff --git a/cad/pdnmesh/Makefile b/cad/pdnmesh/Makefile
index 8ff4aaa190cb..cd7768dc1a94 100644
--- a/cad/pdnmesh/Makefile
+++ b/cad/pdnmesh/Makefile
@@ -25,23 +25,17 @@ LDFLAGS+= -lm
DESKTOP_ENTRIES="pdnMesh" "${COMMENT}" "" "${PORTNAME}" "" true
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MATLAS}
-USES+= blaslapack:atlas
-CONFIGURE_ARGS+=--with-blas=cblas --with-lapack=alapack
-.else
-USES+= blaslapack
-CONFIGURE_ARGS+=--with-blas=blas --with-lapack=lapack
-.endif
+ATLAS_USES= blaslapack:atlas
+ATLAS_CONFIGURE_ON=--with-blas=cblas --with-lapack=alapack
+ATLAS_USES_OFF= blaslapack
+ATLAS_CONFIGURE_OFF=--with-blas=blas --with-lapack=lapack
post-patch:
@${REINPLACE_CMD}-e \
'/^SUBDIRS/s|doc|| ; \
s|^pkgdata_DATA|#pkgdata_DATA|' ${WRKSRC}/Makefile.in
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} \
&& ${INSTALL_DATA} ChangeLog ${STAGEDIR}${DOCSDIR} \
@@ -50,11 +44,9 @@ post-install:
(cd ${WRKSRC}/doc/tutorial \
&& ${INSTALL_DATA} README ${STAGEDIR}${DOCSDIR}/tutorial \
&& ${INSTALL_DATA} tutorial.* ${STAGEDIR}${DOCSDIR}/tutorial)
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
+post-install-EXAMPLES-on:
(cd ${WRKSRC}/doc/examples && \
${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
${RM} ${STAGEDIR}${EXAMPLESDIR}/Makefile*
-.endif
.include <bsd.port.mk>