aboutsummaryrefslogtreecommitdiff
path: root/cad/py-cadquery
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2020-08-16 12:54:13 +0000
committerSteve Wills <swills@FreeBSD.org>2020-08-16 12:54:13 +0000
commit8398ee71c0202e6a6f8eaefbf2abda43c9549c22 (patch)
tree9787dd9ca7ccdfdbb8e2bf0f7371a88a03fe86ef /cad/py-cadquery
parente5e12151145962f82a670215e038b127b17fcd0a (diff)
downloadports-8398ee71c0202e6a6f8eaefbf2abda43c9549c22.tar.gz
ports-8398ee71c0202e6a6f8eaefbf2abda43c9549c22.zip
cad/py-cadquery: create port
CadQuery is an intuitive, easy-to-use Python module for building parametric 3D CAD models. Using CadQuery, you can write short, simple scripts that produce high quality CAD models. It is easy to make many different objects using a single script that can be customized. WWW: https://github.com/CadQuery/cadquery PR: 248210 Submitted by: Neal Nelson <ports@nicandneal.net>
Notes
Notes: svn path=/head/; revision=545104
Diffstat (limited to 'cad/py-cadquery')
-rw-r--r--cad/py-cadquery/Makefile29
-rw-r--r--cad/py-cadquery/distinfo3
-rw-r--r--cad/py-cadquery/files/patch-setup.py11
-rw-r--r--cad/py-cadquery/pkg-descr6
4 files changed, 49 insertions, 0 deletions
diff --git a/cad/py-cadquery/Makefile b/cad/py-cadquery/Makefile
new file mode 100644
index 000000000000..881e445d7290
--- /dev/null
+++ b/cad/py-cadquery/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= cadquery
+DISTVERSION= 2.0.1
+CATEGORIES= cad
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@nicandneal.net
+COMMENT= Python module for building parametric 3D CAD models
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/ezdxf/__init__.py:cad/py-ezdxf@${PY_FLAVOR} \
+ ${PYTHON_SITELIBDIR}/OCP.so:cad/py-ocp@${PY_FLAVOR} \
+ ${PYTHON_SITELIBDIR}/pyparsing.py:devel/py-pyparsing@${PY_FLAVOR} \
+ ${PYTHON_SITELIBDIR}/typing_extensions.py:devel/py-typing-extensions@${PY_FLAVOR}
+
+USES= python:3.6+,run
+USE_PYTHON= autoplist distutils
+
+USE_GITHUB= yes
+GH_ACCOUNT= CadQuery
+GH_PROJECT= cadquery
+
+post-extract:
+# Move into a sub-directory so that we don't pollute site-packages.
+ ${MV} ${WRKSRC}/tests ${WRKSRC}/cadquery/tests
+
+.include <bsd.port.mk>
diff --git a/cad/py-cadquery/distinfo b/cad/py-cadquery/distinfo
new file mode 100644
index 000000000000..d2c1a91f50eb
--- /dev/null
+++ b/cad/py-cadquery/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1595406745
+SHA256 (CadQuery-cadquery-2.0.1_GH0.tar.gz) = 7e126628a3928af42f9a86f2f0efd3ea2b143f9f9c14603a26ac76c25d1596b1
+SIZE (CadQuery-cadquery-2.0.1_GH0.tar.gz) = 1835724
diff --git a/cad/py-cadquery/files/patch-setup.py b/cad/py-cadquery/files/patch-setup.py
new file mode 100644
index 000000000000..3e04f8224240
--- /dev/null
+++ b/cad/py-cadquery/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2020-06-25 14:36:51 UTC
++++ setup.py
+@@ -35,7 +35,7 @@ setup(
+ "cadquery.contrib",
+ "cadquery.occ_impl",
+ "cadquery.plugins",
+- "tests",
++ "cadquery.tests",
+ ],
+ include_package_data=True,
+ zip_safe=False,
diff --git a/cad/py-cadquery/pkg-descr b/cad/py-cadquery/pkg-descr
new file mode 100644
index 000000000000..46a58948d553
--- /dev/null
+++ b/cad/py-cadquery/pkg-descr
@@ -0,0 +1,6 @@
+CadQuery is an intuitive, easy-to-use Python module for building parametric 3D
+CAD models. Using CadQuery, you can write short, simple scripts that produce
+high quality CAD models. It is easy to make many different objects using a
+single script that can be customized.
+
+WWW: https://github.com/CadQuery/cadquery