aboutsummaryrefslogtreecommitdiff
path: root/cad/py-cq-editor
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2020-08-16 12:54:34 +0000
committerSteve Wills <swills@FreeBSD.org>2020-08-16 12:54:34 +0000
commit0ea0c4c9b12f5fdcdb3d0f4add00213706d42295 (patch)
tree622542123984e7f591edd7479f493c40a9f78ca1 /cad/py-cq-editor
parent8398ee71c0202e6a6f8eaefbf2abda43c9549c22 (diff)
downloadports-0ea0c4c9b12f5fdcdb3d0f4add00213706d42295.tar.gz
ports-0ea0c4c9b12f5fdcdb3d0f4add00213706d42295.zip
cad/py-cq-editor: create port
CQ-editor is a CadQuery GUI editor based on PyQT. Graphical debugger for CadQuery scripts - Step through script and watch how your model changes CadQuery object stack inspector - Visual inspection of current workplane and selected items - Insight into evolution of the model Export to various formats - STL - STEP WWW: https://github.com/CadQuery/CQ-editor/ PR: 248212 Submitted by: Neal Nelson <ports@nicandneal.net>
Notes
Notes: svn path=/head/; revision=545105
Diffstat (limited to 'cad/py-cq-editor')
-rw-r--r--cad/py-cq-editor/Makefile23
-rw-r--r--cad/py-cq-editor/distinfo3
-rw-r--r--cad/py-cq-editor/pkg-descr14
3 files changed, 40 insertions, 0 deletions
diff --git a/cad/py-cq-editor/Makefile b/cad/py-cq-editor/Makefile
new file mode 100644
index 000000000000..253f1161969d
--- /dev/null
+++ b/cad/py-cq-editor/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= cq-editor
+DISTVERSION= 0.1.2
+CATEGORIES= cad
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@nicandneal.net
+COMMENT= CadQuery GUI editor based on PyQT
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cadquery:cad/py-cadquery@${PY_FLAVOR}
+
+USES= pyqt:5 python:3.6+
+USE_PYTHON= autoplist distutils
+USE_PYQT= core gui widgets
+
+USE_GITHUB= yes
+GH_ACCOUNT= CadQuery
+GH_PROJECT= CQ-editor
+
+.include <bsd.port.mk>
diff --git a/cad/py-cq-editor/distinfo b/cad/py-cq-editor/distinfo
new file mode 100644
index 000000000000..d31cfb396fc3
--- /dev/null
+++ b/cad/py-cq-editor/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1595406923
+SHA256 (CadQuery-CQ-editor-0.1.2_GH0.tar.gz) = 760f1bf2f5c46dd7b6590f1161ebc7dc6907f286602f4f27a294596eeb51611e
+SIZE (CadQuery-CQ-editor-0.1.2_GH0.tar.gz) = 2229478
diff --git a/cad/py-cq-editor/pkg-descr b/cad/py-cq-editor/pkg-descr
new file mode 100644
index 000000000000..b5ab2d0e6eaa
--- /dev/null
+++ b/cad/py-cq-editor/pkg-descr
@@ -0,0 +1,14 @@
+CQ-editor is a CadQuery GUI editor based on PyQT.
+
+Graphical debugger for CadQuery scripts
+- Step through script and watch how your model changes
+
+CadQuery object stack inspector
+- Visual inspection of current workplane and selected items
+- Insight into evolution of the model
+
+Export to various formats
+- STL
+- STEP
+
+WWW: https://github.com/CadQuery/CQ-editor/