aboutsummaryrefslogtreecommitdiff
path: root/cad/qrouter
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-03-19 05:20:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-03-19 05:20:13 +0000
commitc9f070300be91bd2259b340195449c5f1cd8b51f (patch)
tree3da47bafd4de9929c7a602c8301ce2606c361b42 /cad/qrouter
parent1359966d0931c96542a3c3024c849a1a9adadc9d (diff)
downloadports-c9f070300be91bd2259b340195449c5f1cd8b51f.tar.gz
ports-c9f070300be91bd2259b340195449c5f1cd8b51f.zip
New port: cad/qrouter: Tool to generate metal layers and vias
Notes
Notes: svn path=/head/; revision=528683
Diffstat (limited to 'cad/qrouter')
-rw-r--r--cad/qrouter/Makefile29
-rw-r--r--cad/qrouter/distinfo3
-rw-r--r--cad/qrouter/pkg-descr8
3 files changed, 40 insertions, 0 deletions
diff --git a/cad/qrouter/Makefile b/cad/qrouter/Makefile
new file mode 100644
index 000000000000..496d875a0896
--- /dev/null
+++ b/cad/qrouter/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= qrouter
+DISTVERSION= 1.4.81
+CATEGORIES= cad
+MASTER_SITES= http://opencircuitdesign.com/${PORTNAME}/archive/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Tool to generate metal layers and vias
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+BUILD_DEPENDS= tk87>0:x11-toolkits/tk87 \
+ tcl87>0:lang/tcl87
+
+USES= gmake localbase tar:tgz xorg
+USE_XORG= xt
+
+GNU_CONFIGURE= yes
+
+CFLAGS+= -I${LOCALBASE}/include/tk8.7 -I${LOCALBASE}/include/tcl8.7
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-stage:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/cad/qrouter/distinfo b/cad/qrouter/distinfo
new file mode 100644
index 000000000000..e3e6b8d8d9d8
--- /dev/null
+++ b/cad/qrouter/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1584589818
+SHA256 (qrouter-1.4.81.tgz) = d18ed1d0da450aa2ff18f1f9e31597f2645295f736424c671288ad66f4e5dac7
+SIZE (qrouter-1.4.81.tgz) = 326744
diff --git a/cad/qrouter/pkg-descr b/cad/qrouter/pkg-descr
new file mode 100644
index 000000000000..8b3ed5d1895a
--- /dev/null
+++ b/cad/qrouter/pkg-descr
@@ -0,0 +1,8 @@
+Qrouter is a tool to generate metal layers and vias to physically connect
+together a netlist in a VLSI fabrication technology. It is a maze router,
+otherwise known as an "over-the-cell" router or "sea-of-gates" router. That is,
+unlike a channel router, it begins with a description of placed standard cells,
+usually packed together at minimum spacing, and places metal routes over the
+standard cells.
+
+WWW: http://opencircuitdesign.com/netgen/