aboutsummaryrefslogtreecommitdiff
path: root/cad/solvespace
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-11-10 01:08:44 +0000
committerSteve Wills <swills@FreeBSD.org>2016-11-10 01:08:44 +0000
commit948425549ef6a68337cd35fbea9a675ca2c51272 (patch)
tree7bd1f0cd0158d73e994580003215b2dcfcabd3ad /cad/solvespace
parentf5354365f168dbf8a8806047db0e684f2c7dc75a (diff)
downloadports-948425549ef6a68337cd35fbea9a675ca2c51272.tar.gz
ports-948425549ef6a68337cd35fbea9a675ca2c51272.zip
cad/solvespace: create port
SOLVESPACE is a parametric 3d CAD program. Applications include modeling 2d and 3d parts, 3d-printed parts, preparing CAM data, mechanism design and plane and solid geometry. WWW: http://solvespace.com/
Notes
Notes: svn path=/head/; revision=425822
Diffstat (limited to 'cad/solvespace')
-rw-r--r--cad/solvespace/Makefile34
-rw-r--r--cad/solvespace/distinfo5
-rw-r--r--cad/solvespace/files/patch-CMakeLists.txt14
-rw-r--r--cad/solvespace/pkg-descr5
-rw-r--r--cad/solvespace/pkg-plist18
5 files changed, 76 insertions, 0 deletions
diff --git a/cad/solvespace/Makefile b/cad/solvespace/Makefile
new file mode 100644
index 000000000000..10b2c4a60f2c
--- /dev/null
+++ b/cad/solvespace/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= solvespace
+PORTVERSION= 2.2
+DISTVERSIONPREFIX= v
+CATEGORIES= cad
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Parametric 2d/3d CAD
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
+
+LIB_DEPENDS= libpng.so:graphics/png \
+ libjson-c.so:devel/json-c \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libgtkmm-2.4.so:x11-toolkits/gtkmm24
+
+USE_GITHUB= yes
+GH_PROJECT= libdxfrw:libdxfrw
+GH_TAGNAME= 8f95895:libdxfrw
+GH_SUBDIR= extlib/libdxfrw:libdxfrw
+
+USES= cmake pkgconfig
+USE_GL= gl glu glew
+USE_GNOME= atkmm gtk20 pangomm
+USE_XORG= x11
+USE_LDCONFIG= yes
+INSTALLS_ICONS= yes
+
+BROKEN_FreeBSD_9= Does not build on FreeBSD 9.x
+
+.include <bsd.port.mk>
diff --git a/cad/solvespace/distinfo b/cad/solvespace/distinfo
new file mode 100644
index 000000000000..20489efabf80
--- /dev/null
+++ b/cad/solvespace/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1478636572
+SHA256 (solvespace-solvespace-v2.2_GH0.tar.gz) = ba2d5b6aa78c6d3b1b67b533376c901c687e4d4e233aee2b8bf69e1c29807ae1
+SIZE (solvespace-solvespace-v2.2_GH0.tar.gz) = 2115713
+SHA256 (solvespace-libdxfrw-8f95895_GH0.tar.gz) = d39a07d00b9590be5f2ac7e468cb97077e029498d0e2e5ccfc8d5bbc9e494ba4
+SIZE (solvespace-libdxfrw-8f95895_GH0.tar.gz) = 691378
diff --git a/cad/solvespace/files/patch-CMakeLists.txt b/cad/solvespace/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..0bd9c93de7c9
--- /dev/null
+++ b/cad/solvespace/files/patch-CMakeLists.txt
@@ -0,0 +1,14 @@
+--- CMakeLists.txt.orig 2016-10-17 02:07:14 UTC
++++ CMakeLists.txt
+@@ -20,9 +20,9 @@ set(CMAKE_USER_MAKE_RULES_OVERRIDE_CXX
+ # NOTE TO PACKAGERS: The embedded git commit hash is critical for rapid bug triage when the builds
+ # can come from a variety of sources. If you are mirroring the sources or otherwise build when
+ # the .git directory is not present, please comment the following line:
+-include(GetGitCommitHash)
++#include(GetGitCommitHash)
+ # and instead uncomment the following, adding the complete git hash of the checkout you are using:
+-# set(GIT_COMMIT_HASH 0000000000000000000000000000000000000000)
++set(GIT_COMMIT_HASH c4ad073d1b3d3fcd81b34cbe5f2352547b14213f)
+
+ project(solvespace)
+ set(solvespace_VERSION_MAJOR 2)
diff --git a/cad/solvespace/pkg-descr b/cad/solvespace/pkg-descr
new file mode 100644
index 000000000000..9201c8d67e52
--- /dev/null
+++ b/cad/solvespace/pkg-descr
@@ -0,0 +1,5 @@
+SOLVESPACE is a parametric 3d CAD program. Applications include modeling 2d and
+3d parts, 3d-printed parts, preparing CAM data, mechanism design and plane and
+solid geometry.
+
+WWW: http://solvespace.com/
diff --git a/cad/solvespace/pkg-plist b/cad/solvespace/pkg-plist
new file mode 100644
index 000000000000..05949e4881aa
--- /dev/null
+++ b/cad/solvespace/pkg-plist
@@ -0,0 +1,18 @@
+bin/solvespace
+include/slvs.h
+lib/libslvs.so
+lib/libslvs.so.1
+lib/libslvs.so.2.2
+share/applications/solvespace.desktop
+share/icons/hicolor/16x16/apps/solvespace.png
+share/icons/hicolor/16x16/mimetypes/application.x-solvespace.png
+share/icons/hicolor/24x24/apps/solvespace.png
+share/icons/hicolor/24x24/mimetypes/application.x-solvespace.png
+share/icons/hicolor/32x32/apps/solvespace.png
+share/icons/hicolor/32x32/mimetypes/application.x-solvespace.png
+share/icons/hicolor/48x48/apps/solvespace.png
+share/icons/hicolor/48x48/mimetypes/application.x-solvespace.png
+share/pixmaps/solvespace-16x16.xpm
+share/pixmaps/solvespace-24x24.xpm
+share/pixmaps/solvespace-32x32.xpm
+share/pixmaps/solvespace-48x48.xpm