aboutsummaryrefslogtreecommitdiff
path: root/cad/sumo
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-12-03 19:20:35 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-12-03 19:20:35 +0000
commitebccb14778029f48aa12383da22034ba919e5b23 (patch)
tree9bb68cbe459830a2a0d00704476a71530fa97db8 /cad/sumo
parent5227936c18f2da8b470c6e6739418e616d1fd50b (diff)
downloadports-ebccb14778029f48aa12383da22034ba919e5b23.tar.gz
ports-ebccb14778029f48aa12383da22034ba919e5b23.zip
New port: cad/sumo: Traffic simulation suite for road vehicles, public transportation, etc
PR: 193884 Submitted by: Enrique Fynn <me@enriquefynn.com> Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13248
Notes
Notes: svn path=/head/; revision=455420
Diffstat (limited to 'cad/sumo')
-rw-r--r--cad/sumo/Makefile53
-rw-r--r--cad/sumo/distinfo5
-rw-r--r--cad/sumo/pkg-descr5
-rw-r--r--cad/sumo/pkg-plist15
4 files changed, 78 insertions, 0 deletions
diff --git a/cad/sumo/Makefile b/cad/sumo/Makefile
new file mode 100644
index 000000000000..0267249e3251
--- /dev/null
+++ b/cad/sumo/Makefile
@@ -0,0 +1,53 @@
+# $FreeBSD$
+
+PORTNAME= sumo
+DISTVERSION= 0.31.0
+CATEGORIES= cad
+MASTER_SITES= http://www.dlr.de/ts/en/Portaldata/16/Resources/projekte/sumo/
+DISTFILES= ${PORTNAME}-src-${DISTVERSIONFULL}${EXTRACT_SUFX}
+
+MAINTAINER= enriquefynn@gmail.com
+COMMENT= Traffic simulation suite for road vehicles, public transportation, etc
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libFOX-1.6.so:x11-toolkits/fox16 \
+ libfreetype.so:print/freetype2 \
+ libgdal.so:graphics/gdal \
+ libpng16.so:graphics/png \
+ libproj.so:graphics/proj \
+ libtiff.so:graphics/tiff \
+ libxerces-c.so:textproc/xerces-c3
+
+USES= jpeg zip
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-proj-gdal=${LOCALBASE} \
+ --with-xerces-libraries=${LOCALBASE}/lib \
+ --disable-debug
+USE_GL= gl glu
+USE_XORG= x11 xcursor xext xfixes xft xi xrandr xrender
+
+OPTIONS_DEFINE= DOCS # the GUI option is possible (--without-fox-config), but it is broken, and it doesn't seem important to have. https://github.com/DLR-TS/sumo/issues/3655
+
+DOCS_DISTFILES= ${PORTNAME}-doc-${DISTVERSION}${EXTRACT_SUFX}
+DOCS_USES= shebangfix
+DOCS_VARS= SHEBANG_FILES=docs/tutorial/*/*.py
+
+PORTDOCS= *
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
+ @${FIND} ${STAGEDIR}${DOCSDIR} -d -empty -delete
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100000
+BUILD_DEPENDS+= clang40:devel/llvm40
+CC= clang40
+CXX= clang++40 # fails to build with the default compiler on 10
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/cad/sumo/distinfo b/cad/sumo/distinfo
new file mode 100644
index 000000000000..f625c4b12b89
--- /dev/null
+++ b/cad/sumo/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1512078820
+SHA256 (sumo-src-0.31.0.zip) = ae9d71079439d4fb2b97023d8d50003c3b0756b00a836a20abede8c77e5e213c
+SIZE (sumo-src-0.31.0.zip) = 18515639
+SHA256 (sumo-doc-0.31.0.zip) = 25c0471461cf39fb38ab19f1db397969add088630470ea8ed6cc7685f88efcd4
+SIZE (sumo-doc-0.31.0.zip) = 72064786
diff --git a/cad/sumo/pkg-descr b/cad/sumo/pkg-descr
new file mode 100644
index 000000000000..284f66d5937e
--- /dev/null
+++ b/cad/sumo/pkg-descr
@@ -0,0 +1,5 @@
+Simulation of Urban MObility (SUMO) is an open source, highly portable,
+microscopic and continuous road traffic simulation package designed to handle
+large road networks.
+
+WWW: http://sumo-sim.org
diff --git a/cad/sumo/pkg-plist b/cad/sumo/pkg-plist
new file mode 100644
index 000000000000..7f3c7c4856e3
--- /dev/null
+++ b/cad/sumo/pkg-plist
@@ -0,0 +1,15 @@
+bin/TraCITestClient
+bin/activitygen
+bin/dfrouter
+bin/duarouter
+bin/emissionsDrivingCycle
+bin/emissionsMap
+bin/jtrrouter
+bin/marouter
+bin/netconvert
+bin/netedit
+bin/netgenerate
+bin/od2trips
+bin/polyconvert
+bin/sumo
+bin/sumo-gui