aboutsummaryrefslogtreecommitdiff
path: root/cad/sweethome3d
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-10-23 08:23:22 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-10-23 08:23:22 +0000
commitacc9b3a0dda95fae1a9b32c6e3789d771f3c40d5 (patch)
tree66fa59029be054f20d9e3337d1e82db79bc70f53 /cad/sweethome3d
parent59e033c960f090748ddc9da765be727f47217c15 (diff)
downloadports-acc9b3a0dda95fae1a9b32c6e3789d771f3c40d5.tar.gz
ports-acc9b3a0dda95fae1a9b32c6e3789d771f3c40d5.zip
- Enforce JAVA_VERSION when launching javavm(1), otherwise the program
crashes when several JDK versions are installed and javawm(1) picks higher version (happens when /usr/ports/Mk/bsd.java.mk is absent, contrary to documented selection process which is designed to behave almost identically WRT presence/absence of /usr/ports/Mk/bsd.java.mk - While here, simplify the script a bit and remove keywords and their expansion, they are useless for wrapper scripts PR: 250268 Submitted by: rodrigo
Notes
Notes: svn path=/head/; revision=553098
Diffstat (limited to 'cad/sweethome3d')
-rw-r--r--cad/sweethome3d/Makefile1
-rw-r--r--cad/sweethome3d/files/sweethome3d.sh.in6
2 files changed, 3 insertions, 4 deletions
diff --git a/cad/sweethome3d/Makefile b/cad/sweethome3d/Makefile
index c357c0a0975d..057bfc0b9b84 100644
--- a/cad/sweethome3d/Makefile
+++ b/cad/sweethome3d/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sweethome3d
PORTVERSION= 6.4.2
+PORTREVISION= 1
CATEGORIES= cad java
MASTER_SITES= SF/${PORTNAME}/SweetHome3D-source/${DISTNAME}/
DISTNAME= SweetHome3D-${PORTVERSION}-src
diff --git a/cad/sweethome3d/files/sweethome3d.sh.in b/cad/sweethome3d/files/sweethome3d.sh.in
index 98b88265f4d3..1584b6778854 100644
--- a/cad/sweethome3d/files/sweethome3d.sh.in
+++ b/cad/sweethome3d/files/sweethome3d.sh.in
@@ -1,8 +1,6 @@
#!/bin/sh
-#
-# $FreeBSD$
JAVA="%%LOCALBASE%%/bin/java"
-JARPATH="%%JAVALIBDIR%%"
+SH3D_JAR="%%JAVALIBDIR%%/%%JARNAME%%"
-exec "${JAVA}" -Xmx1024m -jar "${JARPATH}/%%JARNAME%%" "$@"
+JAVA_VERSION=%%JAVA_VERSION%% exec "${JAVA}" -Xmx1024m -jar "${SH3D_JAR}" "$@"