aboutsummaryrefslogtreecommitdiff
path: root/cad/tkgate/Makefile
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2015-06-24 14:23:14 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2015-06-24 14:23:14 +0000
commite34e0e7775c3b2d5b6250c378adca8bca8acb532 (patch)
treece8488098cd58f88814436fb99b013b2c741d0ea /cad/tkgate/Makefile
parentdb5d0315f62dc135dfece31e1846b7895e83550e (diff)
downloadports-e34e0e7775c3b2d5b6250c378adca8bca8acb532.tar.gz
ports-e34e0e7775c3b2d5b6250c378adca8bca8acb532.zip
Notes
Diffstat (limited to 'cad/tkgate/Makefile')
-rw-r--r--cad/tkgate/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/cad/tkgate/Makefile b/cad/tkgate/Makefile
new file mode 100644
index 000000000000..4a7015252330
--- /dev/null
+++ b/cad/tkgate/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= tkgate
+PORTVERSION= 2.0.0
+CATEGORIES= cad
+MASTER_SITES= http://highsecure.ru/distfiles/ \
+ http://cdn.bitbucket.org/starling13/tkgate/downloads/
+
+MAINTAINER= vsevolod@FreeBSD.org
+COMMENT= Event driven digital circuit simulator
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+GNU_CONFIGURE= yes
+USES+= tk:build,run
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/wish|${WISH}|g' ${WRKSRC}/scripts/tree.tcl
+ @${REINPLACE_CMD} -e \
+ 's|%%TCL_VER%%|${TCL_VER}|g; \
+ s|%%TCL_INCLUDEDIR%%|${TCL_INCLUDEDIR}|g; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/configure
+
+# Remove backup files somehow installed to the stagedir
+post-stage:
+ ${FIND} ${STAGEDIR}/${DATADIR} -name '*~' -delete -or -name '*~?' -delete
+
+.include <bsd.port.mk>