aboutsummaryrefslogtreecommitdiff
path: root/cad/tkgate
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2019-08-08 15:08:31 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2019-08-08 15:08:31 +0000
commitc6ce1c0b390f172ca0b40c1913b04ddfcd3f78cc (patch)
tree5c63044111e238361dcacadba14bd3a964174f8c /cad/tkgate
parente10066389949f335741e6bba673ebae431859fca (diff)
downloadports-c6ce1c0b390f172ca0b40c1913b04ddfcd3f78cc.tar.gz
ports-c6ce1c0b390f172ca0b40c1913b04ddfcd3f78cc.zip
- Update to 2.1
- Use autoreconf - Add pango dependency - Remove obsoleted master site - Add patches to avoid malloc.h include PR: 234081 Submitted by: ManFree <roman_romul at mail.ru>
Notes
Notes: svn path=/head/; revision=508387
Diffstat (limited to 'cad/tkgate')
-rw-r--r--cad/tkgate/Makefile12
-rw-r--r--cad/tkgate/distinfo5
-rw-r--r--cad/tkgate/files/patch-config.h.in11
-rw-r--r--cad/tkgate/files/patch-configure.ac (renamed from cad/tkgate/files/patch-configure)19
-rw-r--r--cad/tkgate/files/patch-src_common_list.c10
-rw-r--r--cad/tkgate/pkg-plist342
6 files changed, 308 insertions, 91 deletions
diff --git a/cad/tkgate/Makefile b/cad/tkgate/Makefile
index fe120ff24498..be698447ff73 100644
--- a/cad/tkgate/Makefile
+++ b/cad/tkgate/Makefile
@@ -1,11 +1,9 @@
# $FreeBSD$
PORTNAME= tkgate
-PORTVERSION= 2.0.0
-PORTREVISION= 1
+PORTVERSION= 2.1
CATEGORIES= cad
-MASTER_SITES= http://highsecure.ru/distfiles/ \
- http://cdn.bitbucket.org/starling13/tkgate/downloads/
+MASTER_SITES= http://cdn.bitbucket.org/starling13/tkgate/downloads/
MAINTAINER= vsevolod@FreeBSD.org
COMMENT= Event driven digital circuit simulator
@@ -14,8 +12,8 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-USES+= iconv:translit tk:build,run
-
+USES+= iconv:translit tk:build,run autoreconf
+USE_GNOME= pango
OPTIONS_DEFINE= DOCS
post-patch:
@@ -24,7 +22,7 @@ post-patch:
's|%%TCL_VER%%|${TCL_VER}|g; \
s|%%TCL_INCLUDEDIR%%|${TCL_INCLUDEDIR}|g; \
s|%%LOCALBASE%%|${LOCALBASE}|g' \
- ${WRKSRC}/configure
+ ${WRKSRC}/configure.ac
# Remove backup files somehow installed to the stagedir
post-install:
diff --git a/cad/tkgate/distinfo b/cad/tkgate/distinfo
index 2949c199bf08..8f5ac84edd5c 100644
--- a/cad/tkgate/distinfo
+++ b/cad/tkgate/distinfo
@@ -1,2 +1,3 @@
-SHA256 (tkgate-2.0.0.tar.gz) = 4a9829ec8e8082ef7ceb26b358a9a3e8c632c5726a24eccb389777db701ed10a
-SIZE (tkgate-2.0.0.tar.gz) = 8916887
+TIMESTAMP = 1565260422
+SHA256 (tkgate-2.1.tar.gz) = 3cafc1fbad59bca139736da1208635a99daff39a43f0e148b3d338f1fb705bc0
+SIZE (tkgate-2.1.tar.gz) = 10598271
diff --git a/cad/tkgate/files/patch-config.h.in b/cad/tkgate/files/patch-config.h.in
new file mode 100644
index 000000000000..e72b1779881a
--- /dev/null
+++ b/cad/tkgate/files/patch-config.h.in
@@ -0,0 +1,11 @@
+--- config.h.in.orig 2019-08-08 11:15:24 UTC
++++ config.h.in
+@@ -57,7 +57,7 @@
+ #undef HAVE_MALLOC
+
+ /* Define to 1 if you have the <malloc.h> header file. */
+-#undef HAVE_MALLOC_H
++/* #undef HAVE_MALLOC_H */
+
+ /* Define to 1 if you have the `memmove' function. */
+ #undef HAVE_MEMMOVE
diff --git a/cad/tkgate/files/patch-configure b/cad/tkgate/files/patch-configure.ac
index 64662a658613..0e38cf9f9cb1 100644
--- a/cad/tkgate/files/patch-configure
+++ b/cad/tkgate/files/patch-configure.ac
@@ -1,29 +1,34 @@
---- configure.orig 2015-06-24 14:08:08 UTC
-+++ configure
-@@ -2887,22 +2887,22 @@ $as_echo "#define TKGATE_COPYRIGHT \"Cop
+--- configure.ac.orig 2018-12-14 11:38:37 UTC
++++ configure.ac
+@@ -31,27 +31,25 @@ AC_DEFINE(TKGATE_HOMEPAGE, "https://bitbucket.org/star
+ #
+ # Configuration options.
+ #
+-
#
# Tcl/Tk version we will try to use (from most favored to least favored)
#
-TKGATE_TCLTK_VERSIONS="8.6 8.5 8.4 8.3"
-+TKGATE_TCLTK_VERSIONS="%%TCL_VER%%"
++TKGATE_TCLTK_VERSIONS="8.6"
#
# Directories to search for include files
#
-TKGATE_INCDIRS="/usr/X11R6/include /usr/X11/include /pkgs/include /usr/local/include /usr/openwin/include /usr/X/include /usr/include /sw/include /opt/local/include"
-+TKGATE_INCDIRS="%%LOCALBASE%%/include %%TCL_INCLUDEDIR%%"
++TKGATE_INCDIRS="/usr/local/include /usr/local/include/tcl8.6"
#
# Directories to search for library files
#
-TKGATE_LIBDIRS="/usr/X11R6/lib /usr/X11/lib /pkgs/lib /usr/local/lib /usr/lib /sw/lib /opt/local/lib /usr/local/lib/tcl /usr/lib64"
-+TKGATE_LIBDIRS="%%LOCALBASE%%/lib"
++TKGATE_LIBDIRS="/usr/local/lib"
#
# Libraries we may need if available.
#
-#TKGATE_OPTLIBNAMES="dl socket nsl m"
+-
+TKGATE_OPTLIBNAMES="m"
-
#############################################################################
+ #
diff --git a/cad/tkgate/files/patch-src_common_list.c b/cad/tkgate/files/patch-src_common_list.c
new file mode 100644
index 000000000000..e3d427796673
--- /dev/null
+++ b/cad/tkgate/files/patch-src_common_list.c
@@ -0,0 +1,10 @@
+--- src/common/list.c.orig 2019-08-08 12:43:30 UTC
++++ src/common/list.c
+@@ -16,7 +16,6 @@
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+ ****************************************************************************/
+ #include <stdlib.h>
+-#include <malloc.h>
+ #include "misc.h"
+ #include "list.h"
+
diff --git a/cad/tkgate/pkg-plist b/cad/tkgate/pkg-plist
index 6e2b8b2e4085..b4a1370bcfad 100644
--- a/cad/tkgate/pkg-plist
+++ b/cad/tkgate/pkg-plist
@@ -17,6 +17,31 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/bindings/windows
%%DATADIR%%/doc/74xx.txt
%%DATADIR%%/doc/adding_gate_types.txt
+%%DATADIR%%/doc/docbook/index.xml
+%%DATADIR%%/doc/docbook/index.xsl
+%%DATADIR%%/doc/docbook/index_fo.xsl
+%%DATADIR%%/doc/docbook/titlepage.templates.xml
+%%DATADIR%%/doc/docbook/titlepage.xsl
+%%DATADIR%%/doc/en/gateEdit.html
+%%DATADIR%%/doc/en/gateGmac.html
+%%DATADIR%%/doc/en/gateHDL.html
+%%DATADIR%%/doc/en/gateInterface.html
+%%DATADIR%%/doc/en/gateIntro.html
+%%DATADIR%%/doc/en/gateLibrary.html
+%%DATADIR%%/doc/en/gateModules.html
+%%DATADIR%%/doc/en/gateOptions.html
+%%DATADIR%%/doc/en/gateSim.html
+%%DATADIR%%/doc/en/gateTypeList.html
+%%DATADIR%%/doc/en/index.html
+%%DATADIR%%/doc/en/menagerie.html
+%%DATADIR%%/doc/en/menuList.html
+%%DATADIR%%/doc/en/popupmenu.html
+%%DATADIR%%/doc/en/simErrors.html
+%%DATADIR%%/doc/en/systemTasks.html
+%%DATADIR%%/doc/en/temp.html
+%%DATADIR%%/doc/en/toolbarList.html
+%%DATADIR%%/doc/en/verga.html
+%%DATADIR%%/doc/en/vpdCreation.html
%%DATADIR%%/doc/favicon.ico
%%DATADIR%%/doc/fig/adder_circuit.gif
%%DATADIR%%/doc/fig/adder_circuit2.gif
@@ -37,6 +62,7 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/doc/fig/before_andinv.gif
%%DATADIR%%/doc/fig/before_cut.gif
%%DATADIR%%/doc/fig/biggatelogo.gif
+%%DATADIR%%/doc/fig/biggatelogo20.gif
%%DATADIR%%/doc/fig/bittap.gif
%%DATADIR%%/doc/fig/blk_claim.gif
%%DATADIR%%/doc/fig/blk_close.gif
@@ -54,7 +80,9 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/doc/fig/break.gif
%%DATADIR%%/doc/fig/chdir.gif
%%DATADIR%%/doc/fig/chip.gif
+%%DATADIR%%/doc/fig/circprop_general-small.png
%%DATADIR%%/doc/fig/circprop_general.gif
+%%DATADIR%%/doc/fig/circprop_general.png
%%DATADIR%%/doc/fig/circprop_simulation.gif
%%DATADIR%%/doc/fig/cokemachine.gif
%%DATADIR%%/doc/fig/cokemachinewin.gif
@@ -72,8 +100,11 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/doc/fig/cpathcirc.gif
%%DATADIR%%/doc/fig/cpathdlg.gif
%%DATADIR%%/doc/fig/create1.gif
+%%DATADIR%%/doc/fig/create1.png
%%DATADIR%%/doc/fig/create2.gif
+%%DATADIR%%/doc/fig/create2.png
%%DATADIR%%/doc/fig/create3.gif
+%%DATADIR%%/doc/fig/create3.png
%%DATADIR%%/doc/fig/cretin.gif
%%DATADIR%%/doc/fig/cretinout.gif
%%DATADIR%%/doc/fig/cretout.gif
@@ -114,6 +145,7 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/doc/fig/file_saveas.gif
%%DATADIR%%/doc/fig/filemenu.gif
%%DATADIR%%/doc/fig/fileopen.gif
+%%DATADIR%%/doc/fig/fileopen.png
%%DATADIR%%/doc/fig/forward.gif
%%DATADIR%%/doc/fig/g_add.gif
%%DATADIR%%/doc/fig/g_and.gif
@@ -165,7 +197,9 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/doc/fig/inv_curs.gif
%%DATADIR%%/doc/fig/invaddel.gif
%%DATADIR%%/doc/fig/label.gif
+%%DATADIR%%/doc/fig/libmanager-small.png
%%DATADIR%%/doc/fig/libmanager.gif
+%%DATADIR%%/doc/fig/libmanager.png
%%DATADIR%%/doc/fig/librariesOpts.gif
%%DATADIR%%/doc/fig/log.gif
%%DATADIR%%/doc/fig/logic.gif
@@ -177,6 +211,7 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/doc/fig/logicx.gif
%%DATADIR%%/doc/fig/logicz.gif
%%DATADIR%%/doc/fig/majortabs.gif
+%%DATADIR%%/doc/fig/majortabs.png
%%DATADIR%%/doc/fig/makeand.gif
%%DATADIR%%/doc/fig/makemodinst1.gif
%%DATADIR%%/doc/fig/makemodinst2.gif
@@ -327,6 +362,7 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/doc/fig/solder.gif
%%DATADIR%%/doc/fig/ss_done.gif
%%DATADIR%%/doc/fig/statusbar.gif
+%%DATADIR%%/doc/fig/statusbar.png
%%DATADIR%%/doc/fig/symed_autobold.gif
%%DATADIR%%/doc/fig/symed_bold.gif
%%DATADIR%%/doc/fig/symed_ccwrotate.gif
@@ -349,40 +385,27 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/doc/fig/symed_select_S.gif
%%DATADIR%%/doc/fig/text.gif
%%DATADIR%%/doc/fig/tkgate.gif
+%%DATADIR%%/doc/fig/tkgatewindow-small.png
+%%DATADIR%%/doc/fig/tkgatewindow.png
%%DATADIR%%/doc/fig/toolbarOpts.gif
%%DATADIR%%/doc/fig/tty.gif
%%DATADIR%%/doc/fig/ttywindow.gif
%%DATADIR%%/doc/fig/txchar.gif
%%DATADIR%%/doc/fig/unknown.gif
%%DATADIR%%/doc/fig/unused.gif
+%%DATADIR%%/doc/fig/valid-html401.png
%%DATADIR%%/doc/fig/wiretype.gif
%%DATADIR%%/doc/fig/wsize.gif
+%%DATADIR%%/doc/fig/xgate-small.png
%%DATADIR%%/doc/fig/xgate.gif
+%%DATADIR%%/doc/fig/xgate.png
%%DATADIR%%/doc/fig/xmark.gif
%%DATADIR%%/doc/fig/zoom_in.gif
%%DATADIR%%/doc/fig/zoom_out.gif
-%%DATADIR%%/doc/gateEdit.html
-%%DATADIR%%/doc/gateGmac.html
-%%DATADIR%%/doc/gateHDL.html
-%%DATADIR%%/doc/gateInterface.html
-%%DATADIR%%/doc/gateIntro.html
-%%DATADIR%%/doc/gateLibrary.html
-%%DATADIR%%/doc/gateModules.html
-%%DATADIR%%/doc/gateOptions.html
-%%DATADIR%%/doc/gateSim.html
-%%DATADIR%%/doc/gateTypeList.html
-%%DATADIR%%/doc/index.html
%%DATADIR%%/doc/menagerie.gm
-%%DATADIR%%/doc/menagerie.html
-%%DATADIR%%/doc/menuList.html
-%%DATADIR%%/doc/popupmenu.html
-%%DATADIR%%/doc/simErrors.html
-%%DATADIR%%/doc/systemTasks.html
-%%DATADIR%%/doc/temp.html
+%%DATADIR%%/doc/ru/index.html
%%DATADIR%%/doc/tkgate.css
-%%DATADIR%%/doc/toolbarList.html
-%%DATADIR%%/doc/verga.html
-%%DATADIR%%/doc/vpdCreation.html
+%%DATADIR%%/doc/valid-html401.png
%%DATADIR%%/gdf/default.gdf
%%DATADIR%%/gdf/pat.gdf
%%DATADIR%%/images/Ucat1.gif
@@ -452,6 +475,7 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/images/bigdetails.gif
%%DATADIR%%/images/biggatelogo.gif
%%DATADIR%%/images/biggatelogo.xbm
+%%DATADIR%%/images/biggatelogo20.gif
%%DATADIR%%/images/bigiface.gif
%%DATADIR%%/images/bigleftarrow.b
%%DATADIR%%/images/bigleftarrow.gif
@@ -756,6 +780,8 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/images/portrait.gif
%%DATADIR%%/images/printer.gif
%%DATADIR%%/images/probe.b
+%%DATADIR%%/images/pulldown.b
+%%DATADIR%%/images/pullup.b
%%DATADIR%%/images/ram.b
%%DATADIR%%/images/reg.b
%%DATADIR%%/images/regLR.b
@@ -950,21 +976,48 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/images/zoom_out.gif
%%DATADIR%%/libexec/tkgate
%%DATADIR%%/libexec/verga
+%%DATADIR%%/locale/ar/messages
+%%DATADIR%%/locale/az/messages
+%%DATADIR%%/locale/bg/messages
%%DATADIR%%/locale/ca/messages
+%%DATADIR%%/locale/cs/examples/ex1/combinational.v
+%%DATADIR%%/locale/cs/examples/ex2/flipflop.v
+%%DATADIR%%/locale/cs/examples/ex3/counter.v
+%%DATADIR%%/locale/cs/examples/ex4/trff.v
+%%DATADIR%%/locale/cs/examples/ex5/menagerie.gm
+%%DATADIR%%/locale/cs/examples/ex5/menagerie.gss
+%%DATADIR%%/locale/cs/examples/ex5/menagerie.map
+%%DATADIR%%/locale/cs/examples/ex5/menagerie.mem
+%%DATADIR%%/locale/cs/examples/ex5/menagerie.v
+%%DATADIR%%/locale/cs/examples/ex5/menagerie.vs
+%%DATADIR%%/locale/cs/examples/ex5/x-menagerie.mem
+%%DATADIR%%/locale/cs/examples/ex6/coke.v
+%%DATADIR%%/locale/cs/examples/ex7/stdlogic.v
+%%DATADIR%%/locale/cs/examples/index.v
%%DATADIR%%/locale/cs/messages
-%%DATADIR%%/locale/cs/messages.iso-8859-2
+%%DATADIR%%/locale/cs/tutorials/advanced.v
+%%DATADIR%%/locale/cs/tutorials/combinational1.v
+%%DATADIR%%/locale/cs/tutorials/combinational2.v
+%%DATADIR%%/locale/cs/tutorials/combinational3.v
+%%DATADIR%%/locale/cs/tutorials/combinational4.v
+%%DATADIR%%/locale/cs/tutorials/combinational5.v
+%%DATADIR%%/locale/cs/tutorials/create.v
+%%DATADIR%%/locale/cs/tutorials/gates.v
+%%DATADIR%%/locale/cs/tutorials/group.v
+%%DATADIR%%/locale/cs/tutorials/index.v
+%%DATADIR%%/locale/cs/tutorials/interface.txt
+%%DATADIR%%/locale/cs/tutorials/modules.v
+%%DATADIR%%/locale/cs/tutorials/options.v
+%%DATADIR%%/locale/cs/tutorials/sequential1.v
+%%DATADIR%%/locale/cs/tutorials/sequential2.v
+%%DATADIR%%/locale/cs/tutorials/sequential3.v
+%%DATADIR%%/locale/cs/tutorials/sequential4.v
+%%DATADIR%%/locale/cs/tutorials/sequential5.v
+%%DATADIR%%/locale/cs/tutorials/verilog.v
+%%DATADIR%%/locale/cs/tutorials/welcome.v
+%%DATADIR%%/locale/cs/tutorials/wires.v
%%DATADIR%%/locale/cy/messages
-%%DATADIR%%/locale/de/examples.18/ex1/combinational.v
-%%DATADIR%%/locale/de/examples.18/ex2/flipflop.v
-%%DATADIR%%/locale/de/examples.18/ex3/counter.v
-%%DATADIR%%/locale/de/examples.18/ex4/trff.v
-%%DATADIR%%/locale/de/examples.18/ex5/menagerie.gm
-%%DATADIR%%/locale/de/examples.18/ex5/menagerie.gss
-%%DATADIR%%/locale/de/examples.18/ex5/menagerie.map
-%%DATADIR%%/locale/de/examples.18/ex5/menagerie.mem
-%%DATADIR%%/locale/de/examples.18/ex5/menagerie.v
-%%DATADIR%%/locale/de/examples.18/ex5/x-menagerie.mem
-%%DATADIR%%/locale/de/examples.18/index.v
+%%DATADIR%%/locale/da/messages
%%DATADIR%%/locale/de/examples/ex1/combinational.v
%%DATADIR%%/locale/de/examples/ex2/flipflop.v
%%DATADIR%%/locale/de/examples/ex3/counter.v
@@ -977,17 +1030,9 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/locale/de/examples/ex5/menagerie.vs
%%DATADIR%%/locale/de/examples/ex5/x-menagerie.mem
%%DATADIR%%/locale/de/examples/ex6/coke.v
+%%DATADIR%%/locale/de/examples/ex7/stdlogic.v
%%DATADIR%%/locale/de/examples/index.v
%%DATADIR%%/locale/de/messages
-%%DATADIR%%/locale/de/messages.iso8859
-%%DATADIR%%/locale/de/tutorials.18/create_tut.v
-%%DATADIR%%/locale/de/tutorials.18/edit1_tut.v
-%%DATADIR%%/locale/de/tutorials.18/edit2_tut.v
-%%DATADIR%%/locale/de/tutorials.18/edwire_tut.v
-%%DATADIR%%/locale/de/tutorials.18/module_tut.v
-%%DATADIR%%/locale/de/tutorials.18/seqsim_tut.v
-%%DATADIR%%/locale/de/tutorials.18/sim_tut.v
-%%DATADIR%%/locale/de/tutorials.18/welcome_tut.v
%%DATADIR%%/locale/de/tutorials/advanced.v
%%DATADIR%%/locale/de/tutorials/combinational1.v
%%DATADIR%%/locale/de/tutorials/combinational2.v
@@ -996,13 +1041,10 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/locale/de/tutorials/combinational5.v
%%DATADIR%%/locale/de/tutorials/create.v
%%DATADIR%%/locale/de/tutorials/gates.v
-%%DATADIR%%/locale/de/tutorials/glossary.v
%%DATADIR%%/locale/de/tutorials/group.v
%%DATADIR%%/locale/de/tutorials/index.v
%%DATADIR%%/locale/de/tutorials/interface.txt
-%%DATADIR%%/locale/de/tutorials/moddef_tut.v
%%DATADIR%%/locale/de/tutorials/modules.v
-%%DATADIR%%/locale/de/tutorials/notes.v
%%DATADIR%%/locale/de/tutorials/options.v
%%DATADIR%%/locale/de/tutorials/sequential1.v
%%DATADIR%%/locale/de/tutorials/sequential2.v
@@ -1011,9 +1053,7 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/locale/de/tutorials/sequential5.v
%%DATADIR%%/locale/de/tutorials/verilog.v
%%DATADIR%%/locale/de/tutorials/welcome.v
-%%DATADIR%%/locale/de/tutorials/wire2.v
%%DATADIR%%/locale/de/tutorials/wires.v
-%%DATADIR%%/locale/en/all.txt
%%DATADIR%%/locale/en/examples/ex1/combinational.v
%%DATADIR%%/locale/en/examples/ex2/flipflop.v
%%DATADIR%%/locale/en/examples/ex3/counter.v
@@ -1026,8 +1066,8 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/locale/en/examples/ex5/menagerie.vs
%%DATADIR%%/locale/en/examples/ex5/x-menagerie.mem
%%DATADIR%%/locale/en/examples/ex6/coke.v
+%%DATADIR%%/locale/en/examples/ex7/stdlogic.v
%%DATADIR%%/locale/en/examples/index.v
-%%DATADIR%%/locale/en/license.txt
%%DATADIR%%/locale/en/messages
%%DATADIR%%/locale/en/tutorials/advanced.v
%%DATADIR%%/locale/en/tutorials/combinational1.v
@@ -1050,33 +1090,98 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/locale/en/tutorials/verilog.v
%%DATADIR%%/locale/en/tutorials/welcome.v
%%DATADIR%%/locale/en/tutorials/wires.v
-%%DATADIR%%/locale/en/unused.txt
+%%DATADIR%%/locale/es/examples/ex1/combinational.v
+%%DATADIR%%/locale/es/examples/ex2/flipflop.v
+%%DATADIR%%/locale/es/examples/ex3/counter.v
+%%DATADIR%%/locale/es/examples/ex4/trff.v
+%%DATADIR%%/locale/es/examples/ex5/menagerie.gm
+%%DATADIR%%/locale/es/examples/ex5/menagerie.gss
+%%DATADIR%%/locale/es/examples/ex5/menagerie.map
+%%DATADIR%%/locale/es/examples/ex5/menagerie.mem
+%%DATADIR%%/locale/es/examples/ex5/menagerie.v
+%%DATADIR%%/locale/es/examples/ex5/menagerie.vs
+%%DATADIR%%/locale/es/examples/ex5/x-menagerie.mem
+%%DATADIR%%/locale/es/examples/ex6/coke.v
+%%DATADIR%%/locale/es/examples/ex7/stdlogic.v
+%%DATADIR%%/locale/es/examples/index.v
%%DATADIR%%/locale/es/messages
+%%DATADIR%%/locale/es/tutorials/advanced.v
+%%DATADIR%%/locale/es/tutorials/combinational1.v
+%%DATADIR%%/locale/es/tutorials/combinational2.v
+%%DATADIR%%/locale/es/tutorials/combinational3.v
+%%DATADIR%%/locale/es/tutorials/combinational4.v
+%%DATADIR%%/locale/es/tutorials/combinational5.v
+%%DATADIR%%/locale/es/tutorials/create.v
+%%DATADIR%%/locale/es/tutorials/gates.v
+%%DATADIR%%/locale/es/tutorials/group.v
+%%DATADIR%%/locale/es/tutorials/index.v
+%%DATADIR%%/locale/es/tutorials/interface.txt
+%%DATADIR%%/locale/es/tutorials/modules.v
+%%DATADIR%%/locale/es/tutorials/options.v
+%%DATADIR%%/locale/es/tutorials/sequential1.v
+%%DATADIR%%/locale/es/tutorials/sequential2.v
+%%DATADIR%%/locale/es/tutorials/sequential3.v
+%%DATADIR%%/locale/es/tutorials/sequential4.v
+%%DATADIR%%/locale/es/tutorials/sequential5.v
+%%DATADIR%%/locale/es/tutorials/verilog.v
+%%DATADIR%%/locale/es/tutorials/welcome.v
+%%DATADIR%%/locale/es/tutorials/wires.v
%%DATADIR%%/locale/fr/messages
-%%DATADIR%%/locale/it/examples.18/ex1/combinational.v
-%%DATADIR%%/locale/it/examples.18/ex2/flipflop.v
-%%DATADIR%%/locale/it/examples.18/ex3/counter.v
-%%DATADIR%%/locale/it/examples.18/ex4/trff.v
-%%DATADIR%%/locale/it/examples.18/ex5/menagerie.gm
-%%DATADIR%%/locale/it/examples.18/ex5/menagerie.gss
-%%DATADIR%%/locale/it/examples.18/ex5/menagerie.map
-%%DATADIR%%/locale/it/examples.18/ex5/menagerie.mem
-%%DATADIR%%/locale/it/examples.18/ex5/menagerie.v
-%%DATADIR%%/locale/it/examples.18/ex5/x-menagerie.mem
-%%DATADIR%%/locale/it/examples.18/index.v
+%%DATADIR%%/locale/gl/messages
+%%DATADIR%%/locale/hr/messages
+%%DATADIR%%/locale/id/messages
+%%DATADIR%%/locale/is/messages
+%%DATADIR%%/locale/it/examples/ex1/combinational.v
+%%DATADIR%%/locale/it/examples/ex2/flipflop.v
+%%DATADIR%%/locale/it/examples/ex3/counter.v
+%%DATADIR%%/locale/it/examples/ex4/trff.v
+%%DATADIR%%/locale/it/examples/ex5/menagerie.gm
+%%DATADIR%%/locale/it/examples/ex5/menagerie.gss
+%%DATADIR%%/locale/it/examples/ex5/menagerie.map
+%%DATADIR%%/locale/it/examples/ex5/menagerie.mem
+%%DATADIR%%/locale/it/examples/ex5/menagerie.v
+%%DATADIR%%/locale/it/examples/ex5/menagerie.vs
+%%DATADIR%%/locale/it/examples/ex5/x-menagerie.mem
+%%DATADIR%%/locale/it/examples/ex6/coke.v
+%%DATADIR%%/locale/it/examples/ex7/stdlogic.v
+%%DATADIR%%/locale/it/examples/index.v
%%DATADIR%%/locale/it/messages
-%%DATADIR%%/locale/it/tutorials.18/create_tut.v
-%%DATADIR%%/locale/it/tutorials.18/edit1_tut.v
-%%DATADIR%%/locale/it/tutorials.18/edit2_tut.v
-%%DATADIR%%/locale/it/tutorials.18/edwire_tut.v
-%%DATADIR%%/locale/it/tutorials.18/module_tut.v
-%%DATADIR%%/locale/it/tutorials.18/seqsim_tut.v
-%%DATADIR%%/locale/it/tutorials.18/sim_tut.v
-%%DATADIR%%/locale/it/tutorials.18/welcome_tut.v
+%%DATADIR%%/locale/it/tutorials/advanced.v
+%%DATADIR%%/locale/it/tutorials/combinational1.v
+%%DATADIR%%/locale/it/tutorials/combinational2.v
+%%DATADIR%%/locale/it/tutorials/combinational3.v
+%%DATADIR%%/locale/it/tutorials/combinational4.v
+%%DATADIR%%/locale/it/tutorials/combinational5.v
+%%DATADIR%%/locale/it/tutorials/create.v
+%%DATADIR%%/locale/it/tutorials/gates.v
+%%DATADIR%%/locale/it/tutorials/group.v
+%%DATADIR%%/locale/it/tutorials/index.v
+%%DATADIR%%/locale/it/tutorials/interface.txt
+%%DATADIR%%/locale/it/tutorials/modules.v
+%%DATADIR%%/locale/it/tutorials/options.v
+%%DATADIR%%/locale/it/tutorials/sequential1.v
+%%DATADIR%%/locale/it/tutorials/sequential2.v
+%%DATADIR%%/locale/it/tutorials/sequential3.v
+%%DATADIR%%/locale/it/tutorials/sequential4.v
+%%DATADIR%%/locale/it/tutorials/sequential5.v
+%%DATADIR%%/locale/it/tutorials/verilog.v
+%%DATADIR%%/locale/it/tutorials/welcome.v
+%%DATADIR%%/locale/it/tutorials/wires.v
+%%DATADIR%%/locale/ja/examples/ex1/combinational.v
+%%DATADIR%%/locale/ja/examples/ex2/flipflop.v
+%%DATADIR%%/locale/ja/examples/ex3/counter.v
+%%DATADIR%%/locale/ja/examples/ex4/trff.v
+%%DATADIR%%/locale/ja/examples/ex5/menagerie.gm
+%%DATADIR%%/locale/ja/examples/ex5/menagerie.gss
+%%DATADIR%%/locale/ja/examples/ex5/menagerie.map
+%%DATADIR%%/locale/ja/examples/ex5/menagerie.mem
+%%DATADIR%%/locale/ja/examples/ex5/menagerie.v
+%%DATADIR%%/locale/ja/examples/ex5/menagerie.vs
+%%DATADIR%%/locale/ja/examples/ex5/x-menagerie.mem
+%%DATADIR%%/locale/ja/examples/ex6/coke.v
+%%DATADIR%%/locale/ja/examples/ex7/stdlogic.v
+%%DATADIR%%/locale/ja/examples/index.v
%%DATADIR%%/locale/ja/messages
-%%DATADIR%%/locale/ja/messages.euc
-%%DATADIR%%/locale/ja/messages.utf8
-%%DATADIR%%/locale/ja/messages.xxx
%%DATADIR%%/locale/ja/tutorials/advanced.v
%%DATADIR%%/locale/ja/tutorials/combinational1.v
%%DATADIR%%/locale/ja/tutorials/combinational2.v
@@ -1085,13 +1190,10 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/locale/ja/tutorials/combinational5.v
%%DATADIR%%/locale/ja/tutorials/create.v
%%DATADIR%%/locale/ja/tutorials/gates.v
-%%DATADIR%%/locale/ja/tutorials/glossary.v
%%DATADIR%%/locale/ja/tutorials/group.v
%%DATADIR%%/locale/ja/tutorials/index.v
%%DATADIR%%/locale/ja/tutorials/interface.txt
-%%DATADIR%%/locale/ja/tutorials/moddef_tut.v
%%DATADIR%%/locale/ja/tutorials/modules.v
-%%DATADIR%%/locale/ja/tutorials/notes.v
%%DATADIR%%/locale/ja/tutorials/options.v
%%DATADIR%%/locale/ja/tutorials/sequential1.v
%%DATADIR%%/locale/ja/tutorials/sequential2.v
@@ -1100,8 +1202,49 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/locale/ja/tutorials/sequential5.v
%%DATADIR%%/locale/ja/tutorials/verilog.v
%%DATADIR%%/locale/ja/tutorials/welcome.v
-%%DATADIR%%/locale/ja/tutorials/wire2.v
%%DATADIR%%/locale/ja/tutorials/wires.v
+%%DATADIR%%/locale/lt/messages
+%%DATADIR%%/locale/ms/messages
+%%DATADIR%%/locale/nl/messages
+%%DATADIR%%/locale/oc/messages
+%%DATADIR%%/locale/pl/examples/ex1/combinational.v
+%%DATADIR%%/locale/pl/examples/ex2/flipflop.v
+%%DATADIR%%/locale/pl/examples/ex3/counter.v
+%%DATADIR%%/locale/pl/examples/ex4/trff.v
+%%DATADIR%%/locale/pl/examples/ex5/menagerie.gm
+%%DATADIR%%/locale/pl/examples/ex5/menagerie.gss
+%%DATADIR%%/locale/pl/examples/ex5/menagerie.map
+%%DATADIR%%/locale/pl/examples/ex5/menagerie.mem
+%%DATADIR%%/locale/pl/examples/ex5/menagerie.v
+%%DATADIR%%/locale/pl/examples/ex5/menagerie.vs
+%%DATADIR%%/locale/pl/examples/ex5/x-menagerie.mem
+%%DATADIR%%/locale/pl/examples/ex6/coke.v
+%%DATADIR%%/locale/pl/examples/ex7/stdlogic.v
+%%DATADIR%%/locale/pl/examples/index.v
+%%DATADIR%%/locale/pl/messages
+%%DATADIR%%/locale/pl/tutorials/advanced.v
+%%DATADIR%%/locale/pl/tutorials/combinational1.v
+%%DATADIR%%/locale/pl/tutorials/combinational2.v
+%%DATADIR%%/locale/pl/tutorials/combinational3.v
+%%DATADIR%%/locale/pl/tutorials/combinational4.v
+%%DATADIR%%/locale/pl/tutorials/combinational5.v
+%%DATADIR%%/locale/pl/tutorials/create.v
+%%DATADIR%%/locale/pl/tutorials/gates.v
+%%DATADIR%%/locale/pl/tutorials/group.v
+%%DATADIR%%/locale/pl/tutorials/index.v
+%%DATADIR%%/locale/pl/tutorials/interface.txt
+%%DATADIR%%/locale/pl/tutorials/modules.v
+%%DATADIR%%/locale/pl/tutorials/options.v
+%%DATADIR%%/locale/pl/tutorials/sequential1.v
+%%DATADIR%%/locale/pl/tutorials/sequential2.v
+%%DATADIR%%/locale/pl/tutorials/sequential3.v
+%%DATADIR%%/locale/pl/tutorials/sequential4.v
+%%DATADIR%%/locale/pl/tutorials/sequential5.v
+%%DATADIR%%/locale/pl/tutorials/verilog.v
+%%DATADIR%%/locale/pl/tutorials/welcome.v
+%%DATADIR%%/locale/pl/tutorials/wires.v
+%%DATADIR%%/locale/pt/messages
+%%DATADIR%%/locale/pt_BR/messages
%%DATADIR%%/locale/ru/examples/ex1/combinational.v
%%DATADIR%%/locale/ru/examples/ex2/flipflop.v
%%DATADIR%%/locale/ru/examples/ex3/counter.v
@@ -1116,7 +1259,6 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/locale/ru/examples/ex6/coke.v
%%DATADIR%%/locale/ru/examples/ex7/stdlogic.v
%%DATADIR%%/locale/ru/examples/index.v
-%%DATADIR%%/locale/ru/license.txt
%%DATADIR%%/locale/ru/messages
%%DATADIR%%/locale/ru/tutorials/advanced.v
%%DATADIR%%/locale/ru/tutorials/combinational1.v
@@ -1128,6 +1270,7 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/locale/ru/tutorials/gates.v
%%DATADIR%%/locale/ru/tutorials/group.v
%%DATADIR%%/locale/ru/tutorials/index.v
+%%DATADIR%%/locale/ru/tutorials/interface.txt
%%DATADIR%%/locale/ru/tutorials/modules.v
%%DATADIR%%/locale/ru/tutorials/options.v
%%DATADIR%%/locale/ru/tutorials/sequential1.v
@@ -1138,6 +1281,46 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/locale/ru/tutorials/verilog.v
%%DATADIR%%/locale/ru/tutorials/welcome.v
%%DATADIR%%/locale/ru/tutorials/wires.v
+%%DATADIR%%/locale/sk/messages
+%%DATADIR%%/locale/sr/messages
+%%DATADIR%%/locale/sv/messages
+%%DATADIR%%/locale/tr/messages
+%%DATADIR%%/locale/uk/examples/ex1/combinational.v
+%%DATADIR%%/locale/uk/examples/ex2/flipflop.v
+%%DATADIR%%/locale/uk/examples/ex3/counter.v
+%%DATADIR%%/locale/uk/examples/ex4/trff.v
+%%DATADIR%%/locale/uk/examples/ex5/menagerie.gm
+%%DATADIR%%/locale/uk/examples/ex5/menagerie.gss
+%%DATADIR%%/locale/uk/examples/ex5/menagerie.map
+%%DATADIR%%/locale/uk/examples/ex5/menagerie.mem
+%%DATADIR%%/locale/uk/examples/ex5/menagerie.v
+%%DATADIR%%/locale/uk/examples/ex5/menagerie.vs
+%%DATADIR%%/locale/uk/examples/ex5/x-menagerie.mem
+%%DATADIR%%/locale/uk/examples/ex6/coke.v
+%%DATADIR%%/locale/uk/examples/ex7/stdlogic.v
+%%DATADIR%%/locale/uk/examples/index.v
+%%DATADIR%%/locale/uk/messages
+%%DATADIR%%/locale/uk/tutorials/advanced.v
+%%DATADIR%%/locale/uk/tutorials/combinational1.v
+%%DATADIR%%/locale/uk/tutorials/combinational2.v
+%%DATADIR%%/locale/uk/tutorials/combinational3.v
+%%DATADIR%%/locale/uk/tutorials/combinational4.v
+%%DATADIR%%/locale/uk/tutorials/combinational5.v
+%%DATADIR%%/locale/uk/tutorials/create.v
+%%DATADIR%%/locale/uk/tutorials/gates.v
+%%DATADIR%%/locale/uk/tutorials/group.v
+%%DATADIR%%/locale/uk/tutorials/index.v
+%%DATADIR%%/locale/uk/tutorials/interface.txt
+%%DATADIR%%/locale/uk/tutorials/modules.v
+%%DATADIR%%/locale/uk/tutorials/options.v
+%%DATADIR%%/locale/uk/tutorials/sequential1.v
+%%DATADIR%%/locale/uk/tutorials/sequential2.v
+%%DATADIR%%/locale/uk/tutorials/sequential3.v
+%%DATADIR%%/locale/uk/tutorials/sequential4.v
+%%DATADIR%%/locale/uk/tutorials/sequential5.v
+%%DATADIR%%/locale/uk/tutorials/verilog.v
+%%DATADIR%%/locale/uk/tutorials/welcome.v
+%%DATADIR%%/locale/uk/tutorials/wires.v
%%DATADIR%%/primitives/README
%%DATADIR%%/primitives/adder.v
%%DATADIR%%/primitives/and.v
@@ -1220,6 +1403,7 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/scripts/tkgate.tcl
%%DATADIR%%/scripts/toolbar.tcl
%%DATADIR%%/scripts/tree.tcl
+%%DATADIR%%/scripts/tree.tcl.bak
%%DATADIR%%/scripts/undo.tcl
%%DATADIR%%/scripts/vpd.tcl
%%DATADIR%%/scripts/wizard.tcl
@@ -1303,6 +1487,10 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/test/verga/fibonacci.v
%%DATADIR%%/test/verga/fork1.out
%%DATADIR%%/test/verga/fork1.v
+%%DATADIR%%/test/verga/gatelevel.out
+%%DATADIR%%/test/verga/gatelevel.v
+%%DATADIR%%/test/verga/gatelevel1.out
+%%DATADIR%%/test/verga/gatelevel1.v
%%DATADIR%%/test/verga/grammar.out
%%DATADIR%%/test/verga/grammar.v
%%DATADIR%%/test/verga/loops.out
@@ -1385,13 +1573,17 @@ share/pixmaps/tkgate.xpm
%%DATADIR%%/test/verga/trireg1.v
%%DATADIR%%/test/verga/tristate1.out
%%DATADIR%%/test/verga/tristate1.v
+%%DATADIR%%/test/verga/tristate2.out
+%%DATADIR%%/test/verga/tristate2.v
%%DATADIR%%/test/verga/uops.out
%%DATADIR%%/test/verga/uops.v
%%DATADIR%%/test/verga/verga.out
%%DATADIR%%/test/verga/wire1.out
%%DATADIR%%/test/verga/wire1.v
%%DATADIR%%/vlib/74xx.v
+%%DATADIR%%/vlib/74xxGateLevel.v
%%DATADIR%%/vlib/coke.v
+%%DATADIR%%/vlib/m68xx.v
%%DATADIR%%/vlib/timer.v
%%DATADIR%%/vlib/timer.xv
%%DATADIR%%/vlib/tty.v