aboutsummaryrefslogtreecommitdiff
path: root/cad/xcircuit/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-02 19:00:08 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-02 19:00:08 +0000
commit3d8ddfe32c2d6955fe9650d6a3bc0f8932602d9b (patch)
treeb18a1e1e3ef2b489039744f49feb8726638effa7 /cad/xcircuit/Makefile
parentb3db4fe928c05a10fc4fc446ea6dfc42d73f73ef (diff)
downloadports-3d8ddfe32c2d6955fe9650d6a3bc0f8932602d9b.tar.gz
ports-3d8ddfe32c2d6955fe9650d6a3bc0f8932602d9b.zip
Notes
Diffstat (limited to 'cad/xcircuit/Makefile')
-rw-r--r--cad/xcircuit/Makefile29
1 files changed, 6 insertions, 23 deletions
diff --git a/cad/xcircuit/Makefile b/cad/xcircuit/Makefile
index b8244b6515c1..11fd8086dab7 100644
--- a/cad/xcircuit/Makefile
+++ b/cad/xcircuit/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xcircuit
-PORTVERSION= 3.1.18
-PORTREVISION= 2
+PORTVERSION= 3.1.38
PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= http://xcircuit.ece.jhu.edu/archive/
@@ -18,6 +17,7 @@ COMMENT= An X11 drawing program [especially for circuit schematics]
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_XPM= yes
+USE_GHOSTSCRIPT_RUN= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -26,8 +26,6 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
-USE_GHOSTSCRIPT_RUN= yes
-
WISH= ${LOCALBASE}/bin/wish8.4
.if defined(WITH_TCLTK)
@@ -37,21 +35,12 @@ CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.4 \
--with-tk=${LOCALBASE}/lib/tk8.4
ALL_TARGET= tcl
INSTALL_TARGET= install-tcl
-PLIST_SUB+= PYTHON="@comment " NOPYTHON="" TCLTK="" NOTCLTK="@comment "
+PLIST_SUB+= TCLTK="" NOTCLTK="@comment "
CFLAGS+= -I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include/tk8.4 \
-I${X11BASE}/include
.else
MAN1+= xcircuit.1
-.if defined(WITH_PYTHON)
-PKGNAMESUFFIX= -python
-USE_PYTHON= yes
-CONFIGURE_ARGS+= --with-python
-CPPFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
-PLIST_SUB+= PYTHON="" NOPYTHON="@comment " TCLTK="@comment " NOTCLTK=""
-.else
-PLIST_SUB+= PYTHON="@comment " NOPYTHON="" TCLTK="@comment " NOTCLTK=""
-.endif
+PLIST_SUB+= TCLTK="@comment " NOTCLTK=""
.endif
pre-everything::
@@ -67,12 +56,6 @@ pre-everything::
@${ECHO_MSG} " (prevents python support)"
@${ECHO_MSG} ""
.endif
-.if !defined(WITH_PYTHON)
- @${ECHO_MSG} ""
- @${ECHO_MSG} " Or define WITH_PYTHON for Python support"
- @${ECHO_MSG} " (only available without WITH_TCLTK defined)"
- @${ECHO_MSG} ""
-.endif
post-patch:
@${REINPLACE_CMD} -e 's|TCL_LIB_NAME=.*$$|TCL_LIB_NAME="tcl84"|g ; \
@@ -84,8 +67,8 @@ post-patch:
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}
- ${TAR} -C ${WRKSRC}/examples --exclude CVS -cf - . | \
- ${TAR} -C ${EXAMPLESDIR} --unlink -xf -
+ ${TAR} -C ${WRKSRC}/examples --exclude "CVS" --exclude "*.py" \
+ -cf - . | ${TAR} -C ${EXAMPLESDIR} --unlink -xf -
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.endif