aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-01-15 00:24:11 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-01-15 00:24:11 +0000
commit16f08410fac103d5ff8af38468f46859a4b81de4 (patch)
tree4a3e71723173760bcec65510c067b37e5e53f5ad /cad
parentd0029e3e01f288d5f52304bfb9e0271b9c2625c6 (diff)
downloadports-16f08410fac103d5ff8af38468f46859a4b81de4.tar.gz
ports-16f08410fac103d5ff8af38468f46859a4b81de4.zip
- Update to 2.3.0 [1]
- Some port cleanup [2] - Whitespace fixes - Remove duplicate and unused depends - Add missing depends - Use WX_CONFIG properly - Support FHS - Switch to PORTDATA - Install .desktop files into proper location - Fix compatibility with 11.x PR: 252611 Submitted by: teodorsigaev@gmail.com (maintainer) [1], amdmi3 [2]
Notes
Notes: svn path=/head/; revision=561616
Diffstat (limited to 'cad')
-rw-r--r--cad/PrusaSlicer/Makefile48
-rw-r--r--cad/PrusaSlicer/distinfo8
-rw-r--r--cad/PrusaSlicer/files/patch-CMakeLists.txt25
-rw-r--r--cad/PrusaSlicer/files/patch-src_libslic3r_Thread.cpp46
-rw-r--r--cad/PrusaSlicer/files/patch-src_slic3r_CMakeLists.txt11
-rw-r--r--cad/PrusaSlicer/files/patch-src_slic3r_GUI_InstanceCheck.cpp20
-rw-r--r--cad/PrusaSlicer/pkg-plist313
7 files changed, 119 insertions, 352 deletions
diff --git a/cad/PrusaSlicer/Makefile b/cad/PrusaSlicer/Makefile
index 50a441d52eee..2a986cae0c48 100644
--- a/cad/PrusaSlicer/Makefile
+++ b/cad/PrusaSlicer/Makefile
@@ -1,10 +1,9 @@
# $FreeBSD$
-PORTNAME= PrusaSlicer
-DISTVERSIONPREFIX= version_
-DISTVERSION= 2.2.0
-PORTREVISION= 9
-CATEGORIES= cad
+PORTNAME= PrusaSlicer
+DISTVERSIONPREFIX=version_
+DISTVERSION= 2.3.0
+CATEGORIES= cad
MAINTAINER= teodorsigaev@gmail.com
COMMENT= Slicing application for 3D printers
@@ -20,42 +19,21 @@ LIB_DEPENDS= libtbb.so:devel/tbb \
libexpat.so:textproc/expat2 \
libopenvdb.so:misc/openvdb \
libgmp.so:math/gmp \
- libmpfr.so:math/mpfr
+ libmpfr.so:math/mpfr \
+ libdbus-1.so:devel/dbus \
+ libpng.so:graphics/png
BUILD_DEPENDS= cereal>=1.2.2:devel/cereal \
- googletest>=1.7:devel/googletest \
- boost-libs>=1.64:devel/boost-libs \
- wx31-gtk3>=3.1:x11-toolkits/wxgtk31 \
- cmake>=3.2:devel/cmake \
- ninja>=1.8.2:devel/ninja \
- openvdb>=6.1.0:misc/openvdb \
- gmp>=6.1.2:math/gmp \
- mpfr>=4.0.2:math/mpfr \
- qt5-buildtools>=0:devel/qt5-buildtools
-
-USES= cmake eigen:3 gettext gl iconv pkgconfig
-
-CMAKE_ARGS+= -DwxWidgets_CONFIG_EXECUTABLE=${LOCALBASE}/bin/wxgtk3u-3.1-config \
- -DCGAL_DIR=${WRKSRC}/CGAL/lib/cmake/CGAL
-CMAKE_INSTALL_PREFIX= ${PREFIX}/${PORTNAME}
+ cgal>=5.0.2:math/cgal
+USES= cmake desktop-file-utils eigen:3 gettext gl iconv pkgconfig
+CMAKE_ARGS= -DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}" \
+ -DSLIC3R_GTK=3 \
+ -DSLIC3R_FHS=1
USE_GITHUB= yes
GH_ACCOUNT= prusa3d
-GH_TUPLE= CGAL:cgal:releases/CGAL-5.0.2:cgal
USE_WX= 3.1
USE_GL= gl glu glew
-post-patch:
- ${REINPLACE_CMD} -e 's,%%WRKSRC%%,${WRKSRC},' \
- ${WRKSRC}/CMakeLists.txt
-
-pre-configure:
- cd ${WRKSRC_cgal} && \
- ${CMAKE_BIN} -E remove CGALConfig-installation-dirs.cmake && \
- ${MKDIR} build && cd build && \
- ${CMAKE_BIN} -DCMAKE_INSTALL_PREFIX=${WRKSRC}/CGAL \
- -DCMAKE_PREFIX_PATH=${WRKSRC}/CGAL \
- -DCMAKE_MODULE_PATH=${WRKSRC}/cmake/modules \
- -DCMAKE_BUILD_TYPE=Release .. && \
- ${BSDMAKE} all install
+PORTDATA= *
.include <bsd.port.mk>
diff --git a/cad/PrusaSlicer/distinfo b/cad/PrusaSlicer/distinfo
index 94b2a08bee32..1d66ee41deaa 100644
--- a/cad/PrusaSlicer/distinfo
+++ b/cad/PrusaSlicer/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1585766317
-SHA256 (prusa3d-PrusaSlicer-version_2.2.0_GH0.tar.gz) = e6e0c83bf92e448ec058fd3063b84caca69f58b8b419e48eace6e8ce534937c0
-SIZE (prusa3d-PrusaSlicer-version_2.2.0_GH0.tar.gz) = 30811929
-SHA256 (CGAL-cgal-releases-CGAL-5.0.2_GH0.tar.gz) = 7d824efce318fe901fd9d6f233a1f27e2d956d787602621df035a759b587c40c
-SIZE (CGAL-cgal-releases-CGAL-5.0.2_GH0.tar.gz) = 146441795
+TIMESTAMP = 1610441839
+SHA256 (prusa3d-PrusaSlicer-version_2.3.0_GH0.tar.gz) = cd3bac5e29b5441fc4690f28cd7b1064e97dc00207bbdc88f7bd7832308d6ca5
+SIZE (prusa3d-PrusaSlicer-version_2.3.0_GH0.tar.gz) = 34785471
diff --git a/cad/PrusaSlicer/files/patch-CMakeLists.txt b/cad/PrusaSlicer/files/patch-CMakeLists.txt
index 1055ad8dca26..375a24916abe 100644
--- a/cad/PrusaSlicer/files/patch-CMakeLists.txt
+++ b/cad/PrusaSlicer/files/patch-CMakeLists.txt
@@ -1,11 +1,30 @@
---- CMakeLists.txt.orig 2020-03-21 10:55:51 UTC
+--- CMakeLists.txt.orig 2021-01-11 13:01:51 UTC
+++ CMakeLists.txt
-@@ -3,6 +3,8 @@ project(PrusaSlicer)
+@@ -3,6 +3,7 @@ project(PrusaSlicer)
include("version.inc")
include(GNUInstallDirs)
-+include_directories(BEFORE SYSTEM "%%WRKSRC%%/CGAL/include")
+add_compile_options(-DNDEBUG)
set(SLIC3R_RESOURCES_DIR "${CMAKE_CURRENT_SOURCE_DIR}/resources")
file(TO_NATIVE_PATH "${SLIC3R_RESOURCES_DIR}" SLIC3R_RESOURCES_DIR_WIN)
+@@ -154,7 +155,7 @@ if (APPLE)
+ endif ()
+ endif ()
+
+-if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
++if (CMAKE_SYSTEM_NAME STREQUAL "Linux" OR CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
+ find_package(PkgConfig REQUIRED)
+
+ if (CMAKE_VERSION VERSION_LESS "3.1")
+@@ -513,8 +514,8 @@ elseif (SLIC3R_FHS)
+ # CMAKE_INSTALL_FULL_DATAROOTDIR: read-only architecture-independent data root (share)
+ set(SLIC3R_FHS_RESOURCES "${CMAKE_INSTALL_FULL_DATAROOTDIR}/PrusaSlicer")
+ install(DIRECTORY "${SLIC3R_RESOURCES_DIR}/" DESTINATION "${SLIC3R_FHS_RESOURCES}")
+- install(FILES src/platform/unix/PrusaSlicer.desktop DESTINATION ${SLIC3R_FHS_RESOURCES}/applications)
+- install(FILES src/platform/unix/PrusaGcodeviewer.desktop DESTINATION ${SLIC3R_FHS_RESOURCES}/applications)
++ install(FILES src/platform/unix/PrusaSlicer.desktop DESTINATION share/applications)
++ install(FILES src/platform/unix/PrusaGcodeviewer.desktop DESTINATION share/applications)
+ else ()
+ install(FILES src/platform/unix/PrusaSlicer.desktop DESTINATION ${CMAKE_INSTALL_PREFIX}/resources/applications)
+ install(FILES src/platform/unix/PrusaGcodeviewer.desktop DESTINATION ${CMAKE_INSTALL_PREFIX}/resources/applications)
diff --git a/cad/PrusaSlicer/files/patch-src_libslic3r_Thread.cpp b/cad/PrusaSlicer/files/patch-src_libslic3r_Thread.cpp
new file mode 100644
index 000000000000..d48272fed2fe
--- /dev/null
+++ b/cad/PrusaSlicer/files/patch-src_libslic3r_Thread.cpp
@@ -0,0 +1,46 @@
+Note that this patch may be removed after FreeBSD 11.x EoL
+as latest FreeBSD versions have proper
+pthread_setname_np/pthread_getname_np support.
+
+--- src/libslic3r/Thread.cpp.orig 2021-01-11 13:01:51 UTC
++++ src/libslic3r/Thread.cpp
+@@ -4,6 +4,7 @@
+ #else
+ // any posix system
+ #include <pthread.h>
++ #include <pthread_np.h>
+ #endif
+
+ #include <atomic>
+@@ -161,26 +162,27 @@ std::optional<std::string> get_current_thread_name()
+ // posix
+ bool set_thread_name(std::thread &thread, const char *thread_name)
+ {
+- pthread_setname_np(thread.native_handle(), thread_name);
++ pthread_set_name_np(thread.native_handle(), thread_name);
+ return true;
+ }
+
+ bool set_thread_name(boost::thread &thread, const char *thread_name)
+ {
+- pthread_setname_np(thread.native_handle(), thread_name);
++ pthread_set_name_np(thread.native_handle(), thread_name);
+ return true;
+ }
+
+ bool set_current_thread_name(const char *thread_name)
+ {
+- pthread_setname_np(pthread_self(), thread_name);
++ pthread_set_name_np(pthread_self(), thread_name);
+ return true;
+ }
+
+ std::optional<std::string> get_current_thread_name()
+ {
+ char buf[16];
+- return std::string(pthread_getname_np(pthread_self(), buf, 16) == 0 ? buf : "");
++ pthread_get_name_np(pthread_self(), buf, 16);
++ return std::string(buf);
+ }
+
+ #endif
diff --git a/cad/PrusaSlicer/files/patch-src_slic3r_CMakeLists.txt b/cad/PrusaSlicer/files/patch-src_slic3r_CMakeLists.txt
new file mode 100644
index 000000000000..b26800f0bccf
--- /dev/null
+++ b/cad/PrusaSlicer/files/patch-src_slic3r_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/slic3r/CMakeLists.txt.orig 2021-01-12 12:07:42 UTC
++++ src/slic3r/CMakeLists.txt
+@@ -234,7 +234,7 @@ encoding_check(libslic3r_gui)
+
+ target_link_libraries(libslic3r_gui libslic3r avrdude cereal imgui GLEW::GLEW OpenGL::GL OpenGL::GLU hidapi libcurl ${wxWidgets_LIBRARIES})
+
+-if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
++if (CMAKE_SYSTEM_NAME STREQUAL "Linux" OR CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
+ target_link_libraries(libslic3r_gui ${DBUS_LIBRARIES})
+ endif()
+
diff --git a/cad/PrusaSlicer/files/patch-src_slic3r_GUI_InstanceCheck.cpp b/cad/PrusaSlicer/files/patch-src_slic3r_GUI_InstanceCheck.cpp
new file mode 100644
index 000000000000..c5505225059a
--- /dev/null
+++ b/cad/PrusaSlicer/files/patch-src_slic3r_GUI_InstanceCheck.cpp
@@ -0,0 +1,20 @@
+--- src/slic3r/GUI/InstanceCheck.cpp.orig 2021-01-11 13:01:51 UTC
++++ src/slic3r/GUI/InstanceCheck.cpp
+@@ -23,7 +23,7 @@
+ #include <strsafe.h>
+ #endif //WIN32
+
+-#if __linux__
++#if defined(__linux__) || defined (__FreeBSD__)
+ #include <dbus/dbus.h> /* Pull in all of D-Bus headers. */
+ #endif //__linux__
+
+@@ -169,7 +169,7 @@ namespace instance_check_internal
+ return false;
+ }
+
+-#elif defined(__linux__)
++#elif defined(__linux__) || defined (__FreeBSD__)
+
+ static bool send_message(const std::string &message_text, const std::string &version)
+ {
diff --git a/cad/PrusaSlicer/pkg-plist b/cad/PrusaSlicer/pkg-plist
index 7b480e8a43c6..a4bdeba7ca6f 100644
--- a/cad/PrusaSlicer/pkg-plist
+++ b/cad/PrusaSlicer/pkg-plist
@@ -1,309 +1,4 @@
-PrusaSlicer/resources/fonts/NotoSans-Regular.ttf
-PrusaSlicer/resources/fonts/NotoSansCJK-Regular.ttc
-PrusaSlicer/resources/fonts/README.txt
-PrusaSlicer/resources/icons/PrusaSlicer.icns
-PrusaSlicer/resources/icons/PrusaSlicer.ico
-PrusaSlicer/resources/icons/PrusaSlicer.png
-PrusaSlicer/resources/icons/PrusaSlicer_128px.png
-PrusaSlicer/resources/icons/PrusaSlicer_192px.png
-PrusaSlicer/resources/icons/PrusaSlicer_192px_grayscale.png
-PrusaSlicer/resources/icons/PrusaSlicer_192px_transparent.png
-PrusaSlicer/resources/icons/PrusaSlicer_32px.png
-PrusaSlicer/resources/icons/add.svg
-PrusaSlicer/resources/icons/add_copies.svg
-PrusaSlicer/resources/icons/add_gcode.svg
-PrusaSlicer/resources/icons/add_modifier.svg
-PrusaSlicer/resources/icons/add_part.svg
-PrusaSlicer/resources/icons/advanced_plus.svg
-PrusaSlicer/resources/icons/arrange.svg
-PrusaSlicer/resources/icons/browse.svg
-PrusaSlicer/resources/icons/bullet_black.png
-PrusaSlicer/resources/icons/cog.svg
-PrusaSlicer/resources/icons/bullet_blue.png
-PrusaSlicer/resources/icons/bullet_white.png
-PrusaSlicer/resources/icons/change_extruder.svg
-PrusaSlicer/resources/icons/cog_go.png
-PrusaSlicer/resources/icons/colorchange_add.svg
-PrusaSlicer/resources/icons/colorchange_add_f.svg
-PrusaSlicer/resources/icons/colorchange_add_m.svg
-PrusaSlicer/resources/icons/colorchange_add_off.png
-PrusaSlicer/resources/icons/colorchange_add_on.png
-PrusaSlicer/resources/icons/colorchange_del.svg
-PrusaSlicer/resources/icons/colorchange_del_f.svg
-PrusaSlicer/resources/icons/colorchange_delete_off.png
-PrusaSlicer/resources/icons/colorchange_delete_on.png
-PrusaSlicer/resources/icons/cooling.svg
-PrusaSlicer/resources/icons/copy.svg
-PrusaSlicer/resources/icons/copy_menu.svg
-PrusaSlicer/resources/icons/cross.svg
-PrusaSlicer/resources/icons/cross_focus.svg
-PrusaSlicer/resources/icons/cut.svg
-PrusaSlicer/resources/icons/delete.svg
-PrusaSlicer/resources/icons/delete_all.svg
-PrusaSlicer/resources/icons/delete_all_menu.svg
-PrusaSlicer/resources/icons/dot.svg
-PrusaSlicer/resources/icons/dot_white.svg
-PrusaSlicer/resources/icons/down_half_circle.png
-PrusaSlicer/resources/icons/drop_to_bed.svg
-PrusaSlicer/resources/icons/edit_gcode.svg
-PrusaSlicer/resources/icons/edit_gcode_f.svg
-PrusaSlicer/resources/icons/edit_layers_all.svg
-PrusaSlicer/resources/icons/edit_layers_some.svg
-PrusaSlicer/resources/icons/edit_uni.svg
-PrusaSlicer/resources/icons/editor.svg
-PrusaSlicer/resources/icons/editor_menu.svg
-PrusaSlicer/resources/icons/eject_sd.svg
-PrusaSlicer/resources/icons/error_tick.svg
-PrusaSlicer/resources/icons/error_tick_f.svg
-PrusaSlicer/resources/icons/exclamation.svg
-PrusaSlicer/resources/icons/export_config.svg
-PrusaSlicer/resources/icons/export_config_bundle.svg
-PrusaSlicer/resources/icons/export_gcode.svg
-PrusaSlicer/resources/icons/export_plater.svg
-PrusaSlicer/resources/icons/export_to_sd.svg
-PrusaSlicer/resources/icons/eye_closed.svg
-PrusaSlicer/resources/icons/eye_open.svg
-PrusaSlicer/resources/icons/flag_green.svg
-PrusaSlicer/resources/icons/flag_red.svg
-PrusaSlicer/resources/icons/funnel.svg
-PrusaSlicer/resources/icons/gcode.icns
-PrusaSlicer/resources/icons/hollow.svg
-PrusaSlicer/resources/icons/hollowing.svg
-PrusaSlicer/resources/icons/import_config.svg
-PrusaSlicer/resources/icons/import_config_bundle.svg
-PrusaSlicer/resources/icons/import_plater.svg
-PrusaSlicer/resources/icons/infill.svg
-PrusaSlicer/resources/icons/instance_add.svg
-PrusaSlicer/resources/icons/instance_remove.svg
-PrusaSlicer/resources/icons/layers.svg
-PrusaSlicer/resources/icons/layers_white.svg
-PrusaSlicer/resources/icons/left_half_circle.png
-PrusaSlicer/resources/icons/lock_closed.svg
-PrusaSlicer/resources/icons/lock_closed_f.svg
-PrusaSlicer/resources/icons/lock_closed_white.svg
-PrusaSlicer/resources/icons/lock_open.svg
-PrusaSlicer/resources/icons/lock_open_f.svg
-PrusaSlicer/resources/icons/lock_open_sys.svg
-PrusaSlicer/resources/icons/mark_X.svg
-PrusaSlicer/resources/icons/mark_Y.svg
-PrusaSlicer/resources/icons/mark_Z.svg
-PrusaSlicer/resources/icons/mirroring_off.svg
-PrusaSlicer/resources/icons/mirroring_on.svg
-PrusaSlicer/resources/icons/mirroring_transparent.png
-PrusaSlicer/resources/icons/mode_advanced.svg
-PrusaSlicer/resources/icons/mode_advanced_.png
-PrusaSlicer/resources/icons/mode_advanced_sq.png
-PrusaSlicer/resources/icons/mode_expert.svg
-PrusaSlicer/resources/icons/mode_expert_.png
-PrusaSlicer/resources/icons/mode_expert_sq.png
-PrusaSlicer/resources/icons/mode_simple.svg
-PrusaSlicer/resources/icons/mode_simple_.png
-PrusaSlicer/resources/icons/mode_simple_sq.png
-PrusaSlicer/resources/icons/move.svg
-PrusaSlicer/resources/icons/note.svg
-PrusaSlicer/resources/icons/number_of_copies.svg
-PrusaSlicer/resources/icons/one_layer_lock_off.png
-PrusaSlicer/resources/icons/one_layer_lock_on.png
-PrusaSlicer/resources/icons/one_layer_unlock_off.png
-PrusaSlicer/resources/icons/one_layer_unlock_on.png
-PrusaSlicer/resources/icons/open.svg
-PrusaSlicer/resources/icons/output+page_white.svg
-PrusaSlicer/resources/icons/pad.svg
-PrusaSlicer/resources/icons/paste.svg
-PrusaSlicer/resources/icons/paste_menu.svg
-PrusaSlicer/resources/icons/pause_add.png
-PrusaSlicer/resources/icons/pause_print.svg
-PrusaSlicer/resources/icons/pause_print_f.svg
-PrusaSlicer/resources/icons/place.svg
-PrusaSlicer/resources/icons/plater.svg
-PrusaSlicer/resources/icons/preview.svg
-PrusaSlicer/resources/icons/preview_menu.svg
-PrusaSlicer/resources/icons/printer.svg
-PrusaSlicer/resources/icons/printer_placeholder.png
-PrusaSlicer/resources/icons/printer_white.svg
-PrusaSlicer/resources/icons/question.svg
-PrusaSlicer/resources/icons/re_slice.svg
-PrusaSlicer/resources/icons/redo.svg
-PrusaSlicer/resources/icons/redo_menu.svg
-PrusaSlicer/resources/icons/redo_toolbar.svg
-PrusaSlicer/resources/icons/remove.svg
-PrusaSlicer/resources/icons/remove_copies.svg
-PrusaSlicer/resources/icons/remove_menu.svg
-PrusaSlicer/resources/icons/resin.svg
-PrusaSlicer/resources/icons/revert_all_.svg
-PrusaSlicer/resources/icons/right_half_circle.png
-PrusaSlicer/resources/icons/rotate.svg
-PrusaSlicer/resources/icons/row.png
-PrusaSlicer/resources/icons/save.svg
-PrusaSlicer/resources/icons/scale.svg
-PrusaSlicer/resources/icons/set_separate_obj.svg
-PrusaSlicer/resources/icons/shape_ungroup.png
-PrusaSlicer/resources/icons/skirt+brim.svg
-PrusaSlicer/resources/icons/sla_printer.svg
-PrusaSlicer/resources/icons/sla_supports.svg
-PrusaSlicer/resources/icons/split_object_SMALL.svg
-PrusaSlicer/resources/icons/split_objects.svg
-PrusaSlicer/resources/icons/split_parts.svg
-PrusaSlicer/resources/icons/split_parts_SMALL.svg
-PrusaSlicer/resources/icons/spool.svg
-PrusaSlicer/resources/icons/stl.icns
-PrusaSlicer/resources/icons/support.svg
-PrusaSlicer/resources/icons/support_blocker.svg
-PrusaSlicer/resources/icons/support_enforcer.svg
-PrusaSlicer/resources/icons/table.png
-PrusaSlicer/resources/icons/test.svg
-PrusaSlicer/resources/icons/thumb_down.svg
-PrusaSlicer/resources/icons/thumb_up.svg
-PrusaSlicer/resources/icons/time.svg
-PrusaSlicer/resources/icons/toolbar_background.png
-PrusaSlicer/resources/icons/undo.svg
-PrusaSlicer/resources/icons/undo_menu.svg
-PrusaSlicer/resources/icons/white/add_copies.svg
-PrusaSlicer/resources/icons/white/add_modifier.svg
-PrusaSlicer/resources/icons/white/add_part.svg
-PrusaSlicer/resources/icons/white/advanced+wrench.svg
-PrusaSlicer/resources/icons/white/advanced_plus.svg
-PrusaSlicer/resources/icons/white/cog.svg
-PrusaSlicer/resources/icons/white/cooling.svg
-PrusaSlicer/resources/icons/white/copy_menu.svg
-PrusaSlicer/resources/icons/white/delete.svg
-PrusaSlicer/resources/icons/white/delete_all_menu.svg
-PrusaSlicer/resources/icons/white/edit_layers_all.svg
-PrusaSlicer/resources/icons/white/edit_layers_some.svg
-PrusaSlicer/resources/icons/white/editor_menu.svg
-PrusaSlicer/resources/icons/white/export_config.svg
-PrusaSlicer/resources/icons/white/export_config_bundle.svg
-PrusaSlicer/resources/icons/white/export_gcode.svg
-PrusaSlicer/resources/icons/white/export_plate.svg
-PrusaSlicer/resources/icons/white/export_plater.svg
-PrusaSlicer/resources/icons/white/pad.svg
-PrusaSlicer/resources/icons/white/export_to_sd.svg
-PrusaSlicer/resources/icons/white/extruder+funnel.svg
-PrusaSlicer/resources/icons/white/flag_green.svg
-PrusaSlicer/resources/icons/white/flag_red.svg
-PrusaSlicer/resources/icons/white/funnel.svg
-PrusaSlicer/resources/icons/white/hollowing.svg
-PrusaSlicer/resources/icons/white/import_config.svg
-PrusaSlicer/resources/icons/white/import_config_bundle.svg
-PrusaSlicer/resources/icons/white/import_plate.svg
-PrusaSlicer/resources/icons/white/import_plater.svg
-PrusaSlicer/resources/icons/white/infill.svg
-PrusaSlicer/resources/icons/white/layers.svg
-PrusaSlicer/resources/icons/white/lock2_closed.svg
-PrusaSlicer/resources/icons/white/lock_closed.svg
-PrusaSlicer/resources/icons/white/lock_open_sys.svg
-PrusaSlicer/resources/icons/white/machine+cog.svg
-PrusaSlicer/resources/icons/white/mirroring_off.svg
-PrusaSlicer/resources/icons/white/mirroring_on.svg
-PrusaSlicer/resources/icons/white/note.svg
-PrusaSlicer/resources/icons/white/notes.svg
-PrusaSlicer/resources/icons/white/number_of_copies.svg
-PrusaSlicer/resources/icons/white/open.svg
-PrusaSlicer/resources/icons/white/output+page_white.svg
-PrusaSlicer/resources/icons/white/paste_menu.svg
-PrusaSlicer/resources/icons/white/plater.svg
-PrusaSlicer/resources/icons/white/preview_menu.svg
-PrusaSlicer/resources/icons/white/printer.svg
-PrusaSlicer/resources/icons/white/re_slice.svg
-PrusaSlicer/resources/icons/white/redo_menu.svg
-PrusaSlicer/resources/icons/white/remove_copies.svg
-PrusaSlicer/resources/icons/white/remove_menu.svg
-PrusaSlicer/resources/icons/white/resin.svg
-PrusaSlicer/resources/icons/white/save.svg
-PrusaSlicer/resources/icons/white/set_separate_obj.svg
-PrusaSlicer/resources/icons/white/skirt+brim.svg
-PrusaSlicer/resources/icons/white/sla_printer.svg
-PrusaSlicer/resources/icons/white/split_object_SMALL.svg
-PrusaSlicer/resources/icons/white/split_parts_SMALL.svg
-PrusaSlicer/resources/icons/white/spool.svg
-PrusaSlicer/resources/icons/white/support.svg
-PrusaSlicer/resources/icons/white/support_blocker.svg
-PrusaSlicer/resources/icons/white/support_enforcer.svg
-PrusaSlicer/resources/icons/white/test.svg
-PrusaSlicer/resources/icons/white/time.svg
-PrusaSlicer/resources/icons/white/undo_menu.svg
-PrusaSlicer/resources/icons/white/upload_queue.svg
-PrusaSlicer/resources/icons/white/wrench.svg
-PrusaSlicer/resources/icons/undo_toolbar.svg
-PrusaSlicer/resources/icons/up_half_circle.png
-PrusaSlicer/resources/icons/upload_queue.svg
-PrusaSlicer/resources/icons/variable_layer_height_reset.png
-PrusaSlicer/resources/icons/variable_layer_height_tooltip.png
-PrusaSlicer/resources/icons/wrench.svg
-PrusaSlicer/resources/icons/wrench_white.svg
-PrusaSlicer/resources/localization/PrusaSlicer.pot
-PrusaSlicer/resources/localization/cs/PrusaSlicer.mo
-PrusaSlicer/resources/localization/cs/PrusaSlicer_cs.po
-PrusaSlicer/resources/localization/de/PrusaSlicer.mo
-PrusaSlicer/resources/localization/de/PrusaSlicer_de.po
-PrusaSlicer/resources/localization/en/PrusaSlicer.mo
-PrusaSlicer/resources/localization/en/PrusaSlicer_en.po
-PrusaSlicer/resources/localization/es/PrusaSlicer.mo
-PrusaSlicer/resources/localization/es/PrusaSlicer_es.po
-PrusaSlicer/resources/localization/fr/PrusaSlicer.mo
-PrusaSlicer/resources/localization/fr/PrusaSlicer_fr.po
-PrusaSlicer/resources/localization/it/PrusaSlicer.mo
-PrusaSlicer/resources/localization/it/PrusaSlicer_it.po
-PrusaSlicer/resources/localization/ja/PrusaSlicer.mo
-PrusaSlicer/resources/localization/ja/PrusaSlicer_ja.po
-PrusaSlicer/resources/localization/ko/PrusaSlicer.mo
-PrusaSlicer/resources/localization/ko/PrusaSlicer_ko_KR.po
-PrusaSlicer/resources/localization/list.txt
-PrusaSlicer/resources/localization/nl/PrusaSlicer.mo
-PrusaSlicer/resources/localization/nl/PrusaSlicer_nl.po
-PrusaSlicer/resources/localization/pl/PrusaSlicer.mo
-PrusaSlicer/resources/localization/pl/PrusaSlicer_pl.po
-PrusaSlicer/resources/localization/pt_br/PrusaSlicer.mo
-PrusaSlicer/resources/localization/pt_br/PrusaSlicer_pt_br.po
-PrusaSlicer/resources/localization/tr/PrusaSlicer.mo
-PrusaSlicer/resources/localization/tr/PrusaSlicer_tr.po
-PrusaSlicer/resources/localization/uk/PrusaSlicer.mo
-PrusaSlicer/resources/localization/uk/PrusaSlicer_uk.po
-PrusaSlicer/resources/localization/zh_cn/PrusaSlicer.mo
-PrusaSlicer/resources/localization/zh_cn/PrusaSlicer_zh_CN.po
-PrusaSlicer/resources/localization/zh_tw/PrusaSlicer.mo
-PrusaSlicer/resources/localization/zh_tw/PrusaSlicer_zh_TW.po
-PrusaSlicer/resources/profiles/BIBO.idx
-PrusaSlicer/resources/profiles/BIBO.ini
-PrusaSlicer/resources/profiles/BIBO/BIBO2.svg
-PrusaSlicer/resources/profiles/BIBO/BIBO2_bed.stl
-PrusaSlicer/resources/profiles/BIBO/BIBO2_thumbnail.png
-PrusaSlicer/resources/profiles/Creality.idx
-PrusaSlicer/resources/profiles/Creality.ini
-PrusaSlicer/resources/profiles/Creality/ENDER3_thumbnail.png
-PrusaSlicer/resources/profiles/Creality/ender3.svg
-PrusaSlicer/resources/profiles/Creality/ender3_bed.stl
-PrusaSlicer/resources/profiles/LulzBot.idx
-PrusaSlicer/resources/profiles/LulzBot.ini
-PrusaSlicer/resources/profiles/LulzBot/MINI_AERO_thumbnail.png
-PrusaSlicer/resources/profiles/LulzBot/TAZ6_AERO_thumbnail.png
-PrusaSlicer/resources/profiles/PrusaResearch.idx
-PrusaSlicer/resources/profiles/PrusaResearch.ini
-PrusaSlicer/resources/profiles/PrusaResearch/MINI_thumbnail.png
-PrusaSlicer/resources/profiles/PrusaResearch/MK2.5MMU2_thumbnail.png
-PrusaSlicer/resources/profiles/PrusaResearch/MK2.5SMMU2S_thumbnail.png
-PrusaSlicer/resources/profiles/PrusaResearch/MK2.5S_thumbnail.png
-PrusaSlicer/resources/profiles/PrusaResearch/MK2.5_thumbnail.png
-PrusaSlicer/resources/profiles/PrusaResearch/MK2SMM_thumbnail.png
-PrusaSlicer/resources/profiles/PrusaResearch/MK2S_thumbnail.png
-PrusaSlicer/resources/profiles/PrusaResearch/MK3MMU2_thumbnail.png
-PrusaSlicer/resources/profiles/PrusaResearch/MK3SMMU2S_thumbnail.png
-PrusaSlicer/resources/profiles/PrusaResearch/MK3S_thumbnail.png
-PrusaSlicer/resources/profiles/PrusaResearch/MK3_thumbnail.png
-PrusaSlicer/resources/profiles/PrusaResearch/SL1_thumbnail.png
-PrusaSlicer/resources/profiles/PrusaResearch/mini.svg
-PrusaSlicer/resources/profiles/PrusaResearch/mini_bed.stl
-PrusaSlicer/resources/profiles/PrusaResearch/mk2.svg
-PrusaSlicer/resources/profiles/PrusaResearch/mk2_bed.stl
-PrusaSlicer/resources/profiles/PrusaResearch/mk3.svg
-PrusaSlicer/resources/profiles/PrusaResearch/mk3_bed.stl
-PrusaSlicer/resources/profiles/PrusaResearch/sl1.svg
-PrusaSlicer/resources/profiles/PrusaResearch/sl1_bed.stl
-PrusaSlicer/resources/shaders/gouraud.fs
-PrusaSlicer/resources/shaders/gouraud.vs
-PrusaSlicer/resources/shaders/printbed.fs
-PrusaSlicer/resources/shaders/printbed.vs
-PrusaSlicer/resources/shaders/variable_layer_height.fs
-PrusaSlicer/resources/shaders/variable_layer_height.vs
-PrusaSlicer/resources/udev/90-3dconnexion.rules
-PrusaSlicer/bin/prusa-slicer
+bin/prusa-gcodeviewer
+bin/prusa-slicer
+share/applications/PrusaGcodeviewer.desktop
+share/applications/PrusaSlicer.desktop