aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-05-08 19:46:52 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-05-08 19:48:14 +0000
commit19ba7830ef8ed3dd7f8486836c47ab919c30f37c (patch)
tree1f123c29a844dc318f3ffe10f476665341173482 /cad
parentb0e9f854a8bb6b4995332a09b0c9c6aa69a392a2 (diff)
downloadports-19ba7830ef8ed3dd7f8486836c47ab919c30f37c.tar.gz
ports-19ba7830ef8ed3dd7f8486836c47ab919c30f37c.zip
cad/horizon-eda: Fix build failures
clang-13 crashes on this port. Bring back the rule that it builds with clang-12. Reported by: fallout
Diffstat (limited to 'cad')
-rw-r--r--cad/horizon-eda/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/cad/horizon-eda/Makefile b/cad/horizon-eda/Makefile
index a09a1df10c92..32b9f386943f 100644
--- a/cad/horizon-eda/Makefile
+++ b/cad/horizon-eda/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libzip.so:archivers/libzip \
libzmq.so:net/libzmq4
-USES= compiler:c++17-lang gmake gnome libarchive localbase pkgconfig python:build sqlite
+USES= gmake gnome libarchive localbase pkgconfig python:build sqlite # compiler:c++17-lang
USE_GNOME= atkmm gdkpixbuf2 gtkmm30 librsvg2
USE_GITHUB= yes
@@ -33,6 +33,12 @@ MAKE_ARGS= DEBUGFLAGS= OPTIMIZE=
BINARY_ALIAS= python3=${PYTHON_CMD}
+LLVM_VER= 12 # workaround for bug#263870
+BUILD_DEPENDS+= clang${LLVM_VER}:devel/llvm${LLVM_VER}
+CPP= clang-cpp${LLVM_VER}
+CC= clang${LLVM_VER}
+CXX= clang++${LLVM_VER}
+
post-install: # https://github.com/horizon-eda/horizon/issues/558
@cd ${STAGEDIR}${PREFIX}/bin && ${STRIP_CMD} horizon-eda horizon-imp