aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-06-18 09:17:59 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-06-18 09:17:59 +0000
commit5ea5235d7908c8e7f08aafa5e06e0074e407a830 (patch)
treea349782d1998f3a0def84e18bc61832977229fa1 /cad
parentd3a92693cd3b1bc9d881f590fe3aaeab60251f0e (diff)
downloadports-5ea5235d7908c8e7f08aafa5e06e0074e407a830.tar.gz
ports-5ea5235d7908c8e7f08aafa5e06e0074e407a830.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/salome-gui/files/patch-GUI_check_vtk.m466
-rw-r--r--cad/salome/Makefile.ext3
2 files changed, 65 insertions, 4 deletions
diff --git a/cad/salome-gui/files/patch-GUI_check_vtk.m4 b/cad/salome-gui/files/patch-GUI_check_vtk.m4
index 82723c41f18e..bd3ebeaa48e4 100644
--- a/cad/salome-gui/files/patch-GUI_check_vtk.m4
+++ b/cad/salome-gui/files/patch-GUI_check_vtk.m4
@@ -1,6 +1,6 @@
---- adm_local/unix/config_files/check_vtk.m4.orig 2009-08-15 21:43:12.000000000 +0700
-+++ adm_local/unix/config_files/check_vtk.m4 2009-08-15 21:43:20.000000000 +0700
-@@ -91,7 +91,7 @@
+--- adm_local/unix/config_files/check_vtk.m4.orig 2009-12-01 20:59:03.000000000 +0600
++++ adm_local/unix/config_files/check_vtk.m4 2010-06-18 14:18:42.000000000 +0700
+@@ -94,18 +94,18 @@
if test -z $vtk_suffix ; then
vtk_suffix="yes"
fi
@@ -9,3 +9,63 @@
dnl in case user wrote --with-vtk-version=no, use empty suffix
vtk_suffix=""
fi
+-if test "x$vtk_suffix" != "xyes" ; then
+- VTKSUFFIX="$vtk_suffix"
+-else
+- dnl in case user wrote --with-vtk-version=yes, get the suffix from env
+- if test -z $VTKSUFFIX ; then
+- VTKSUFFIX="-5.0"
+- fi
+-fi
++#if test "x$vtk_suffix" != "xyes" ; then
++# VTKSUFFIX="$vtk_suffix"
++#else
++# dnl in case user wrote --with-vtk-version=yes, get the suffix from env
++# if test -z $VTKSUFFIX ; then
++# VTKSUFFIX="-5.0"
++# fi
++#fi
+
+ dnl VTK install dir
+ if test -z $with_vtk ; then
+@@ -121,9 +121,9 @@
+ AC_MSG_WARN(Value "no", specified for option --with-vtk, is not supported)
+ fi
+
+-if test "x$with_vtk" != "x" ; then
+- VTKHOME="$with_vtk"
+-else
++#if test "x$with_vtk" != "x" ; then
++# VTKHOME="$with_vtk"
++#else
+ if test -z $VTKHOME ; then
+ AC_MSG_WARN(undefined VTKHOME variable which specify where vtk was compiled)
+ for d in /usr/local /usr ; do
+@@ -144,6 +144,18 @@
+ VTKSUFFIX="-5.2"
+ break
+ fi
++ if test -f ${d}/include/vtk-5.4/vtkPlane.h ; then
++ AC_MSG_RESULT(trying ${d})
++ VTKHOME="${d}"
++ VTKSUFFIX="-5.4"
++ break
++ fi
++ if test -f ${d}/include/vtk-5.6/vtkPlane.h ; then
++ AC_MSG_RESULT(trying ${d})
++ VTKHOME="${d}"
++ VTKSUFFIX="-5.6"
++ break
++ fi
+ if test -f ${d}/include/vtk/vtkPlane.h ; then
+ AC_MSG_RESULT(trying ${d})
+ VTKHOME="${d}"
+@@ -152,7 +164,7 @@
+ fi
+ done
+ fi
+-fi
++#fi
+
+ # Using regular VTK installation
+ if test "x$with_paraview" = "x" ; then
diff --git a/cad/salome/Makefile.ext b/cad/salome/Makefile.ext
index ae93fa37b7d9..18ab2b405355 100644
--- a/cad/salome/Makefile.ext
+++ b/cad/salome/Makefile.ext
@@ -164,7 +164,8 @@ CONFIGURE_ARGS+= --with-qsci4-libraries=${QT_LIBDIR} --with-qsci4-includes=${QT_
#Dependency from vtk
.if !${SAL_MODULE} == "kernel" && !${SAL_MODULE} == "randomizer"
LIB_DEPENDS+= vtkCommon.5:${PORTSDIR}/math/vtk5
-CONFIGURE_ENV+= VTKHOME=${LOCALBASE} VTKSUFFIX=-5.4
+CONFIGURE_ARGS+= --with-vtk=${LOCALBASE}
+#CONFIGURE_ENV+= VTKHOME=${LOCALBASE}
.endif
#Dependency from qwt5