aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /cad
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'cad')
-rw-r--r--cad/brlcad/Makefile3
-rw-r--r--cad/geda-gattrib/Makefile4
-rw-r--r--cad/geda-gschem/Makefile4
-rw-r--r--cad/geda-netlist/Makefile4
-rw-r--r--cad/geda-symbols/Makefile4
-rw-r--r--cad/geda-symcheck/Makefile4
-rw-r--r--cad/geda-utils/Makefile4
-rw-r--r--cad/gerbv/Makefile5
-rw-r--r--cad/gwave/Makefile4
-rw-r--r--cad/irsim/Makefile2
-rw-r--r--cad/libgeda/Makefile4
-rw-r--r--cad/magic/Makefile5
-rw-r--r--cad/netgen/Makefile1
-rw-r--r--cad/opencascade-tutorial/Makefile2
-rw-r--r--cad/opencascade/Makefile5
-rw-r--r--cad/pcb/Makefile6
-rw-r--r--cad/salome/Makefile.ext2
17 files changed, 30 insertions, 33 deletions
diff --git a/cad/brlcad/Makefile b/cad/brlcad/Makefile
index 61d82fee7658..751c0e4831c5 100644
--- a/cad/brlcad/Makefile
+++ b/cad/brlcad/Makefile
@@ -34,8 +34,7 @@ USE_GNOME= gnomehack
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.5\
-I${LOCALBASE}/include/tk8.5 -I${LOCALBASE}/include/tnt
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
- TKINCDIR=${LOCALBASE}/include/tk8.5
+CONFIGURE_ENV+= TKINCDIR=${LOCALBASE}/include/tk8.5
CONFIGURE_ARGS+=--with-libs="-lpng ${EXTRA_LIBS}" --program-transform-name="" \
--x-includes=${LOCALBASE}/include --x-libraries=${LOCALBASE}/libs \
--disable-jove-build --disable-strict-build --disable-warnings \
diff --git a/cad/geda-gattrib/Makefile b/cad/geda-gattrib/Makefile
index 16a6e27adad4..2b4692b58bae 100644
--- a/cad/geda-gattrib/Makefile
+++ b/cad/geda-gattrib/Makefile
@@ -30,8 +30,8 @@ USE_GMAKE= yes
INSTALLS_ICONS= yes
CONFIGURE_ARGS= --with-docdir="${DOCSDIR}" --disable-update-mime-database \
--disable-update-desktop-database
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
diff --git a/cad/geda-gschem/Makefile b/cad/geda-gschem/Makefile
index d7610d245772..8a687d3025ef 100644
--- a/cad/geda-gschem/Makefile
+++ b/cad/geda-gschem/Makefile
@@ -31,8 +31,8 @@ INSTALLS_ICONS= yes
CONFIGURE_ARGS= --enable-gdgeda --with-docdir=${DOCSDIR} \
--disable-update-mime-database \
--disable-update-desktop-database
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= gschem.1
diff --git a/cad/geda-netlist/Makefile b/cad/geda-netlist/Makefile
index bfaddace1a3d..725adfb549f9 100644
--- a/cad/geda-netlist/Makefile
+++ b/cad/geda-netlist/Makefile
@@ -27,8 +27,8 @@ DOCSDIR= ${PREFIX}/share/doc/geda
GNU_CONFIGURE= yes
USE_GNOME= gtk20
CONFIGURE_ARGS= --with-docdir=${DOCSDIR}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= gnetlist.1
diff --git a/cad/geda-symbols/Makefile b/cad/geda-symbols/Makefile
index 8c2e9cbb0830..dec427e0d850 100644
--- a/cad/geda-symbols/Makefile
+++ b/cad/geda-symbols/Makefile
@@ -22,8 +22,8 @@ DOCSDIR= ${PREFIX}/share/doc/geda
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-docdir=${DOCSDIR}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -E \
diff --git a/cad/geda-symcheck/Makefile b/cad/geda-symcheck/Makefile
index cea6d790b9b3..bdd264420196 100644
--- a/cad/geda-symcheck/Makefile
+++ b/cad/geda-symcheck/Makefile
@@ -27,8 +27,8 @@ DATADIR= ${PREFIX}/share/geda
GNU_CONFIGURE= yes
USE_GNOME= gtk20
CONFIGURE_ARGS= --with-docdir=${DOCSDIR}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= gsymcheck.1
diff --git a/cad/geda-utils/Makefile b/cad/geda-utils/Makefile
index d50982819ac0..7b5f22f8ca6d 100644
--- a/cad/geda-utils/Makefile
+++ b/cad/geda-utils/Makefile
@@ -30,8 +30,8 @@ USE_GNOME= gtk20
USE_PERL5_RUN= yes
USE_PYTHON_RUN= yes
CONFIGURE_ARGS= --with-docdir=${DOCSDIR}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= grenum.1
diff --git a/cad/gerbv/Makefile b/cad/gerbv/Makefile
index f8f5df45803e..2c7424817f2a 100644
--- a/cad/gerbv/Makefile
+++ b/cad/gerbv/Makefile
@@ -19,7 +19,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_GNOME= desktopfileutils gnomehack gtk20
USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
@@ -27,8 +26,8 @@ PLIST_SUB= VERSION="${PORTVERSION}"
MAN1= gerbv.1
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s|desktop||g' ${WRKSRC}/Makefile.in
diff --git a/cad/gwave/Makefile b/cad/gwave/Makefile
index af82d22b5e01..7bc867d98029 100644
--- a/cad/gwave/Makefile
+++ b/cad/gwave/Makefile
@@ -20,8 +20,8 @@ LIB_DEPENDS= guile.21:${PORTSDIR}/lang/guile \
USE_GNOME= gtk12
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
OPTIONS= PLOTUTILS "Use GNU plotutils for plotting" off \
GNUPLOT "Use gnuplot for plotting" on \
diff --git a/cad/irsim/Makefile b/cad/irsim/Makefile
index edfccb701ac1..2fbf79fc6fd0 100644
--- a/cad/irsim/Makefile
+++ b/cad/irsim/Makefile
@@ -22,7 +22,7 @@ CONFIGURE_WRKSRC= ${WRKSRC}/scripts/
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= PIC_CFLAGS="-fpic" LDFLAGS="${LDFLAGS}" \
+CONFIGURE_ENV+= PIC_CFLAGS="-fpic" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
OPTIONS= SCHEME "Enable built-in Scheme interpreter" on \
diff --git a/cad/libgeda/Makefile b/cad/libgeda/Makefile
index fdc1361c5956..4b0f60498bac 100644
--- a/cad/libgeda/Makefile
+++ b/cad/libgeda/Makefile
@@ -25,8 +25,8 @@ USE_GNOME= gtk20 gnomehack
USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-update-mime-database \
--disable-update-desktop-database
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
diff --git a/cad/magic/Makefile b/cad/magic/Makefile
index 2d90d6fc83f1..c9a2fd274cb6 100644
--- a/cad/magic/Makefile
+++ b/cad/magic/Makefile
@@ -27,7 +27,6 @@ USE_TCL= yes
USE_TK= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} --with-tk=${TK_LIBDIR}
ALL_TARGET= tcllibrary
MAKE_JOBS_UNSAFE=yes
@@ -36,8 +35,8 @@ MAN1= ext2sim.1 ext2spice.1 extcheck.1 magic.1
MAN5= cmap.5 displays.5 dlys.5 dstyle.5 ext.5 glyphs.5 mag.5 \
net.5 sim.5
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
diff --git a/cad/netgen/Makefile b/cad/netgen/Makefile
index ffbcffb1421c..d0d1e7cfd986 100644
--- a/cad/netgen/Makefile
+++ b/cad/netgen/Makefile
@@ -27,7 +27,6 @@ USE_XORG= xmu xi
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR} -I${TK_LIBDIR}/Togl-1.7
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
CONFIGURE_ARGS+= --with-tcl=${TCL_LIBDIR} --with-tk=${TK_LIBDIR} --enable-jpeglib
FETCH_BEFORE_ARGS+= -o ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}
diff --git a/cad/opencascade-tutorial/Makefile b/cad/opencascade-tutorial/Makefile
index 6bd797865167..7c6b4c96ff12 100644
--- a/cad/opencascade-tutorial/Makefile
+++ b/cad/opencascade-tutorial/Makefile
@@ -30,7 +30,7 @@ CONFIGURE_ARGS= --with-gl-include=${LOCALBASE}/include \
--with-qt-dir=${QTDIR} \
--enable-qt-mt \
--with-cascade-dir=${CASROOT}
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
+LDFLAGS+= ${PTHREAD_LIBS}
WRKSRC= ${WRKDIR}/opencascade-${PORTVERSION}/samples/tutorial
CONFIGURE_LOG= adm/${OPSYS}/config.log
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index b19a6c0e4551..b6a1cc3987a4 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -65,8 +65,9 @@ CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
--with-stlport-libname=stlport_${STL_COMPILER} \
--with-stlport-library=${LOCALBASE}/lib \
--enable-production=yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} ${GCC4WA} -I${LOCALBASE}/include \
- -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}" ARCH=${ARCH} LD=${CXX}
+CONFIGURE_ENV= ARCH=${ARCH} LD=${CXX}
+CPPFLAGS+= ${CXXFLAGS} ${GCC4WA} -I${LOCALBASE}/include \
+ -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}
# We strip the libs
MAKE_ENV= INSTALL_STRIP_FLAG=-s OCC_BUILDDIR="${PATCH_WRKSRC}" \
OCC_INSTALLDIR="${OCCROOT}" PTHREAD_LIBS="${PTHREAD_LIBS}" LD=${CXX}
diff --git a/cad/pcb/Makefile b/cad/pcb/Makefile
index aa486d118846..d2edcaaa24d9 100644
--- a/cad/pcb/Makefile
+++ b/cad/pcb/Makefile
@@ -24,9 +24,9 @@ USE_AUTOTOOLS= autoconf
USE_GMAKE= yes
USE_TK_RUN= 83
INSTALLS_ICONS= yes
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib" \
- INSTALL_DATA="/usr/bin/install ${COPY} ${_SHROWNGRP} -m ${SHAREMODE}"
+CONFIGURE_ENV+= INSTALL_DATA="/usr/bin/install ${COPY} ${_SHROWNGRP} -m ${SHAREMODE}"
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
CONFIGURE_ARGS= --docdir=${DOCSDIR} --disable-nls
PORTDOCS= pcb.html pcb.ps refcard.ps pcb.pdf refcard.pdf pad.gif \
puller.gif thermal.gif pad.png puller.png thermal.png examples \
diff --git a/cad/salome/Makefile.ext b/cad/salome/Makefile.ext
index 420b57caa2b2..f7fd798c60f3 100644
--- a/cad/salome/Makefile.ext
+++ b/cad/salome/Makefile.ext
@@ -292,7 +292,7 @@ PLIST_SUB+= MPI="@comment "
.endif
.endif
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" CXXFLAGS="${QSCIFLAGS} ${QTFLAGS} ${CXXFLAGS} " CPPFLAGS="${CPPFLAGS}"
+CXXFLAGS+= ${QSCIFLAGS} ${QTFLAGS}
.include <bsd.port.pre.mk>