aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-10-21 14:31:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-10-21 19:21:52 +0000
commit9f02903fc610e0ee6355d351d75c201b213e0abe (patch)
tree69c20be5da402e32b01e8e2f024afb5246126d47 /cad
parentd8d23f866b81fd543e56be5d76e0ebfc0001f73a (diff)
downloadports-9f02903fc610e0ee6355d351d75c201b213e0abe.tar.gz
ports-9f02903fc610e0ee6355d351d75c201b213e0abe.zip
Diffstat (limited to 'cad')
-rw-r--r--cad/appcsxcad/Makefile7
-rw-r--r--cad/csxcad/Makefile7
-rw-r--r--cad/opencascade/Makefile9
-rw-r--r--cad/qcsxcad/Makefile7
4 files changed, 16 insertions, 14 deletions
diff --git a/cad/appcsxcad/Makefile b/cad/appcsxcad/Makefile
index eeacd1ff5ed4..391abcce4447 100644
--- a/cad/appcsxcad/Makefile
+++ b/cad/appcsxcad/Makefile
@@ -2,7 +2,7 @@ PORTNAME= appcsxcad
DISTVERSIONPREFIX= v
DISTVERSION= 0.2.2-9
DISTVERSIONSUFFIX= -g97ba30e
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= cad
MAINTAINER= yuri@FreeBSD.org
@@ -20,7 +20,7 @@ LIB_DEPENDS= libCSXCAD.so:cad/csxcad \
libQCSXCAD.so:cad/qcsxcad \
libsz.so:science/libaec \
libtiff.so:graphics/tiff \
- libvtkCommonCore-9.1.so:math/vtk9
+ libvtkCommonCore-${VTK_VER}.so:math/vtk9
USES= cmake jpeg pkgconfig qt:5 xorg
USE_QT= core gui sql widgets xml buildtools:build qmake:build
@@ -31,7 +31,7 @@ USE_GITHUB= yes
GH_ACCOUNT= thliebig
GH_PROJECT= AppCSXCAD
-CMAKE_ARGS= -DVTK_DIR=${LOCALBASE}/lib/cmake/vtk-9.1
+CMAKE_ARGS= -DVTK_DIR=${LOCALBASE}/lib/cmake/vtk-${VTK_VER}
PLIST_FILES= bin/AppCSXCAD
@@ -40,4 +40,5 @@ post-install:
# an example of file that AppCSXCAD opens (zipped): http://openems.de/forum/download/file.php?id=418&sid=6daebbb2df72b415fa2ec7031ffa6ca9
+.include <../../math/vtk9/Makefile.version>
.include <bsd.port.mk>
diff --git a/cad/csxcad/Makefile b/cad/csxcad/Makefile
index 4c2563b0c173..55b3091b7edf 100644
--- a/cad/csxcad/Makefile
+++ b/cad/csxcad/Makefile
@@ -2,7 +2,7 @@ PORTNAME= csxcad
DISTVERSIONPREFIX= v
DISTVERSION= 0.6.2-109
DISTVERSIONSUFFIX= -gcd9decb
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= cad
MAINTAINER= yuri@FreeBSD.org
@@ -22,7 +22,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libsz.so:science/libaec \
libtiff.so:graphics/tiff \
libtinyxml.so:textproc/tinyxml \
- libvtkCommonCore-9.1.so:math/vtk9
+ libvtkCommonCore-${VTK_VER}.so:math/vtk9
USES= cmake jpeg pkgconfig
USE_LDCONFIG= yes
@@ -32,6 +32,7 @@ GH_ACCOUNT= thliebig
GH_PROJECT= ${PORTNAME:tu}
CMAKE_ARGS= -DFPARSER_ROOT_DIR=${LOCALBASE} \
- -DVTK_DIR=${LOCALBASE}/lib/cmake/vtk-9.1
+ -DVTK_DIR=${LOCALBASE}/lib/cmake/vtk-${VTK_VER}
+.include <../../math/vtk9/Makefile.version>
.include <bsd.port.mk>
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index 0ff44d1e1b94..d10b1d6a1967 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -1,6 +1,6 @@
PORTNAME= opencascade
PORTVERSION= 7.6.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= cad science
MASTER_SITES= LOCAL/thierry
@@ -20,7 +20,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libexpat.so:textproc/expat2 \
libpng16.so:graphics/png \
- libvtksys-${VTKVER}.so:math/vtk${VTKVER:R}
+ libvtksys-${VTK_VER}.so:math/vtk${VTK_VER:R}
RUN_DEPENDS= bash:shells/bash
# Check ${WRKSRC}/dox/overview/overview.md
@@ -40,8 +40,6 @@ SHEBANG_FILES= adm/templates/*.sh \
gendoc
ENVSH= adm/templates/env.sh
-VTKVER= 9.1
-
OPTIONS_DEFINE= DOCS DOXYGEN FFMPEG VIS
VIS_DESC= Build Visualizazion module (requires OpenGL, freetype, ftgl)
OPTIONS_DEFAULT=FFMPEG VIS
@@ -62,7 +60,7 @@ CMAKE_ARGS+= -DINSTALL_DIR=${OCCROOT} \
-DUSE_TBB:BOOL=OFF \
-DUSE_RAPIDJSON:BOOL=ON \
-DUSE_VTK:BOOL=ON \
- -D3RDPARTY_VTK_INCLUDE_DIR:PATH=${LOCALBASE}/include/vtk-${VTKVER}
+ -D3RDPARTY_VTK_INCLUDE_DIR:PATH=${LOCALBASE}/include/vtk-${VTK_VER}
CONFIGURE_ENV+= DESTDIR=${STAGEDIR}
.if defined(MAINTAINER_MODE)
@@ -181,4 +179,5 @@ regression-test: install
DRAWEXE -f ${FILESDIR}/regtest "
.endif
+.include <../../math/vtk9/Makefile.version>
.include <bsd.port.mk>
diff --git a/cad/qcsxcad/Makefile b/cad/qcsxcad/Makefile
index 8fc566507178..2ac32b0d67bc 100644
--- a/cad/qcsxcad/Makefile
+++ b/cad/qcsxcad/Makefile
@@ -1,7 +1,7 @@
PORTNAME= qcsxcad
DISTVERSIONPREFIX= v
DISTVERSION= 0.6.2-9
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONSUFFIX= -g3f09a8b
CATEGORIES= cad
@@ -18,7 +18,7 @@ LIB_DEPENDS= libCSXCAD.so:cad/csxcad \
libpng16.so:graphics/png \
libtiff.so:graphics/tiff \
libtinyxml.so:textproc/tinyxml \
- libvtkCommonCore-9.1.so:math/vtk9
+ libvtkCommonCore-${VTK_VER}.so:math/vtk9
USES= cmake gl jpeg pkgconfig qt:5 xorg
USE_QT= core gui opengl sql widgets xml buildtools:build qmake:build
@@ -30,6 +30,7 @@ USE_GITHUB= yes
GH_ACCOUNT= thliebig
GH_PROJECT= ${PORTNAME:tu}
-CMAKE_ARGS= -DVTK_DIR=${LOCALBASE}/lib/cmake/vtk-9.1
+CMAKE_ARGS= -DVTK_DIR=${LOCALBASE}/lib/cmake/vtk-${VTK_VER}
+.include <../../math/vtk9/Makefile.version>
.include <bsd.port.mk>