aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-07-04 16:55:16 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-07-04 16:55:16 +0000
commitbe86c4fe23e089aeef1ed7467161c2ce321a8c81 (patch)
treeeebf8f5b9a2bc359ffda39b2eac6fa88f6345545 /cad
parent066b4db9b1ddaadd5fb0c7076733998f810dcda8 (diff)
downloadports-be86c4fe23e089aeef1ed7467161c2ce321a8c81.tar.gz
ports-be86c4fe23e089aeef1ed7467161c2ce321a8c81.zip
misc/qtchooser: remove
QtChooser allows you to select your version of Qt among those installed. However, this tool is no longer supported upstream and will not be available for Qt6. By default, our Qt installations are done in ${LOCALBASE}/lib/qt${QT_VERSION} as recommended. We have added symbolic linking for the main binaries to ${LOCALBASE}/bin with the suffix -qt5.
Diffstat (limited to 'cad')
-rw-r--r--cad/freecad/Makefile13
-rw-r--r--cad/ldview/Makefile4
2 files changed, 9 insertions, 8 deletions
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index c173b88dde18..c4e79075928c 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -1,6 +1,6 @@
PORTNAME= FreeCAD
DISTVERSION= 0.19.2
-PORTREVISION= 1
+PORTREVISION= 2
# use these for bugfixes/snapshots
# DISTVERSION= 0.18-16093 # git rev-list --count
# DISTVERSIONSUFFIX= -g690774c0e
@@ -12,7 +12,7 @@ COMMENT= General purpose 3D CAD modeller
LICENSE= LGPL20+
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyside2-tools>5.14.0:devel/pyside2-tools@${PY_FLAVOR} \
+BUILD_DEPENDS= pyside_tool.py:devel/pyside2-tools@${PY_FLAVOR} \
${PYTHON_SITELIBDIR}/matplotlib/__init__.py:math/py-matplotlib@${PY_FLAVOR} \
swig:devel/swig
LIB_DEPENDS= libexpat.so:textproc/expat2 \
@@ -34,7 +34,7 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pivy>0:graphics/py-pivy@${PY_FLAVOR} \
${PYTHON_SITELIBDIR}/matplotlib/__init__.py:math/py-matplotlib@${PY_FLAVOR}
-USES= dos2unix compiler:c++11-lib cmake gl eigen:3 fortran jpeg \
+USES= dos2unix compiler:c++17-lang cmake gl eigen:3 fortran jpeg \
localbase:ldflags pkgconfig python:3.7+ localbase qt:5 xorg
USE_GITHUB= yes
USE_XORG= ice sm x11 xext xt
@@ -53,9 +53,10 @@ CMAKE_ARGS+= -DOCC_INCLUDE_DIR="${LOCALBASE}/include/OpenCASCADE" \
-DPYTHON_PACKAGES_PATH="${PYTHON_SITELIBDIR}" \
-DPYTHON_EXECUTABLE="${PYTHON_CMD}" \
-DBUILD_ASSEMBLY="OFF" -DBUILD_FLAT_MESH="ON" \
- -DPYSIDE2RCCBINARY="${LOCALBASE}/bin/rcc" \
- -DPYSIDE2UICBINARY="${LOCALBASE}/bin/uic" \
- -DVTK_DIR:PATH=${LOCALBASE}/lib/vtk-8.2/cmake/vtk-8.2
+ -DPYSIDE2RCCBINARY="${RCC}" \
+ -DPYSIDE2UICBINARY="${UIC}" \
+ -DVTK_DIR:PATH=${LOCALBASE}/lib/vtk-8.2/cmake/vtk-8.2 \
+ -DBUILD_ENABLE_CXX_STD=C++17
CMAKE_INSTALL_PREFIX= ${PREFIX}/${PORTNAME}
diff --git a/cad/ldview/Makefile b/cad/ldview/Makefile
index 28a3d9d945fa..5744c75da92b 100644
--- a/cad/ldview/Makefile
+++ b/cad/ldview/Makefile
@@ -1,7 +1,7 @@
PORTNAME= ldview
DISTVERSIONPREFIX= v
DISTVERSION= 4.4_Beta5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= cad
MAINTAINER= yuri@FreeBSD.org
@@ -36,7 +36,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|"/usr/share/ldraw"|"${PREFIX}/share/ldraw"|' ${WRKSRC}/ModelViewerWidget.cpp
pre-configure:
- @cd ${WRKSRC} && lrelease LDView.pro
+ @cd ${WRKSRC} && ${LRELEASE} LDView.pro
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/LDView