aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-06-17 18:17:45 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-06-17 18:17:45 +0000
commitcb333cf1eccb98899b1700ca42a800ab92697fa4 (patch)
tree7f623e7c3f52defb4424cb7124504b8d4e77d35c /cad
parente2a5e08ce3f52f8bff9eb487e88342c0ec9fff81 (diff)
downloadports-cb333cf1eccb98899b1700ca42a800ab92697fa4.tar.gz
ports-cb333cf1eccb98899b1700ca42a800ab92697fa4.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/freecad/Makefile2
-rw-r--r--cad/kicad-devel/Makefile2
-rw-r--r--cad/kicad/Makefile2
-rw-r--r--cad/opensta/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index 526f2a20363a..abc0f2ecdd67 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyside2-tools>5.14.0:devel/pyside2-tools@${PY_FLAVOR} \
${PYTHON_SITELIBDIR}/matplotlib/__init__.py:math/py-matplotlib@${PY_FLAVOR} \
- swig3.0:devel/swig30
+ swig:devel/swig
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libfreetype.so:print/freetype2 \
${PY_BOOST} \
diff --git a/cad/kicad-devel/Makefile b/cad/kicad-devel/Makefile
index 7303e4c00bf9..660a1938c5d6 100644
--- a/cad/kicad-devel/Makefile
+++ b/cad/kicad-devel/Makefile
@@ -14,7 +14,7 @@ COMMENT= Schematic and PCB editing software
LICENSE= GPLv3
BUILD_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:math/glm \
- ${LOCALBASE}/bin/swig3.0:devel/swig30
+ ${LOCALBASE}/bin/swig:devel/swig
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libngspice.so:cad/ngspice_rework@shlib \
libTKernel.so:cad/opencascade \
diff --git a/cad/kicad/Makefile b/cad/kicad/Makefile
index ae707cca7cea..66b6438339e2 100644
--- a/cad/kicad/Makefile
+++ b/cad/kicad/Makefile
@@ -13,7 +13,7 @@ COMMENT= Schematic and PCB editing software
LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:math/glm \
- swig3.0:devel/swig30
+ swig:devel/swig
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libngspice.so:cad/ngspice_rework@shlib \
libTKernel.so:cad/opencascade \
diff --git a/cad/opensta/Makefile b/cad/opensta/Makefile
index 9bc6d5589319..843a0e1bc905 100644
--- a/cad/opensta/Makefile
+++ b/cad/opensta/Makefile
@@ -10,7 +10,7 @@ COMMENT= Gate level static timing verifier
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= swig3.0:devel/swig30
+BUILD_DEPENDS= swig:devel/swig
LIB_DEPENDS= libcudd.so:math/cudd
USES= bison compiler:c++11-lang cmake tcl