aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-02-16 07:50:26 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-02-16 07:50:26 +0000
commitd3e94a211176c5ee49759362898e1ccd99289a3d (patch)
tree150b9ba36df6552e5f3e4ba8b242001aa1e4985d /cad
parent118fd42877f21f9ba5938402043be0cd2ae94ee6 (diff)
downloadports-d3e94a211176c5ee49759362898e1ccd99289a3d.tar.gz
ports-d3e94a211176c5ee49759362898e1ccd99289a3d.zip
cad/horizon-eda: Fix build with clang-11
Reported by: fallout
Notes
Notes: svn path=/head/; revision=565386
Diffstat (limited to 'cad')
-rw-r--r--cad/horizon-eda/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/cad/horizon-eda/Makefile b/cad/horizon-eda/Makefile
index 35fd5611a7f5..c0656c6f905c 100644
--- a/cad/horizon-eda/Makefile
+++ b/cad/horizon-eda/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libzip.so:archivers/libzip \
libzmq.so:net/libzmq4
-USES= compiler:c++17-lang gmake gnome localbase pkgconfig python:build sqlite
+USES= gmake gnome localbase pkgconfig python:build sqlite # compiler:c++17-lang
USE_GITHUB= yes
GH_PROJECT= horizon
USE_GNOME= atkmm gdkpixbuf2 gtkmm30 librsvg2
@@ -34,6 +34,12 @@ BINARY_ALIAS= python3=${PYTHON_CMD}
INSTALLS_ICONS= yes
+LLVM_VER= 10 # workaround for bug#253551
+BUILD_DEPENDS+= clang${LLVM_VER}:devel/llvm${LLVM_VER}
+CPP= clang-cpp${LLVM_VER}
+CC= clang${LLVM_VER}
+CXX= clang++${LLVM_VER}
+
post-install: # https://github.com/horizon-eda/horizon/issues/558
cd ${STAGEDIR}${PREFIX}/bin && ${STRIP_CMD} horizon-eda