aboutsummaryrefslogtreecommitdiff
path: root/chinese/arphicttf/Makefile
diff options
context:
space:
mode:
authorJing-Tang Keith Jang <keith@FreeBSD.org>2000-12-04 12:59:39 +0000
committerJing-Tang Keith Jang <keith@FreeBSD.org>2000-12-04 12:59:39 +0000
commitf0fefed0d41dcd9935ca40d43f20b0a3c9226d5a (patch)
tree70a4b78b2506e21f854e8c2927f7511eddfcec4e /chinese/arphicttf/Makefile
parent19184ea11176949ff82aa62669ed379f045f6871 (diff)
downloadports-f0fefed0d41dcd9935ca40d43f20b0a3c9226d5a.tar.gz
ports-f0fefed0d41dcd9935ca40d43f20b0a3c9226d5a.zip
Notes
Diffstat (limited to 'chinese/arphicttf/Makefile')
-rw-r--r--chinese/arphicttf/Makefile33
1 files changed, 23 insertions, 10 deletions
diff --git a/chinese/arphicttf/Makefile b/chinese/arphicttf/Makefile
index 823156d87944..a5991ee67ad7 100644
--- a/chinese/arphicttf/Makefile
+++ b/chinese/arphicttf/Makefile
@@ -7,29 +7,42 @@
PORTNAME= arphicttf
PORTVERSION= 2.11
+PORTREVISION= 1
CATEGORIES= chinese x11-fonts
MASTER_SITES= ftp://freebsd.sinica.edu.tw/pub/keith/
-DISTNAME= ${PKGNAME}
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= keith@FreeBSD.org
-LIB_DEPENDS= font.1:${PORTSDIR}/x11-servers/XttXF86srv-common
+RUN_DEPENDS= ttfm.sh:${PORTSDIR}/chinese/ttfm
-USE_X_PREFIX= yes
+CJK?= NO
+GS6?= NO
+XTT?= YES
-NO_BUILD= yes
+NO_BUILD= YES
SHAREMODE= 644
WRKSRC= ${WRKDIR}/arphic
-FONTDIR= ${PREFIX}/lib/X11/fonts/TrueType
+USE_XLIB= YES
+FONTDIR= ${PREFIX}/share/fonts/TrueType
+XFONTDIR= ${X11BASE}/lib/X11/fonts/TrueType
+INSTALL_ENV= PKG_PREFIX=${PREFIX} CJK=${CJK} GS6=${GS6} XTT=${XTT} \
+ XFREE86_VERSION=${XFREE86_VERSION}
.include <bsd.port.pre.mk>
+.if ${CJK} != "NO"
+RUN_DEPENDS+= bg5latex:${PORTSDIR}/chinese/CJK
+.endif
+.if ${GS6} != "NO"
+RUN_DEPENDS+= ${LOCALBASE}/share/ghostscript/CJK/CMap/B5pc-H:${PORTSDIR}/chinese/ghostscript6
+.endif
+.if ${XFREE86_VERSION} == 3 && ${XTT} != "NO"
+RUN_DEPENDS+= mkfontdir.pl:${PORTSDIR}/x11-servers/XttXF86srv-common
+.endif
+
do-install:
.if !exists(${FONTDIR})
- @${ECHO} "========================================================="
- @${ECHO} "Please add ${FONTDIR} to your font path"
- @${ECHO} "in /etc/XF86Config."
- @${ECHO} "========================================================="
@${MKDIR} ${FONTDIR}
.endif
@${INSTALL_DATA} ${WRKSRC}/font/bkai00mp.ttf ${FONTDIR}
@@ -40,6 +53,6 @@ do-install:
@${MKDIR} ${FONTDIR}/arphic
@${CP} -fr ${WRKSRC}/license ${FONTDIR}/arphic
@${CP} -f ${WRKSRC}/logo.gif ${WRKSRC}/release.txt ${FONTDIR}/arphic
- @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${SETENV} ${INSTALL_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.post.mk>